summaryrefslogtreecommitdiffstats
path: root/development/python3-hylang
diff options
context:
space:
mode:
author Lockywolf2023-12-03 09:46:30 +0100
committer Willy Sudiarto Raharjo2023-12-09 01:50:06 +0100
commit511c7f7e87dafb1fe998cfd8c25971a8a4735260 (patch)
treec6fe23a5dc1771eb30cd7e9ef1464a8b6019051b /development/python3-hylang
parentb51381e3160d7069d223c57c7f2c7be8269ab703 (diff)
downloadslackbuilds-511c7f7e87dafb1fe998cfd8c25971a8a4735260.tar.gz
development/python3-hylang: Added (lisp dialect).
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/python3-hylang')
-rw-r--r--development/python3-hylang/README11
-rw-r--r--development/python3-hylang/python3-hylang.SlackBuild111
-rw-r--r--development/python3-hylang/python3-hylang.info10
-rw-r--r--development/python3-hylang/slack-desc19
4 files changed, 151 insertions, 0 deletions
diff --git a/development/python3-hylang/README b/development/python3-hylang/README
new file mode 100644
index 0000000000..e231b83af7
--- /dev/null
+++ b/development/python3-hylang/README
@@ -0,0 +1,11 @@
+Hy is a Lisp dialect that's embedded in Python.
+
+Hy (or "Hylang" for long) is a multi-paradigm general-purpose
+programming language in the Lisp family. It's implemented as a kind of
+alternative syntax for Python. Compared to Python, Hy offers a variety
+of extra features, generalizations, and syntactic simplifications, as
+would be expected of a Lisp. Compared to other Lisps, Hy provides direct
+access to Python's built-ins and third-party Python libraries, while
+allowing you to freely mix imperative, functional, and object-oriented
+styles of programming.
+
diff --git a/development/python3-hylang/python3-hylang.SlackBuild b/development/python3-hylang/python3-hylang.SlackBuild
new file mode 100644
index 0000000000..8afd062cad
--- /dev/null
+++ b/development/python3-hylang/python3-hylang.SlackBuild
@@ -0,0 +1,111 @@
+#!/bin/bash
+
+# Slackware build script for python3-hylang
+
+# Copyright 2023, Lockywolf
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-hylang
+TARNAM=hy
+VERSION=${VERSION:-0.27.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+
+rm -rf $TARNAM-$VERSION
+tar xvf $CWD/$TARNAM-$VERSION.tar.gz
+cd $TARNAM-$VERSION
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+rm -rf $PKG/usr/get_version
+rm $PKG/usr/lib${LIBDIRSUFFIX}/python3.9/site-packages/hy/core/__pycache__/util.cpython-39.pyc
+rm $PKG/usr/lib${LIBDIRSUFFIX}/python3.9/site-packages/hy/core/__pycache__/macros.cpython-39.pyc
+rm $PKG/usr/lib${LIBDIRSUFFIX}/python3.9/site-packages/hy/core/__pycache__/hy_repr.cpython-39.pyc
+rm $PKG/usr/lib${LIBDIRSUFFIX}/python3.9/site-packages/hy/__pycache__/reserved.cpython-39.pyc
+rm $PKG/usr/lib${LIBDIRSUFFIX}/python3.9/site-packages/hy/__pycache__/pyops.cpython-39.pyc
+
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS LICENSE NEWS.rst README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/python3-hylang/python3-hylang.info b/development/python3-hylang/python3-hylang.info
new file mode 100644
index 0000000000..9dae1aaab4
--- /dev/null
+++ b/development/python3-hylang/python3-hylang.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-hylang"
+VERSION="0.27.0"
+HOMEPAGE="https://hylang.org/"
+DOWNLOAD="https://files.pythonhosted.org/packages/93/5a/47276218f7419e134c659061150aeae2bdd80d7cfbb814447b466b59d546/hy-0.27.0.tar.gz"
+MD5SUM="2da29402d1b560767e4bb55bd614e263"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-funcparserlib"
+MAINTAINER="Lockywolf"
+EMAIL="for_sbo.python3-hylang_2023-12-01@lockywolf.net"
diff --git a/development/python3-hylang/slack-desc b/development/python3-hylang/slack-desc
new file mode 100644
index 0000000000..e25a31acb4
--- /dev/null
+++ b/development/python3-hylang/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-hylang: python3-hylang (Lisp dialect that's embedded in Python)
+python3-hylang:
+python3-hylang: Hy (or "Hylang" for long) is a multi-paradigm general-purpose
+python3-hylang: programming language in the Lisp family. It's implemented as a kind
+python3-hylang: of alternative syntax for Python. Compared to Python, Hy offers a
+python3-hylang: variety of extra features, generalizations, and syntactic
+python3-hylang: simplifications, as would be expected of a Lisp. Compared to other
+python3-hylang: Lisps, Hy provides direct access to Python's built-ins and
+python3-hylang: third-party Python libraries, while allowing you to freely mix
+python3-hylang: imperative, functional, and object-oriented styles of programming.
+python3-hylang: