summaryrefslogtreecommitdiffstats
path: root/development/pydblite
diff options
context:
space:
mode:
author LukenShiro2010-05-11 20:00:29 +0200
committer Robby Workman2010-05-11 20:00:29 +0200
commit7314adb536cdbe92bbfce38da69441d51e6cb524 (patch)
treecd7d5510c297aba0fdb4cf7b9ef508eedfadb6e3 /development/pydblite
parent2355ea2d11df34f70b8810b01cf843c0bd6b94e2 (diff)
downloadslackbuilds-7314adb536cdbe92bbfce38da69441d51e6cb524.tar.gz
development/pydblite: Added to 12.0 repository
Diffstat (limited to 'development/pydblite')
-rw-r--r--development/pydblite/README5
-rw-r--r--development/pydblite/pydblite.SlackBuild64
-rw-r--r--development/pydblite/pydblite.info8
-rw-r--r--development/pydblite/slack-desc19
4 files changed, 96 insertions, 0 deletions
diff --git a/development/pydblite/README b/development/pydblite/README
new file mode 100644
index 0000000000..d315119df5
--- /dev/null
+++ b/development/pydblite/README
@@ -0,0 +1,5 @@
+PyDbLite (small footprint untyped database engine in python)
+
+PyDbLite is a pure-Python in-memory database engine, using
+Python list comprehensions as query language instead of SQL,
+which stores data in a cPickled file.
diff --git a/development/pydblite/pydblite.SlackBuild b/development/pydblite/pydblite.SlackBuild
new file mode 100644
index 0000000000..8d1ac18a18
--- /dev/null
+++ b/development/pydblite/pydblite.SlackBuild
@@ -0,0 +1,64 @@
+#!/bin/sh
+
+# Slackware build script for pydblite
+
+# Copyright 2007 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pydblite
+SRC_PRGNAM=PyDbLite
+VERSION=2.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="LICENCE.txt PKG-INFO $SRC_PRGNAM/doc/index.html $SRC_PRGNAM/doc/index_fr.html"
+
+# SLKCFLAGS are not used
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRC_PRGNAM-$VERSION
+unzip $CWD/$SRC_PRGNAM-$VERSION.zip
+cd $SRC_PRGNAM-$VERSION
+#chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+# Install .py source files
+python setup.py build install --root=$PKG
+
+# Copy documentation files
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+install -m 644 $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/development/pydblite/pydblite.info b/development/pydblite/pydblite.info
new file mode 100644
index 0000000000..4c9d984efa
--- /dev/null
+++ b/development/pydblite/pydblite.info
@@ -0,0 +1,8 @@
+PRGNAM="pydblite"
+VERSION="2.1"
+HOMEPAGE="http://pydblite.sourceforge.net"
+DOWNLOAD="http://downloads.sourceforge.net/pydblite/PyDbLite-2.1.zip"
+MD5SUM="a9ae4fc68873d0d9641e06cdd3c24043"
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="rworkman"
diff --git a/development/pydblite/slack-desc b/development/pydblite/slack-desc
new file mode 100644
index 0000000000..aef7a48382
--- /dev/null
+++ b/development/pydblite/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pydblite: PyDbLite (small footprint untyped database engine in python)
+pydblite:
+pydblite: PyDbLite is a pure-Python in-memory database engine, using
+pydblite: Python list comprehensions as query language instead of SQL,
+pydblite: which stores data in a cPickled file.
+pydblite:
+pydblite: It is written by Pierre Quentel and released under BSD license.
+pydblite:
+pydblite: http://pydblite.sourceforge.net
+pydblite:
+pydblite: