summaryrefslogtreecommitdiffstats
path: root/development/protobuf3
diff options
context:
space:
mode:
author B. Watson2022-02-17 08:31:05 +0100
committer Willy Sudiarto Raharjo2022-02-19 06:09:24 +0100
commitdebcaa55c2683e9be28b32df85201bf57524ca6c (patch)
tree3a89ffdd675b3a006cb90a0a379aca7b8fea799d /development/protobuf3
parent4de44686ed59f59f81bcd3fc939416b2135e4b1e (diff)
downloadslackbuilds-debcaa55c2683e9be28b32df85201bf57524ca6c.tar.gz
misc/protobuf3: Moved to development/protobuf3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/protobuf3')
-rw-r--r--development/protobuf3/README27
-rw-r--r--development/protobuf3/protobuf3.SlackBuild124
-rw-r--r--development/protobuf3/protobuf3.info10
-rw-r--r--development/protobuf3/protobuf3.patch10
-rw-r--r--development/protobuf3/slack-desc19
5 files changed, 190 insertions, 0 deletions
diff --git a/development/protobuf3/README b/development/protobuf3/README
new file mode 100644
index 0000000000..c0fe34acc0
--- /dev/null
+++ b/development/protobuf3/README
@@ -0,0 +1,27 @@
+protobuf3 (Google's data interchange format)
+
+Protocol buffers are a flexible, efficient, automated mechanism for
+serializing structured data.
+
+This package contains protobuf API version 3.
+It support the following language implementations:
+* C++
+* Java
+* Python
+* Objective-C
+* C#
+* JavaNano
+* JavaScript
+* Ruby
+* Go
+* PHP (Alpha)
+
+The complete documentation for Protocol Buffers is available at:
+https://developers.google.com/protocol-buffers/
+
+Notes:
+* The protobuf build (API version 2) has been removed from
+ SlackBuilds.org, because nothing uses it any longer and it
+ conflicted with this build.
+* Protobuf3 enforces strict UTF-8 checking.
+ Parsing will fail if a string field contains non UTF-8 data.
diff --git a/development/protobuf3/protobuf3.SlackBuild b/development/protobuf3/protobuf3.SlackBuild
new file mode 100644
index 0000000000..3383ac3446
--- /dev/null
+++ b/development/protobuf3/protobuf3.SlackBuild
@@ -0,0 +1,124 @@
+#!/bin/bash
+
+# Slackware build script for protobuf3
+
+# Copyright 2017-2022 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=protobuf3
+VERSION=${VERSION:-3.19.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+GTEST=googletest-release
+GTESTVERSION=${GTESTVERSION:-1.8.1}
+
+SRCNAM=protobuf
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/protobuf3.patch
+
+./autogen.sh
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --disable-static \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --enable-static=no \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+# Install the python bindings
+cd python
+python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
+cd ..
+
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a BUILD *.txt LICENSE *.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/protobuf3/protobuf3.info b/development/protobuf3/protobuf3.info
new file mode 100644
index 0000000000..f7a0ae3432
--- /dev/null
+++ b/development/protobuf3/protobuf3.info
@@ -0,0 +1,10 @@
+PRGNAM="protobuf3"
+VERSION="3.19.4"
+HOMEPAGE="https://github.com/google/protobuf"
+DOWNLOAD="https://github.com/google/protobuf/archive/v3.19.4/protobuf-3.19.4.tar.gz"
+MD5SUM="ebaa4e04df3bffc2401a7ad47d32a90b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Willy Sudiarto Raharjo"
+EMAIL="willysr@slackbuilds.org"
diff --git a/development/protobuf3/protobuf3.patch b/development/protobuf3/protobuf3.patch
new file mode 100644
index 0000000000..a69862dd63
--- /dev/null
+++ b/development/protobuf3/protobuf3.patch
@@ -0,0 +1,10 @@
+--- protobuf-3.10.1/src/google/protobuf/text_format.h.orig 2019-10-13 10:42:21.345593616 +0700
++++ protobuf-3.10.1/src/google/protobuf/text_format.h 2019-10-13 10:42:34.151188015 +0700
+@@ -42,6 +42,7 @@
+ #include <memory>
+ #include <string>
+ #include <vector>
++#include <cmath>
+
+ #include <google/protobuf/stubs/common.h>
+ #include <google/protobuf/descriptor.h>
diff --git a/development/protobuf3/slack-desc b/development/protobuf3/slack-desc
new file mode 100644
index 0000000000..440a1c6d9a
--- /dev/null
+++ b/development/protobuf3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+protobuf3: protobuf3 (Google's data interchange format)
+protobuf3:
+protobuf3: Protocol Buffers are Google's language-neutral, platform-neutral,
+protobuf3: extensible mechanism for serializing structured data.
+protobuf3:
+protobuf3: This package contains protobuf API version 3.
+protobuf3:
+protobuf3:
+protobuf3: Project URL: https://github.com/google/protobuf
+protobuf3:
+protobuf3: