summaryrefslogtreecommitdiffstats
path: root/development/pforth
diff options
context:
space:
mode:
author B. Watson2022-03-18 21:50:16 +0100
committer Willy Sudiarto Raharjo2022-03-20 14:45:15 +0100
commit6f02c01e0658d3e1fcbaa3c41fa6dd20f5b785de (patch)
tree1238d654f24599aede1f1afeae1abc251b586189 /development/pforth
parentbcb93bfc01d957d65dc44d152170c79f03b381b2 (diff)
downloadslackbuilds-6f02c01e0658d3e1fcbaa3c41fa6dd20f5b785de.tar.gz
development/pforth: Fix 32-bit build.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/pforth')
-rw-r--r--development/pforth/pforth.SlackBuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/development/pforth/pforth.SlackBuild b/development/pforth/pforth.SlackBuild
index 66d6e97869..9f9dc70d48 100644
--- a/development/pforth/pforth.SlackBuild
+++ b/development/pforth/pforth.SlackBuild
@@ -1,10 +1,15 @@
#!/bin/bash
# Slackware build script for pforth
+# https://github.com/philburk/pforth
# Written by Zbigniew Baniewski, <Zbigniew [dot] Baniewski [at] gmail [dot] com>
# Modified by Willy Sudiarto Raharjo <willysr@slackware-id.org>
+# 20220318 bkw: Modified by SlackBuilds.org: fix build on 32-bit.
+# WARNING: the fix silences some compiler warnings that look like
+# they might actually cause problems. YMMV.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pforth
@@ -21,9 +26,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -58,14 +60,15 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# https://github.com/philburk/pforth
+# 20220318 bkw: hate -Werror. but, see WARNING above...
+sed -i '/-Werror/d' csrc/CMakeLists.txt
CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" cmake .
-make
+make VERBOSE=1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION