summaryrefslogtreecommitdiffstats
path: root/development/kicad-doc
diff options
context:
space:
mode:
author Tim Dickson2023-07-22 03:40:09 +0200
committer Willy Sudiarto Raharjo2023-07-22 10:52:48 +0200
commit10f34a723b93e0e0ebd32995255a1ec47150b627 (patch)
tree05e0d11b29e1b749bc450430d37731dfc735f0ea /development/kicad-doc
parent943568aaa73bd93ac6b5011e436aab87f8ad3733 (diff)
downloadslackbuilds-10f34a723b93e0e0ebd32995255a1ec47150b627.tar.gz
development/kicad-doc: Updated for version 7.0.2.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/kicad-doc')
-rw-r--r--development/kicad-doc/README17
-rw-r--r--development/kicad-doc/kicad-doc.SlackBuild36
-rw-r--r--development/kicad-doc/kicad-doc.info14
3 files changed, 52 insertions, 15 deletions
diff --git a/development/kicad-doc/README b/development/kicad-doc/README
index 9eb0cbd01f..f4c4307186 100644
--- a/development/kicad-doc/README
+++ b/development/kicad-doc/README
@@ -3,7 +3,20 @@ Additional KiCad documentation and presentations.
Since this documentation package has a separate release time-line,
you may have to specify the version of the installed KiCad package if
it is newer than this documentation package. At the time of writing,
-it was "bzr_20130325". To specify another release, run this SlackBuild
+it was "7.0.2". To specify another release, run this SlackBuild
as follows:
- # KICAD_VERSION="bzr_yyyymmdd" ./kicad-doc.SlackBuild
+ # KICAD_VERSION="7.0.5" ./kicad-doc.SlackBuild
+documentation is available in a number of different languages. see
+CMakeLists.txt for a full list. this build will default to en
+(english) but can be changed by setting the environment variable
+DOCLANG before running the script. for example, for french, use
+
+ # DOCLANG=fr ./kicad-doc.SlackBuild
+
+for more than one language, use a quoted semicolon separated list. eg
+
+ # DOCLANG="en;fr;de;it;jp;cz" ./kicad-doc.SlackBuild
+
+note: once package is created, node.js is no longer required
+(build dep only)
diff --git a/development/kicad-doc/kicad-doc.SlackBuild b/development/kicad-doc/kicad-doc.SlackBuild
index cdcc50aeb7..8c3b10798b 100644
--- a/development/kicad-doc/kicad-doc.SlackBuild
+++ b/development/kicad-doc/kicad-doc.SlackBuild
@@ -4,6 +4,7 @@
# Additional documentation for KiCad
# Copyright 2010-2013 Niels Horn, Rio de Janeiro, RJ, Brazil
+# 2023/07/21 tjd: patched for 7.0.2 adding extra deps etc.
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,19 +24,20 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Revision date: 2019-12-12
+# Revision date: 2023-07-23
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=kicad-doc
-VERSION=${VERSION:-5.1.5}
+VERSION=${VERSION:-7.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-
+DOCLANG=${DOCLANG:-en}
+ADWPVER=${ADWPVER:-20230721}
ARCH="noarch"
-KICAD_VERSION=${KICAD_VERSION:-5.1.5}
+KICAD_VERSION=${KICAD_VERSION:-7.0.2}
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
@@ -57,6 +59,18 @@ cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+#patch CmakeLists.txt to remove warning
+sed -i 's\2.8\2.8.12\g' CMakeLists.txt
+
+#note: to create asciidoctor-web-pdf-64bit-YYYYMMDD.tar.js once node.js is installed; in a
+#overlayfs chroot run npm -i -g asciidoctor-pdf
+#then tar.gz the contents of usr/lib64/node_modules from the overlay directory
+#eg. cd $OVERLAYCHANGESDIR/usr/lib64; tar -czf ~/asciidoctor-web-pdf-64bit-YYYYMMDD.tar.gz node_modules
+#
+tar -xzf $CWD/asciidoctor-web-pdf-64bit-$ADWPVER.tar.gz
+#make sure system can find asciidoctor-web-pdf stuff
+OLDPATH=$PATH
+PATH=$TMP/$PRGNAM-$VERSION/node_modules/asciidoctor-pdf/bin:$PATH; export PATH
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -68,19 +82,27 @@ mkdir -p build
cd build
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DLANGUAGES=en \
+ -DLANGUAGES=$DOCLANG \
+ -Wno-dev \
-DBUILD_FORMATS='html;pdf' ../
make
make install DESTDIR=$PKG
cd ..
+PATH=$OLDPATH; export PATH
+#tidy up huge stuff no longer needed.
+rm -rf node_modules
+#fix locations
+#mkdir -p $PKG/usr/doc/kicad-$KICAD_VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -ar $PKG/usr/share/doc/kicad/* $PKG/usr/doc/$PRGNAM-$VERSION/
+rm -rf $PKG/usr/share/doc
# Create a link in the data-dir to the documentation
mkdir -p $PKG/usr/share/kicad
cd $PKG/usr/share/kicad
- ln -sf ../../doc/kicad-$KICAD_VERSION/help
+ ln -sf ../../doc/$PRGNAM-$VERSION/help
cd ..
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/kicad-doc/kicad-doc.info b/development/kicad-doc/kicad-doc.info
index 97e1554d15..d0a91e9a0b 100644
--- a/development/kicad-doc/kicad-doc.info
+++ b/development/kicad-doc/kicad-doc.info
@@ -1,10 +1,12 @@
PRGNAM="kicad-doc"
-VERSION="5.1.5"
+VERSION="7.0.2"
HOMEPAGE="http://kicad-pcb.org/"
-DOWNLOAD="https://github.com/KiCad/kicad-doc/archive/5.1.5/kicad-doc-5.1.5.tar.gz"
-MD5SUM="093bcdf18cd8d9aed3d1d566045fc8c6"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="dblatex po4a"
+DOWNLOAD="UNSUPPORTED"
+MD5SUM=""
+DOWNLOAD_x86_64="https://gitlab.com/kicad/services/kicad-doc/-/archive/7.0.2/kicad-doc-7.0.2.tar.gz \
+ https://sourceforge.net/projects/slackbuildsdirectlinks/files/asciidoctor-web-pdf/asciidoctor-web-pdf-64bit-20230721.tar.gz"
+MD5SUM_x86_64="b2229bb564c1ff4590d6db65f9ea3353 \
+ c522909c78ba3beff9efd4f9a6d00cbc"
+REQUIRES="dblatex po4a nodejs"
MAINTAINER="Fernando Lopez Jr."
EMAIL="fernando.lopezjr@gmail.com"