summaryrefslogtreecommitdiffstats
path: root/development/jupyter_client
diff options
context:
space:
mode:
author Matteo Bernardini2022-02-16 19:11:26 +0100
committer Willy Sudiarto Raharjo2022-02-17 06:59:49 +0100
commit23cd723d459721c6821108f11640e76449f1cd22 (patch)
tree677c8fa8ac299e3de90abbec077954754d3a7711 /development/jupyter_client
parentfedee7987f029339a347594c09b54c229d98bc43 (diff)
downloadslackbuilds-23cd723d459721c6821108f11640e76449f1cd22.tar.gz
development/jupyter_client: Removed (abandoned).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/jupyter_client')
-rw-r--r--development/jupyter_client/README3
-rw-r--r--development/jupyter_client/jupyter_client.SlackBuild97
-rw-r--r--development/jupyter_client/jupyter_client.info10
-rw-r--r--development/jupyter_client/slack-desc19
4 files changed, 0 insertions, 129 deletions
diff --git a/development/jupyter_client/README b/development/jupyter_client/README
deleted file mode 100644
index 21fe6bf3de..0000000000
--- a/development/jupyter_client/README
+++ /dev/null
@@ -1,3 +0,0 @@
-jupyter_client contains the reference implementation of the Jupyter
-protocol. It also provides client and kernel management APIs for
-working with kernels.
diff --git a/development/jupyter_client/jupyter_client.SlackBuild b/development/jupyter_client/jupyter_client.SlackBuild
deleted file mode 100644
index c074bce1e8..0000000000
--- a/development/jupyter_client/jupyter_client.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for jupyter_client
-
-# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=jupyter_client
-VERSION=${VERSION:-6.2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING.md README.md \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/jupyter_client/jupyter_client.info b/development/jupyter_client/jupyter_client.info
deleted file mode 100644
index ad128dbc69..0000000000
--- a/development/jupyter_client/jupyter_client.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="jupyter_client"
-VERSION="6.2.0"
-HOMEPAGE="https://jupyter.org/"
-DOWNLOAD="https://github.com/jupyter/jupyter_client/archive/6.2.0/jupyter_client-6.2.0.tar.gz"
-MD5SUM="7bddde3d7cf856d41566c69746a7feb6"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="decorator jupyter_core python3-dateutil python3-pyzmq traitlets"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/development/jupyter_client/slack-desc b/development/jupyter_client/slack-desc
deleted file mode 100644
index 980739fd32..0000000000
--- a/development/jupyter_client/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-jupyter_client: jupyter_client (Jupyter protocol client APIs)
-jupyter_client:
-jupyter_client: jupyter_client contains the reference implementation of the Jupyter
-jupyter_client: protocol. It also provides client and kernel management APIs for
-jupyter_client: working with kernels.
-jupyter_client:
-jupyter_client:
-jupyter_client:
-jupyter_client:
-jupyter_client:
-jupyter_client: