summaryrefslogtreecommitdiffstats
path: root/development/jupyter-notebook/jupyter-notebook.SlackBuild
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2019-05-17 08:23:07 +0200
committer Willy Sudiarto Raharjo2019-05-18 02:22:18 +0200
commitc3217f94acb46d8ac54b1f53424a35c58d46585f (patch)
treed67c0b1d80a0388baa5e086d513c666393f22651 /development/jupyter-notebook/jupyter-notebook.SlackBuild
parentd3f0255e171be21b547d052710d4f6cc527c2563 (diff)
downloadslackbuilds-c3217f94acb46d8ac54b1f53424a35c58d46585f.tar.gz
development/jupyter-notebook: Updated to use Python 3.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
Diffstat (limited to 'development/jupyter-notebook/jupyter-notebook.SlackBuild')
-rw-r--r--development/jupyter-notebook/jupyter-notebook.SlackBuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/development/jupyter-notebook/jupyter-notebook.SlackBuild b/development/jupyter-notebook/jupyter-notebook.SlackBuild
index 94f89a0187..46b4958400 100644
--- a/development/jupyter-notebook/jupyter-notebook.SlackBuild
+++ b/development/jupyter-notebook/jupyter-notebook.SlackBuild
@@ -25,7 +25,7 @@
SRCNAM=notebook
PRGNAM=jupyter-$SRCNAM
VERSION=${VERSION:-5.7.8}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -70,7 +70,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true