summaryrefslogtreecommitdiffstats
path: root/development/codespell
diff options
context:
space:
mode:
author B. Watson2021-08-29 20:10:23 +0200
committer Willy Sudiarto Raharjo2021-10-12 19:51:53 +0200
commitfa576b482fddd1c122e92d821b54c7fb552cd749 (patch)
tree961155c789e5de1f084ca62fa56a757a0b842146 /development/codespell
parent45128e81cdc3397d3321ba500eacadb865e6ac3c (diff)
downloadslackbuilds-fa576b482fddd1c122e92d821b54c7fb552cd749.tar.gz
development/codespell: Updated for version 2.1.0.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/codespell')
-rw-r--r--development/codespell/codespell.SlackBuild15
-rw-r--r--development/codespell/codespell.info6
2 files changed, 12 insertions, 9 deletions
diff --git a/development/codespell/codespell.SlackBuild b/development/codespell/codespell.SlackBuild
index dc5a030638..5070146e11 100644
--- a/development/codespell/codespell.SlackBuild
+++ b/development/codespell/codespell.SlackBuild
@@ -6,10 +6,16 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20210829 bkw:
+# - update for 2.1.0.
+# - use python3 by default. add PYVER var to force building with 2,
+# but don't document it (nobody should need it).
+# - add example/ to the doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=codespell
-VERSION=${VERSION:-1.17.1}
+VERSION=${VERSION:-2.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +28,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -60,14 +63,14 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-python setup.py install --root=$PKG
+python${PYVER:-3} setup.py install --root=$PKG
make $PRGNAM.1
mkdir -p $PKG/usr/man/man1
gzip -9c < $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README* COPYING example $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/development/codespell/codespell.info b/development/codespell/codespell.info
index 4edb51d153..c7e38485a9 100644
--- a/development/codespell/codespell.info
+++ b/development/codespell/codespell.info
@@ -1,8 +1,8 @@
PRGNAM="codespell"
-VERSION="1.17.1"
+VERSION="2.1.0"
HOMEPAGE="https://github.com/codespell-project/codespell"
-DOWNLOAD="https://github.com/codespell-project/codespell/archive/v1.17.1/codespell-1.17.1.tar.gz"
-MD5SUM="eaa42b26713c571311ba9374046cc12f"
+DOWNLOAD="https://github.com/codespell-project/codespell/archive/v2.1.0/codespell-2.1.0.tar.gz"
+MD5SUM="76e99263c6c0660b3149b59f16f8a365"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""