summaryrefslogtreecommitdiffstats
path: root/development/bacon
diff options
context:
space:
mode:
author B. Watson2023-08-14 21:25:35 +0200
committer Willy Sudiarto Raharjo2023-08-19 04:15:31 +0200
commit50cf12031946a3e04630b931e7622b7e574b238f (patch)
treed6b7f1093cbbfbd78488fd8584af34363133b4cb /development/bacon
parent1c9852616451985a9f1f680b4201aa685f931c5a (diff)
downloadslackbuilds-50cf12031946a3e04630b931e7622b7e574b238f.tar.gz
development/bacon: Updated for version 4.7.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/bacon')
-rw-r--r--development/bacon/bacon.SlackBuild27
-rw-r--r--development/bacon/bacon.info6
2 files changed, 23 insertions, 10 deletions
diff --git a/development/bacon/bacon.SlackBuild b/development/bacon/bacon.SlackBuild
index 2bb0b9a7d2..1cdbe578b0 100644
--- a/development/bacon/bacon.SlackBuild
+++ b/development/bacon/bacon.SlackBuild
@@ -6,10 +6,17 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20230814 bkw:
+# - update to v4.7.
+# - switch to self-hosted download, as upstreams disappears the
+# previous version immediately upon releasing a new one.
+# - prescaled icons.
+# - add CHANGES to doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=bacon
-VERSION=${VERSION:-4.6.1}
+VERSION=${VERSION:-4.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,7 +88,7 @@ sed -i 's,/share/pixmaps/,/share/BaCon/,' bacon.bac
# I use this when editing the script, to avoid the 5+ minute build time.
# The C implementation is thousands of times faster than the shell script.
if [ "${CHEAT:-no}" = "yes" -a -x /usr/bin/bacon ]; then
- sed -i 's,\$(BSHELL) \./bacon\.sh,/usr/bin/bacon,' /tmp/SBo/bacon-4.6.1/Makefile.in
+ sed -i 's,\$(BSHELL) \./bacon\.sh,/usr/bin/bacon,' Makefile.in
fi
CFLAGS="$SLKCFLAGS" \
@@ -111,16 +118,22 @@ gzip -9 $PKG/usr/man/man*/*
# This is where we patched it to look for this icon:
mv $PKG/usr/share/pixmaps/BaCon.xbm $PKG/usr/share/BaCon/
-# I should really do the whole /usr/share/icons and pre-scale them,
-# but for now:
-sed -i '/^Icon/s,\(=\)\(.*\),\1/usr/share/pixmaps/\2.png,' \
- $PKG/usr/share/applications/*.desktop
+# Various icons already in /usr/share/pixmaps. Prescale.
+for icon in BaCon BaConEyes BaConStrip; do
+ PNG=$PKG/usr/share/pixmaps/$icon.png
+ for px in 16 22 32 48 64 128 256; do
+ sz=${px}x${px}
+ dir=$PKG/usr/share/icons/hicolor/$sz/apps
+ mkdir -p $dir
+ convert -resize $sz $PNG $dir/$icon.png
+ done
+done
# The GUI has the documentation path baked in, so symlink it to the
# the Slackware doc dir.
PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
mkdir -p $PKGDOC
-cp -a README* $PKGDOC
+cp -a README* CHANGES* $PKGDOC
ln -s ../../share/BaCon/documentation $PKGDOC/documentation
ln -s ../../share/BaCon/LICENSE $PKGDOC/LICENSE
cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
diff --git a/development/bacon/bacon.info b/development/bacon/bacon.info
index 4605e392b5..49b00c47d6 100644
--- a/development/bacon/bacon.info
+++ b/development/bacon/bacon.info
@@ -1,8 +1,8 @@
PRGNAM="bacon"
-VERSION="4.6.1"
+VERSION="4.7"
HOMEPAGE="http://www.basic-converter.org/"
-DOWNLOAD="http://www.basic-converter.org/stable/bacon-4.6.1.tar.gz"
-MD5SUM="d639d7d287cf55df101abd0ab13be6ce"
+DOWNLOAD="https://slackware.uk/~urchlay/src/bacon-4.7.tar.gz"
+MD5SUM="6b27d53997f9fc7f37b4382db32099cf"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""