summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2020-02-07 19:57:21 +0100
committer Willy Sudiarto Raharjo2020-02-07 19:57:21 +0100
commit833dea650f2915f9769c9969ed3d6674858a3fac (patch)
tree372e042cc4e5d395f2caaf7580e6bfcd7c920f0a /desktop
parent4eea64847185951a76937c4e81037a3f8ee4c808 (diff)
downloadslackbuilds-833dea650f2915f9769c9969ed3d6674858a3fac.tar.gz
desktop/Buku: Removed (replaced by buku).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/Buku/Buku.SlackBuild96
-rw-r--r--desktop/Buku/Buku.info11
-rw-r--r--desktop/Buku/README9
-rw-r--r--desktop/Buku/slack-desc19
4 files changed, 0 insertions, 135 deletions
diff --git a/desktop/Buku/Buku.SlackBuild b/desktop/Buku/Buku.SlackBuild
deleted file mode 100644
index a153a86e50..0000000000
--- a/desktop/Buku/Buku.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script for Buku.
-#
-# Copyright 2018 Edinaldo P. Silva, Rio de Janeiro, Brazil.
-# Copyright 2019-2020 Andrew Clemons, Wellington New Zealand
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=Buku
-SRCNAM=buku
-VERSION=${VERSION:-4.2.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py build
-python3 setup.py install --root=$PKG --prefix=/usr --optimize=1
-
-install -Dm644 auto-completion/fish/buku.fish $PKG/usr/share/fish/vendor_completions.d/buku.fish
-install -Dm644 auto-completion/bash/buku-completion.bash $PKG/etc/bash_completion.d/buku
-install -Dm644 auto-completion/zsh/_buku $PKG/usr/share/zsh/site-functions/_buku
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-install -Dm 644 buku.1 $PKG/usr/man/man1/buku.1
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp CHANGELOG LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/Buku/Buku.info b/desktop/Buku/Buku.info
deleted file mode 100644
index 3a64e1b07b..0000000000
--- a/desktop/Buku/Buku.info
+++ /dev/null
@@ -1,11 +0,0 @@
-PRGNAM="Buku"
-VERSION="4.2.2"
-HOMEPAGE="https://github.com/jarun/Buku"
-DOWNLOAD="https://github.com/jarun/Buku/archive/v4.2.2/buku-4.2.2.tar.gz"
-MD5SUM="2d8c8bc3d673ee4ec1ef9ef99cdb4544"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-urllib3 BeautifulSoup4 cryptography html5lib python3-certifi"
-MAINTAINER="Andrew Clemons"
-EMAIL="andrew.clemons@gmail.com"
-
diff --git a/desktop/Buku/README b/desktop/Buku/README
deleted file mode 100644
index 117c7440a1..0000000000
--- a/desktop/Buku/README
+++ /dev/null
@@ -1,9 +0,0 @@
-Buku (Cmdline bookmark manager with editor and browser integration)
-
-buku is a powerful bookmark manager written in Python3 and SQLite3.
-buku fetches the title of a bookmarked url and stores it along with
-any user-provided comments and tags.
-
-All Buku dependencies must be built with Python 3.
-
-Optional dependency: xsel
diff --git a/desktop/Buku/slack-desc b/desktop/Buku/slack-desc
deleted file mode 100644
index 409c92469c..0000000000
--- a/desktop/Buku/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Buku: Buku (Cmdline bookmark manager with editor and browser integration)
-Buku:
-Buku: buku is a powerful bookmark manager written in Python3 and SQLite3.
-Buku: buku fetches the title of a bookmarked url and stores it along with
-Buku: any user-provided comments and tags.
-Buku:
-Buku: Homepage: https://github.com/jarun/Buku
-Buku:
-Buku:
-Buku:
-Buku: