summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author B. Watson2020-01-01 22:38:20 +0100
committer Robby Workman2020-01-03 09:06:16 +0100
commit507b4d140a2d311a2ceccb6930577ad26bf0ca38 (patch)
treea4133a789380de1368d2c8edb94cf03a345905f3 /desktop
parentd307f26cde068dd821bea2ebc2dc71283bb37949 (diff)
downloadslackbuilds-507b4d140a2d311a2ceccb6930577ad26bf0ca38.tar.gz
desktop/echinus: New maintainer, add xinitrc.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/echinus/README4
-rw-r--r--desktop/echinus/echinus.SlackBuild58
-rw-r--r--desktop/echinus/echinus.info4
-rw-r--r--desktop/echinus/slack-desc6
4 files changed, 44 insertions, 28 deletions
diff --git a/desktop/echinus/README b/desktop/echinus/README
index 607b6ac13b..0b4a0efc25 100644
--- a/desktop/echinus/README
+++ b/desktop/echinus/README
@@ -1,4 +1,6 @@
-Echinus is a simple and lightweight tiling window manager for x similar
+echinus (lightweight tiling window manager)
+
+Echinus is a simple and lightweight tiling window manager for X, similar
to dwm except it can have windows with close, minimize, and maximize
buttons and has a simple config file.
diff --git a/desktop/echinus/echinus.SlackBuild b/desktop/echinus/echinus.SlackBuild
index f17ee8dfc7..b04d8b2a9e 100644
--- a/desktop/echinus/echinus.SlackBuild
+++ b/desktop/echinus/echinus.SlackBuild
@@ -5,17 +5,27 @@
# Written by Charles E. Kauffman gahlgwogi@lycos.com
# Modified from Tom Canich's slackbuild for dwm.
+# Modified by B. Watson
+
+# Now maintained by B. Watson <yalhcru@gmail.com>. Original version
+# had no license; modified version is licensed under the WTFPL.
+# See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20200101 bkw:
+# - take over maintenance
+# - BUILD=2
+# - add xinitrc
+# - simplify build
+
PRGNAM=echinus
VERSION=${VERSION:-0.4.9}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
-# Makefile specific variables.
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -26,8 +36,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -49,15 +59,21 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# use SLKCFLAGS
+sed -i "s/-Os/$SLKCFLAGS -Wl,-s/" config.mk
+
+# absolute paths for pixmaps
+sed -i "s,.pixmap: ,&/usr/share/$PRGNAM/," echinusrc
+
+# install docs in Slackware-compliant dir
+sed -i "s,DOCPREFIX}/$PRGNAM,&-$VERSION," Makefile
-sed -i "s;-Os;$SLKCFLAGS ;" config.mk
-sed -i "s;.pixmap: ;.pixmap: \/usr\/share\/echinus\/;" echinusrc
-sed -i "s/DOCPREFIX}\/echinus/DOCPREFIX}\/echinus-$VERSION/" Makefile
+# don't include $PKG in the path to the default config file
+# mentioned in the man page
+sed -i 's,\${DESTDIR}\(\${CONF}\),\1,' Makefile
make install \
PREFIX=/usr \
@@ -66,19 +82,17 @@ make install \
MANPREFIX=/usr/man \
X11INC=/usr/include/X11 \
X11LIB=/usr/lib${LIBDIRSUFFIX}/X11 \
- CONF=/share/echinus \
+ CONF=/usr/share/$PRGNAM \
DESTDIR=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+gzip -9 $PKG/usr/man/man1/$PRGNAM.1
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+# xinitrc by B. Watson, modified from xinitrc.wmaker
+mkdir -p $PKG/etc/X11/xinit
+install -m0755 -oroot -groot $CWD/xinitrc.$PRGNAM $PKG/etc/X11/xinit
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE README \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/desktop/echinus/echinus.info b/desktop/echinus/echinus.info
index a24c85dbf0..21c4df78e5 100644
--- a/desktop/echinus/echinus.info
+++ b/desktop/echinus/echinus.info
@@ -6,5 +6,5 @@ MD5SUM="8e17f3973060121847050b74a1bf000d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Charles E. Kauffman"
-EMAIL="molbolom@gmail.com"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/desktop/echinus/slack-desc b/desktop/echinus/slack-desc
index 2efbe6fe94..3dc431bb2a 100644
--- a/desktop/echinus/slack-desc
+++ b/desktop/echinus/slack-desc
@@ -8,9 +8,9 @@
|-----handy-ruler------------------------------------------------------|
echinus: echinus (lightweight tiling window manager)
echinus:
-echinus: echinus is a simple and lightweight tiling window manager for x
-echinus: similarto dwm except it can have windows with close, minimize,
-echinus: and maximizebuttons and has a simple config file.
+echinus: echinus is a simple and lightweight tiling window manager for X,
+echinus: similar to dwm except it can have windows with close, minimize,
+echinus: and maximize buttons and has a simple config file.
echinus:
echinus: Homepage: https://plhk.ru/
echinus: