summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Edinaldo P. Silva2015-11-25 09:36:39 +0100
committer Willy Sudiarto Raharjo2015-11-28 01:25:59 +0100
commitdf2092e1bdcd1cf0e9b4230f19effbdc75dbd662 (patch)
tree7f0eb83c0f68ae8e47b9a7527f4e70a9367173e6 /desktop
parent6671081506b3c9f4bb7aeebca59554fbe1c434a5 (diff)
downloadslackbuilds-df2092e1bdcd1cf0e9b4230f19effbdc75dbd662.tar.gz
desktop/numix-icon-theme: Added (icon theme).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/numix-icon-theme/README10
-rw-r--r--desktop/numix-icon-theme/doinst.sh13
-rw-r--r--desktop/numix-icon-theme/numix-icon-theme.SlackBuild62
-rw-r--r--desktop/numix-icon-theme/numix-icon-theme.info10
-rw-r--r--desktop/numix-icon-theme/slack-desc19
5 files changed, 114 insertions, 0 deletions
diff --git a/desktop/numix-icon-theme/README b/desktop/numix-icon-theme/README
new file mode 100644
index 0000000000..05c8582a38
--- /dev/null
+++ b/desktop/numix-icon-theme/README
@@ -0,0 +1,10 @@
+numix-icon-theme (official icon theme from the Numix project)
+
+Numix is the official icon theme from the Numix project. It is
+heavily inspired by, and based upon parts of the Elementary,
+Humanity and Gnome icon themes. Designed to be used along side the
+application icon theme Numix Circle.
+
+Numix is designed to look fresh, swishy and modern using white
+symbols on vividly coloured background for applications and
+simplistic devices, toolbars and status icons.
diff --git a/desktop/numix-icon-theme/doinst.sh b/desktop/numix-icon-theme/doinst.sh
new file mode 100644
index 0000000000..9424ce43ff
--- /dev/null
+++ b/desktop/numix-icon-theme/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/desktop/numix-icon-theme/numix-icon-theme.SlackBuild b/desktop/numix-icon-theme/numix-icon-theme.SlackBuild
new file mode 100644
index 0000000000..dfa628b056
--- /dev/null
+++ b/desktop/numix-icon-theme/numix-icon-theme.SlackBuild
@@ -0,0 +1,62 @@
+#!/bin/sh
+#
+# Slackware build script for numix-icon-theme.
+#
+# Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM="numix-icon-theme"
+VERSION=${VERSION:-0.3.20151121}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+ARCH=noarch
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+CWD=$(pwd)
+
+set -e
+
+SRCVER="0.3+683~201511210216~ubuntu15.10.1"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_${SRCVER}.tar.xz
+mv $PRGNAM-$SRCVER $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+
+mkdir -p $PKG/usr/share/icons
+cp -a Numix Numix-Light $PKG/usr/share/icons
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/changelog license readme.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/numix-icon-theme/numix-icon-theme.info b/desktop/numix-icon-theme/numix-icon-theme.info
new file mode 100644
index 0000000000..98cffa1ac3
--- /dev/null
+++ b/desktop/numix-icon-theme/numix-icon-theme.info
@@ -0,0 +1,10 @@
+PRGNAM="numix-icon-theme"
+VERSION="0.3.20151121"
+HOMEPAGE="https://github.com/numixproject/numix-icon-theme/"
+DOWNLOAD="https://launchpad.net/~numix/+archive/ubuntu/ppa/+files/numix-icon-theme_0.3%2B683~201511210216~ubuntu15.10.1.tar.xz"
+MD5SUM="4713e92b1a7bba50456a47876e628003"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/desktop/numix-icon-theme/slack-desc b/desktop/numix-icon-theme/slack-desc
new file mode 100644
index 0000000000..d3e8fcf1b3
--- /dev/null
+++ b/desktop/numix-icon-theme/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+numix-icon-theme: numix-icon-theme (official icon theme from the Numix project)
+numix-icon-theme:
+numix-icon-theme: Numix is the official icon theme from the Numix project. It is
+numix-icon-theme: heavily inspired by, and based upon parts of the Elementary,
+numix-icon-theme: Humanity and Gnome icon themes. Designed to be used along side the
+numix-icon-theme: application icon theme Numix Circle.
+numix-icon-theme:
+numix-icon-theme: Home Page: https://github.com/numixproject/numix-icon-theme/
+numix-icon-theme:
+numix-icon-theme:
+numix-icon-theme: