summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Edinaldo P. Silva2015-11-25 09:37:36 +0100
committer Willy Sudiarto Raharjo2015-11-28 01:25:59 +0100
commit31083fbe94691a56e84da8de748368608a2983bc (patch)
tree8efe5f23b07242e11b08168c60b8ebbb4433fd37 /desktop
parentdf2092e1bdcd1cf0e9b4230f19effbdc75dbd662 (diff)
downloadslackbuilds-31083fbe94691a56e84da8de748368608a2983bc.tar.gz
desktop/numix-icon-theme-circle: Added (icon theme).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/numix-icon-theme-circle/README3
-rw-r--r--desktop/numix-icon-theme-circle/doinst.sh13
-rw-r--r--desktop/numix-icon-theme-circle/numix-icon-theme-circle.SlackBuild62
-rw-r--r--desktop/numix-icon-theme-circle/numix-icon-theme-circle.info10
-rw-r--r--desktop/numix-icon-theme-circle/slack-desc19
5 files changed, 107 insertions, 0 deletions
diff --git a/desktop/numix-icon-theme-circle/README b/desktop/numix-icon-theme-circle/README
new file mode 100644
index 0000000000..a5adce4e4a
--- /dev/null
+++ b/desktop/numix-icon-theme-circle/README
@@ -0,0 +1,3 @@
+numix-icon-theme-circle (Numix Circle icon theme)
+
+Numix Circle is an icon theme for Linux from the Numix project.
diff --git a/desktop/numix-icon-theme-circle/doinst.sh b/desktop/numix-icon-theme-circle/doinst.sh
new file mode 100644
index 0000000000..9424ce43ff
--- /dev/null
+++ b/desktop/numix-icon-theme-circle/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/desktop/numix-icon-theme-circle/numix-icon-theme-circle.SlackBuild b/desktop/numix-icon-theme-circle/numix-icon-theme-circle.SlackBuild
new file mode 100644
index 0000000000..fb2a40d077
--- /dev/null
+++ b/desktop/numix-icon-theme-circle/numix-icon-theme-circle.SlackBuild
@@ -0,0 +1,62 @@
+#!/bin/sh
+#
+# Slackware build script for numix-icon-theme-circle.
+#
+# Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM="numix-icon-theme-circle"
+VERSION=${VERSION:-1.0.20151016}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+ARCH=noarch
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+CWD=$(pwd)
+
+set -e
+
+SRCVER="1.0.2+5~201510162111~ubuntu15.10.1"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/${PRGNAM}_${SRCVER}.tar.xz
+mv $PRGNAM-$SRCVER $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+
+mkdir -p $PKG/usr/share/icons
+cp -a Numix-Circle Numix-Circle-Light $PKG/usr/share/icons
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a debian/changelog license readme.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/numix-icon-theme-circle/numix-icon-theme-circle.info b/desktop/numix-icon-theme-circle/numix-icon-theme-circle.info
new file mode 100644
index 0000000000..d11e547edf
--- /dev/null
+++ b/desktop/numix-icon-theme-circle/numix-icon-theme-circle.info
@@ -0,0 +1,10 @@
+PRGNAM="numix-icon-theme-circle"
+VERSION="1.0.20151016"
+HOMEPAGE="https://github.com/numixproject/numix-icon-theme-circle"
+DOWNLOAD="https://launchpadlibrarian.net/221494686/numix-icon-theme-circle_1.0.2%2B5%7E201510162111%7Eubuntu15.10.1.tar.xz"
+MD5SUM="02d67a41adb9d12860ed87016c060117"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64="numix-icon-theme"
+REQUIRES=""
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/desktop/numix-icon-theme-circle/slack-desc b/desktop/numix-icon-theme-circle/slack-desc
new file mode 100644
index 0000000000..99e48ae9dd
--- /dev/null
+++ b/desktop/numix-icon-theme-circle/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+numix-icon-theme-circle: numix-icon-theme-circle (Numix Circle icon theme)
+numix-icon-theme-circle:
+numix-icon-theme-circle: Numix Circle is an icon theme for Linux from the Numix project.
+numix-icon-theme-circle:
+numix-icon-theme-circle: Home Page: https://github.com/numixproject/numix-icon-theme-circle/
+numix-icon-theme-circle:
+numix-icon-theme-circle:
+numix-icon-theme-circle:
+numix-icon-theme-circle:
+numix-icon-theme-circle:
+numix-icon-theme-circle: