summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-08-27 07:34:47 +0200
committer Willy Sudiarto Raharjo2014-08-30 09:22:23 +0200
commit4181f14b2e41d597a0bef7591be47904bf440c7c (patch)
tree13a1718fdf36c8cdb8f927f5df8245a45be7fe40 /desktop
parentd98098933a37bc1331b15542e48688c98c362cdd (diff)
downloadslackbuilds-4181f14b2e41d597a0bef7591be47904bf440c7c.tar.gz
desktop/screensaver-icon: Added (control xscreensaver).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/screensaver-icon/README7
-rw-r--r--desktop/screensaver-icon/doinst.sh3
-rw-r--r--desktop/screensaver-icon/screensaver-icon.SlackBuild86
-rw-r--r--desktop/screensaver-icon/screensaver-icon.info10
-rw-r--r--desktop/screensaver-icon/slack-desc19
5 files changed, 125 insertions, 0 deletions
diff --git a/desktop/screensaver-icon/README b/desktop/screensaver-icon/README
new file mode 100644
index 0000000000..1844c0757c
--- /dev/null
+++ b/desktop/screensaver-icon/README
@@ -0,0 +1,7 @@
+Displays a icon to control xscreensaver.
+
+This small daemon serves two basic functions:
+- provides a GTK status-bar icon with one-click enabling and
+ disabling of the screensaver.
+- attempts to set an Away message in pidgin when the screensaver
+ locks the screen and reverts to previous status message on unlock.
diff --git a/desktop/screensaver-icon/doinst.sh b/desktop/screensaver-icon/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/screensaver-icon/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/screensaver-icon/screensaver-icon.SlackBuild b/desktop/screensaver-icon/screensaver-icon.SlackBuild
new file mode 100644
index 0000000000..fd33cec95e
--- /dev/null
+++ b/desktop/screensaver-icon/screensaver-icon.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for screensaver-icon
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=screensaver-icon
+VERSION=${VERSION:-1.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/screensaver-icon/screensaver-icon.info b/desktop/screensaver-icon/screensaver-icon.info
new file mode 100644
index 0000000000..03397ea980
--- /dev/null
+++ b/desktop/screensaver-icon/screensaver-icon.info
@@ -0,0 +1,10 @@
+PRGNAM="screensaver-icon"
+VERSION="1.2"
+HOMEPAGE="https://pypi.python.org/pypi/screensaver-icon"
+DOWNLOAD="https://pypi.python.org/packages/source/s/screensaver-icon/screensaver-icon-1.2.tar.gz"
+MD5SUM="480ba6a1c966aeae5a5cb464f40aa315"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/desktop/screensaver-icon/slack-desc b/desktop/screensaver-icon/slack-desc
new file mode 100644
index 0000000000..31ff96c130
--- /dev/null
+++ b/desktop/screensaver-icon/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+screensaver-icon: screensaver-icon (control xscreensaver)
+screensaver-icon:
+screensaver-icon: Displays an icon to control xscreensaver.
+screensaver-icon: This small daemon serves two basic functions:
+screensaver-icon: - provides a GTK status-bar icon with one-click enabling and
+screensaver-icon: disabling of the screensaver;
+screensaver-icon: - attempts to set an Away message in pidgin when the screensaver
+screensaver-icon: locks the screen and reverts to previous status message on unlock.
+screensaver-icon:
+screensaver-icon: Homepage: https://pypi.python.org/pypi/screensaver-icon
+screensaver-icon: