summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Andrew Rowland2012-01-16 05:36:46 +0100
committer Robby Workman2012-01-16 05:36:46 +0100
commit29c2578e2cb4e548d2b5e9bc1ae750cb0ec7dca2 (patch)
treefab6e45839582a92a9eff5cf355b9018fb580fe4 /desktop
parent3344eb0ba071cc94b96333b2c04f6f65d9555e87 (diff)
downloadslackbuilds-29c2578e2cb4e548d2b5e9bc1ae750cb0ec7dca2.tar.gz
desktop/PyPanel: Added (a lightweight panel/taskbar for X11)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/PyPanel/PyPanel.SlackBuild67
-rw-r--r--desktop/PyPanel/PyPanel.info10
-rw-r--r--desktop/PyPanel/README7
-rw-r--r--desktop/PyPanel/slack-desc19
4 files changed, 103 insertions, 0 deletions
diff --git a/desktop/PyPanel/PyPanel.SlackBuild b/desktop/PyPanel/PyPanel.SlackBuild
new file mode 100644
index 0000000000..8a1ab0fc58
--- /dev/null
+++ b/desktop/PyPanel/PyPanel.SlackBuild
@@ -0,0 +1,67 @@
+#!/bin/sh
+
+# Slackware build script for pypanel
+
+# Written by Andrew Rowland (darowland@ieee.org)
+
+PRGNAM=PyPanel
+VERSION=${VERSION:-2.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING PKG-INFO README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/PyPanel/PyPanel.info b/desktop/PyPanel/PyPanel.info
new file mode 100644
index 0000000000..57af40d143
--- /dev/null
+++ b/desktop/PyPanel/PyPanel.info
@@ -0,0 +1,10 @@
+PRGNAM="PyPanel"
+VERSION="2.4"
+HOMEPAGE="http://pypanel.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/project/pypanel/pypanel/2.4/PyPanel-2.4.tar.gz"
+MD5SUM="f1f9a2ed80be72ab36e748833618daba"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Andrew Rowland"
+EMAIL="darowland@ieee.org"
+APPROVED="rworkman"
diff --git a/desktop/PyPanel/README b/desktop/PyPanel/README
new file mode 100644
index 0000000000..301959b5fb
--- /dev/null
+++ b/desktop/PyPanel/README
@@ -0,0 +1,7 @@
+PyPanel is a lightweight panel/taskbar written in Python and C for
+X11 window managers. It can be easily customized to match any desktop
+theme or taste. PyPanel works with EWMH compliant WMs (Openbox,
+PekWM, PyPanel: FVWM, etc.) and is distributed under the GNU General
+Public License v2.
+
+This requires imlib2 and python-xlib.
diff --git a/desktop/PyPanel/slack-desc b/desktop/PyPanel/slack-desc
new file mode 100644
index 0000000000..14f51b5138
--- /dev/null
+++ b/desktop/PyPanel/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+PyPanel: PyPanel (a lightweight panel/taskbar for X11)
+PyPanel:
+PyPanel: PyPanel is a lightweight panel/taskbar written in Python and C for
+PyPanel: X11 window managers. It can be easily customized to match any desktop
+PyPanel: theme or taste. PyPanel works with EWMH compliant WMs (Openbox,
+PyPanel: PekWM, PyPanel: FVWM, etc.) and is distributed under the GNU General
+PyPanel: Public License v2.
+PyPanel:
+PyPanel: Homepage: http://pypanel.sourceforge.net/
+PyPanel:
+PyPanel: