summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Rex Hauser2011-11-14 03:19:11 +0100
committer Robby Workman2011-11-15 04:27:12 +0100
commit779feccc6b7bb203618438d4d5d9b19389e51f28 (patch)
treeb45530526d61ac947d502502ae1627d37ddb2ac9 /desktop
parentbd0330066dcad5b497e06c6f7dd6a08e16869259 (diff)
downloadslackbuilds-779feccc6b7bb203618438d4d5d9b19389e51f28.tar.gz
desktop/bmpanel2: Added (NETWM-compatible panel for X11)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/bmpanel2/README8
-rw-r--r--desktop/bmpanel2/bmpanel2.SlackBuild106
-rw-r--r--desktop/bmpanel2/bmpanel2.info10
-rw-r--r--desktop/bmpanel2/slack-desc19
4 files changed, 143 insertions, 0 deletions
diff --git a/desktop/bmpanel2/README b/desktop/bmpanel2/README
new file mode 100644
index 0000000000..e7f2a4dea1
--- /dev/null
+++ b/desktop/bmpanel2/README
@@ -0,0 +1,8 @@
+bmpanel2 is a nice NETWM-compatible panel for X11, featuring look and
+feel customization via themes, a bunch of widgets (desktop switcher,
+taskbar, launchbar, systray, clock, etcetera), pseudo-transparency support,
+small executable size (~80kB), and small memory footprint (about 2-4 MB).
+
+Configuration of bmpanel2 is done via bmpanel2cfg program or by editing
+the ~/.config/bmpanel2/bmpanel2rc file. Themes can be installed locally
+by placing them in the ~/.local/share/bmpanel2/themes directory.
diff --git a/desktop/bmpanel2/bmpanel2.SlackBuild b/desktop/bmpanel2/bmpanel2.SlackBuild
new file mode 100644
index 0000000000..9dcee2d368
--- /dev/null
+++ b/desktop/bmpanel2/bmpanel2.SlackBuild
@@ -0,0 +1,106 @@
+#!/bin/sh
+
+# Slackware build script for bmpanel2
+
+# Written by Rex Hauser <thundermachinegun[AT]gmail.com>
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=bmpanel2
+VERSION=${VERSION:-20110303_d6e866f}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# You should change this value if you want to build a newer version/commit
+COMMIT=${COMMIT:-d6e866f}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="COPYING INSTALL WMs.txt changes.txt readme.md"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf nsf-$PRGNAM-$COMMIT
+tar xvf $CWD/nsf-$PRGNAM*-g$COMMIT.tar.?z*
+cd nsf-$PRGNAM-$COMMIT
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# FIXME:
+# -DCMAN_INSTALL_DIR (and -DLIB_SUFFIX) has no effect in the build process so we
+# change the manpage destination here. (Or we can just move it later)
+sed -i 's/DESTINATION share\/man\/man1/DESTINATION man\/man1/' man/CMakeLists.txt
+
+# Use absolute path for pidof
+sed -i 's/pidof/\/sbin\/pidof/g' extra/py/bmpanel2.py
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/bmpanel2/bmpanel2.info b/desktop/bmpanel2/bmpanel2.info
new file mode 100644
index 0000000000..38dcaead23
--- /dev/null
+++ b/desktop/bmpanel2/bmpanel2.info
@@ -0,0 +1,10 @@
+PRGNAM="bmpanel2"
+VERSION="20110303_d6e866f"
+HOMEPAGE="http://code.google.com/p/bmpanel2/"
+DOWNLOAD="https://github.com/nsf/bmpanel2/tarball/d6e866f4b33e1ff8bae3598dd17b00f6dfd77c38"
+MD5SUM="ba48fa48d90d160a298241f8441ad685"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Rex Hauser"
+EMAIL="thundermachinegun@gmail.com"
+APPROVED="rworkman"
diff --git a/desktop/bmpanel2/slack-desc b/desktop/bmpanel2/slack-desc
new file mode 100644
index 0000000000..66e6112f55
--- /dev/null
+++ b/desktop/bmpanel2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+bmpanel2: bmpanel2 (NETWM-compatible panel for X11)
+bmpanel2:
+bmpanel2: bmpanel2 is a nice NETWM-compatible panel for X11, featuring:
+bmpanel2: * Look'n'feel customization via themes.
+bmpanel2: * A bunch of widgets: desktop switcher, taskbar, launchbar, systray,
+bmpanel2: clock, decor, empty.
+bmpanel2: * Pseudo-transparency support.
+bmpanel2: * Small number of dependencies and small memory footprint.
+bmpanel2:
+bmpanel2: Home page: http://code.google.com/p/bmpanel2/
+bmpanel2: