summaryrefslogtreecommitdiffstats
path: root/desktop/slock/slock.SlackBuild
diff options
context:
space:
mode:
author Grigorios Bouzakis2010-05-13 00:23:11 +0200
committer Robby Workman2010-05-13 00:23:11 +0200
commite85e44e3d9533395fba60799e3401761ebf9f29d (patch)
tree9931aad5184eecd4875869020788483e1884f781 /desktop/slock/slock.SlackBuild
parent7dea0f944dee06ba0f53a4f6671c282ae843d0a8 (diff)
downloadslackbuilds-e85e44e3d9533395fba60799e3401761ebf9f29d.tar.gz
desktop/slock: Updated for version 0.9
Diffstat (limited to 'desktop/slock/slock.SlackBuild')
-rw-r--r--desktop/slock/slock.SlackBuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/desktop/slock/slock.SlackBuild b/desktop/slock/slock.SlackBuild
index eeca7c2756..92d0e687d3 100644
--- a/desktop/slock/slock.SlackBuild
+++ b/desktop/slock/slock.SlackBuild
@@ -18,10 +18,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -39,15 +42,23 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# This uses our CFLAGS defined above, changes the prefix to /usr and
-# corrects the X11 includes and libs directories
-sed "s/_SLACKCFLAGS_/$SLKCFLAGS/" $CWD/config.mk.patch | patch -p1
+# This uses our CFLAGS defined above
+sed "s/@SLACKCFLAGS@/$SLKCFLAGS/" $CWD/config.mk.patch | patch -p1
# This makes slock requires sgid shadow instead of suid root
patch -p1 < $CWD/slock-use_shadow_group.patch
-make
-make install DESTDIR=$PKG
+make \
+ PREFIX=/usr \
+ X11INC=/usr/include/X11 \
+ X11LIB=/usr/lib${LIBDIRSUFFIX}/X11
+
+make install \
+ PREFIX=/usr \
+ X11INC=/usr/include/X11 \
+ X11LIB=/usr/lib${LIBDIRSUFFIX}/X11 \
+ DESTDIR=$PKG
+
strip --strip-unneeded $PKG/usr/bin/slock
chown root:shadow $PKG/usr/bin/slock
chmod 2755 $PKG/usr/bin/slock
@@ -60,4 +71,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}