summaryrefslogtreecommitdiffstats
path: root/business
diff options
context:
space:
mode:
author B. Watson2022-03-01 20:34:10 +0100
committer Willy Sudiarto Raharjo2022-03-03 09:56:42 +0100
commitbf014701b6abe4a001bb290c6587790c1fbeeae2 (patch)
treee5b5793283c74854f7d8879820d052f141150ead /business
parent80e9be6722d64a2d8ebe8e29b98d2056c552a721 (diff)
downloadslackbuilds-bf014701b6abe4a001bb290c6587790c1fbeeae2.tar.gz
business/trytond: Fix build if Sphinx installed.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'business')
-rw-r--r--business/trytond/README3
-rw-r--r--business/trytond/trytond.SlackBuild34
2 files changed, 18 insertions, 19 deletions
diff --git a/business/trytond/README b/business/trytond/README
index c1eec1fa35..1c53c18481 100644
--- a/business/trytond/README
+++ b/business/trytond/README
@@ -4,6 +4,9 @@ POS, etc. Technical features include a distributed server, flexible
workflows, an object database, a dynamic GUI, customizable reports, and
SOAP and XML-RPC interfaces.
+Optional dependency: Sphinx (autodetected). Required for building the
+HTML documentation (/usr/doc/trytond-*/html/).
+
To add modules, you will need pip.
Before you can use the tryton server, you will have to set up
diff --git a/business/trytond/trytond.SlackBuild b/business/trytond/trytond.SlackBuild
index 667acd50cf..ebf76c7f7b 100644
--- a/business/trytond/trytond.SlackBuild
+++ b/business/trytond/trytond.SlackBuild
@@ -22,25 +22,29 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220301 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix broken cp command, this never worked on 14.2 either, if
+# Sphinx was installed.
+# - only build and install HTML documentation (we don't need multiple
+# formats like qthelp or pickle).
+# - don't install useless INSTALL in doc dir.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=trytond
VERSION=${VERSION:-3.0.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,8 +54,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -75,28 +79,20 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
if [ -x /usr/bin/sphinx-build ] ; then
( cd $TMP/$PRGNAM-$VERSION/doc
make html
- make pickle
- make json
- make htmlhelp
- make qthelp
- PAPER=${PAPER:-letter} make latex
- cp -a _build_/* $PKG/usr/doc/$PRGNAM-$VERSION
+ cp -a _build/html $PKG/usr/doc/$PRGNAM-$VERSION
)
fi
-cp -a COPYRIGHT CHANGELOG INSTALL LICENSE README TODO $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a COPYRIGHT CHANGELOG LICENSE README TODO $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install