summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author B. Watson2014-01-23 07:45:47 +0100
committer Erik Hanson2014-01-30 06:21:10 +0100
commit09cfdc2c2d231c9078971d4ee2c15307383ab202 (patch)
tree20154b5a80409f59cf93ef9470f7356230d724f6 /audio
parent4641052e0a8521f5a7bf5ddce3d228d5d537f64f (diff)
downloadslackbuilds-09cfdc2c2d231c9078971d4ee2c15307383ab202.tar.gz
audio/gtklick: Added (GUI metronome for JACK).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/gtklick/README10
-rw-r--r--audio/gtklick/doinst.sh3
-rw-r--r--audio/gtklick/gtklick.SlackBuild67
-rw-r--r--audio/gtklick/gtklick.info10
-rw-r--r--audio/gtklick/slack-desc19
5 files changed, 109 insertions, 0 deletions
diff --git a/audio/gtklick/README b/audio/gtklick/README
new file mode 100644
index 0000000000..ca23532447
--- /dev/null
+++ b/audio/gtklick/README
@@ -0,0 +1,10 @@
+gtklick (GUI metronome for JACK)
+
+gtklick is a simple metronome with an easy-to-use GTK interface. As
+a frontend to klick, it supports all of klick's features.
+
+klick must be built with OSC (liblo) support to work with gtklick. If
+you get 'timeout waiting for klick to start', rebuild your klick package
+without LIBLO=no.
+
+You must build this package using "su -" instead of regular "su". \ No newline at end of file
diff --git a/audio/gtklick/doinst.sh b/audio/gtklick/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/audio/gtklick/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/audio/gtklick/gtklick.SlackBuild b/audio/gtklick/gtklick.SlackBuild
new file mode 100644
index 0000000000..8b4fe061db
--- /dev/null
+++ b/audio/gtklick/gtklick.SlackBuild
@@ -0,0 +1,67 @@
+#!/bin/sh
+
+# Slackware build script for gtklick
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=gtklick
+VERSION=${VERSION:-0.6.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a [A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/gtklick/gtklick.info b/audio/gtklick/gtklick.info
new file mode 100644
index 0000000000..e15af8e06c
--- /dev/null
+++ b/audio/gtklick/gtklick.info
@@ -0,0 +1,10 @@
+PRGNAM="gtklick"
+VERSION="0.6.4"
+HOMEPAGE="http://das.nasophon.de/gtklick/"
+DOWNLOAD="http://das.nasophon.de/download/gtklick-0.6.4.tar.gz"
+MD5SUM="47596c45e3b691cc78fa410bf320085f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="klick"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/audio/gtklick/slack-desc b/audio/gtklick/slack-desc
new file mode 100644
index 0000000000..b3aa07656b
--- /dev/null
+++ b/audio/gtklick/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+gtklick: gtklick (GUI metronome for JACK)
+gtklick:
+gtklick: gtklick is a simple metronome with an easy-to-use GTK interface.
+gtklick:
+gtklick:
+gtklick:
+gtklick:
+gtklick:
+gtklick:
+gtklick:
+gtklick: