summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Robby Workman2011-03-09 17:21:34 +0100
committer Robby Workman2011-03-10 06:15:50 +0100
commitebfa99066dd8a26f9667379b615b8e3ae4a946a6 (patch)
tree549fd35830903ca786c5135065a9b831fee0c6da /audio
parentd07dc7b444b669dc1993ec56d810c96f616cda56 (diff)
downloadslackbuilds-ebfa99066dd8a26f9667379b615b8e3ae4a946a6.tar.gz
audio/moc: Removed. This is part of Slackware 13.37.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/moc/Makefile.patch11
-rw-r--r--audio/moc/README8
-rw-r--r--audio/moc/moc.SlackBuild108
-rw-r--r--audio/moc/moc.info10
-rw-r--r--audio/moc/slack-desc19
5 files changed, 0 insertions, 156 deletions
diff --git a/audio/moc/Makefile.patch b/audio/moc/Makefile.patch
deleted file mode 100644
index 4859504b0d..0000000000
--- a/audio/moc/Makefile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- moc-2.5.0-alpha4.orig/Makefile.in 2009-09-25 11:57:33.000000000 +0300
-+++ moc-2.5.0-alpha4/Makefile.in 2010-04-11 03:26:29.856249035 +0300
-@@ -245,7 +245,7 @@
- build_vendor = @build_vendor@
- datadir = @datadir@
- datarootdir = @datarootdir@
--docdir = $(datadir)/doc/$(PACKAGE)
-+docdir = @docdir@
- dvidir = @dvidir@
- exec_prefix = @exec_prefix@
- host = @host@
diff --git a/audio/moc/README b/audio/moc/README
deleted file mode 100644
index 2688843951..0000000000
--- a/audio/moc/README
+++ /dev/null
@@ -1,8 +0,0 @@
-MOC is a console audio player with simple ncurses interface.
-It supports OGG, wave, and MP3 formats. Just run mocp, go to some directory
-using menu and press enter to start playing file, program will be playing
-automaticaly rest of the files in the directory.
-With no options and no file arguments the program begins in current directory
-or in MusicDir if StartIn‐MusicDir option is set. If you give a directory on
-the command line, MOC will try to go there. With files or multiple directories,
-everything will be added to the playlist recursively.
diff --git a/audio/moc/moc.SlackBuild b/audio/moc/moc.SlackBuild
deleted file mode 100644
index c956ef55d6..0000000000
--- a/audio/moc/moc.SlackBuild
+++ /dev/null
@@ -1,108 +0,0 @@
-#!/bin/sh
-# Slackware build script for moc
-
-# (C) 2009 Michael Wagner <slackware.wagnerm@arcor.de>
-# Copyright 2010 Grigorios Bouzakis <grbzks@xsmail.com>
-# All rights reserved.
-#
-# Permission to use, copy, modify, and distribute this software for any purpose
-# with or without fee is hereby granted, provided that the above copyright
-# notice and this permission notice appear in all copies.
-#
-# THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES,
-# INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND
-# FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE
-# AUTHORS AND COPYRIGHT HOLDERS AND THEIR CONTRIBUTORS BE LIABLE FOR ANY
-# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
-# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
-# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=moc
-VERSION=${VERSION:-2.5.0_alpha4}
-SRCVER=2.5.0-alpha4
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS TODO"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$SRCVER
-tar xvf $CWD/$PRGNAM-$SRCVER.tar.bz2
-cd $PRGNAM-$SRCVER
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-patch -p1 < $CWD/Makefile.patch
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --disable-debug \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/moc/moc.info b/audio/moc/moc.info
deleted file mode 100644
index 786297bb0a..0000000000
--- a/audio/moc/moc.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="moc"
-VERSION="2.5.0_alpha4"
-HOMEPAGE="http://moc.daper.net/"
-DOWNLOAD="ftp://ftp.daper.net/pub/soft/moc/unstable/moc-2.5.0-alpha4.tar.bz2"
-MD5SUM="2dd0cb6481d77fda09c58ec3154a21c0"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Grigorios Bouzakis"
-EMAIL="grbzks@xsmail.com"
-APPROVED="dsomero"
diff --git a/audio/moc/slack-desc b/audio/moc/slack-desc
deleted file mode 100644
index 77a6e737ef..0000000000
--- a/audio/moc/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler----------------------------------------------------------|
-moc: moc (console audio player)
-moc:
-moc: MOC is a console audio player with a simple ncurses interface.
-moc:
-moc: Homepage: http://moc.daper.net/
-moc:
-moc:
-moc:
-moc:
-moc:
-moc: