summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author B. Watson2011-08-27 00:03:23 +0200
committer Niels Horn2011-08-27 00:03:23 +0200
commitedcad06d1d5fa7354648d2cdf4bb1a17e0e83a09 (patch)
tree2984067feb5435d8a3f62a9a77211db4754fa813 /audio
parent7ab8ff8f34347e0a1075b00900a56110e033b988 (diff)
downloadslackbuilds-edcad06d1d5fa7354648d2cdf4bb1a17e0e83a09.tar.gz
audio/bristol: Updated for version 0.60.8 (+new maintainer)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/bristol/README9
-rw-r--r--audio/bristol/bristol.SlackBuild24
-rw-r--r--audio/bristol/bristol.info10
-rw-r--r--audio/bristol/doinst.sh13
4 files changed, 28 insertions, 28 deletions
diff --git a/audio/bristol/README b/audio/bristol/README
index 28804e9b88..98c05664fe 100644
--- a/audio/bristol/README
+++ b/audio/bristol/README
@@ -1,3 +1,12 @@
Bristol is synth emulation package for a diverse range of vintage
synthesisers, electric pianos and organs. The application consists of
a multithreaded audio synthesizer and a user interface called brighton.
+
+jack-audio-connection-kit and liblo are optional (but highly recommended)
+dependencies.
+
+Note: If bristol is already installed on the build host, the build will
+fail. I assume the bristol authors have a good reason for wanting this
+to happen, so I don't alter this behaviour. If you want to try, edit
+the SlackBuild and add --disable-version-check to the configure command.
+Otherwise, do a "removepkg bristol" before building.
diff --git a/audio/bristol/bristol.SlackBuild b/audio/bristol/bristol.SlackBuild
index 80f3db3e7b..1df9947eeb 100644
--- a/audio/bristol/bristol.SlackBuild
+++ b/audio/bristol/bristol.SlackBuild
@@ -2,10 +2,11 @@
# Slackware build script for bristol
-# Written by Zbigniew Baniewski, zb@ispid.com.pl
+# Written by Zbigniew Baniewski, zb@ispid.com.pl (email no longer valid?)
+# Modified by B. Watson, yalhcru@gmail.com
PRGNAM=bristol
-VERSION=0.60.7
+VERSION=0.60.8
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -51,6 +52,12 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Hard-coded /usr/lib and /usr/X11R6/lib sucks.
+sed -i "s,/usr/lib,/usr/lib$LIBDIRSUFFIX,g" \
+ configure Makefile.* brighton/Makefile.* libbrightonX11/Makefile.*
+sed -i "s,/usr/X11R6/lib,/usr/X11R6/lib$LIBDIRSUFFIX,g" \
+ configure Makefile.* brighton/Makefile.* libbrightonX11/Makefile.*
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -59,19 +66,16 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
+ --disable-static \
+ --enable-shared \
--build=$ARCH-slackware-linux
make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+make install-strip DESTDIR=$PKG
+# "install -m0644" rather than "cp -a" so the docs aren't executable!
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING COPYING.GPL NEWS README ChangeLog \
+install -m0644 AUTHORS COPYING COPYING.GPL NEWS README ChangeLog \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/audio/bristol/bristol.info b/audio/bristol/bristol.info
index b5f75b56cb..80be461515 100644
--- a/audio/bristol/bristol.info
+++ b/audio/bristol/bristol.info
@@ -1,10 +1,10 @@
PRGNAM="bristol"
-VERSION="0.60.7"
+VERSION="0.60.8"
HOMEPAGE="http://bristol.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/bristol/bristol-0.60.7.tar.gz"
-MD5SUM="21c3fa8ebe9ba4bab3704b91a70ed7cb"
+DOWNLOAD="http://downloads.sourceforge.net/bristol/bristol-0.60.8.tar.gz"
+MD5SUM="0e4cef941ba53ccc64d654fea1e0d572"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Zbigniew Baniewski"
-EMAIL="zb@ispid.com.pl"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
APPROVED="Niels Horn"
diff --git a/audio/bristol/doinst.sh b/audio/bristol/doinst.sh
deleted file mode 100644
index 19a6ff6ac8..0000000000
--- a/audio/bristol/doinst.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-