summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Michales Michaloudes2011-07-11 05:10:51 +0200
committer Niels Horn2011-07-15 02:54:03 +0200
commitd74fdc7745011dc6b14c6d7c5e75ad3b40ad1301 (patch)
tree7057afad07480f20d0b809dd939c570ed6a7ebd2 /audio
parent195a9ddcee263ae5b66853b3596a70efd0d0ef63 (diff)
downloadslackbuilds-d74fdc7745011dc6b14c6d7c5e75ad3b40ad1301.tar.gz
audio/stops: Added (Sound definitions for aeolus)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/stops/README8
-rw-r--r--audio/stops/aeolus.conf.new3
-rw-r--r--audio/stops/doinst.sh25
-rw-r--r--audio/stops/slack-desc19
-rw-r--r--audio/stops/stops.SlackBuild48
-rw-r--r--audio/stops/stops.info10
6 files changed, 113 insertions, 0 deletions
diff --git a/audio/stops/README b/audio/stops/README
new file mode 100644
index 0000000000..01c26e8321
--- /dev/null
+++ b/audio/stops/README
@@ -0,0 +1,8 @@
+This is not a program or library, but sound definitions for aeolus.
+
+If you want write privileges, copy /usr/share/aeolus/stops-0.3.0 to your
+home folder and edit /etc/aeolus.conf accordingly.
+
+Requires: clthreads, clxclient, clalsadrv, jack-audio-connection-kit,
+aeolus
+
diff --git a/audio/stops/aeolus.conf.new b/audio/stops/aeolus.conf.new
new file mode 100644
index 0000000000..e01570de81
--- /dev/null
+++ b/audio/stops/aeolus.conf.new
@@ -0,0 +1,3 @@
+# Aeolus default options
+-u -S /usr/share/aeolus/stops-0.3.0
+
diff --git a/audio/stops/doinst.sh b/audio/stops/doinst.sh
new file mode 100644
index 0000000000..0040669ecc
--- /dev/null
+++ b/audio/stops/doinst.sh
@@ -0,0 +1,25 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+preserve_perms() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ if [ -e $OLD ]; then
+ cp -a $OLD ${NEW}.incoming
+ cat $NEW > ${NEW}.incoming
+ mv ${NEW}.incoming $NEW
+ fi
+ config $NEW
+}
+
+preserve_perms etc/aeolus.conf.new
diff --git a/audio/stops/slack-desc b/audio/stops/slack-desc
new file mode 100644
index 0000000000..06c512cf0d
--- /dev/null
+++ b/audio/stops/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+stops: stops (Sound definitions for aeolus)
+stops:
+stops: Sound definitions for aeolus.
+stops:
+stops:
+stops:
+stops:
+stops:
+stops:
+stops:
+stops:
diff --git a/audio/stops/stops.SlackBuild b/audio/stops/stops.SlackBuild
new file mode 100644
index 0000000000..d9ce7e71d9
--- /dev/null
+++ b/audio/stops/stops.SlackBuild
@@ -0,0 +1,48 @@
+#!/bin/sh
+# Slackware build script for <stops>
+# Written by Michales Michaloudes korgie@gmail.com
+
+
+PRGNAM=stops
+VERSION=${VERSION:-0.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+ARCH=noarch
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xjvf $CWD/$PRGNAM-$VERSION.tar.bz2 || exit 1
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+mkdir -p $PKG/etc
+cat $CWD/aeolus.conf.new > $PKG/etc/aeolus.conf.new
+
+mkdir -p $PKG/usr/share/aeolus/$PRGNAM-$VERSION
+cp -ar $TMP/$PRGNAM-$VERSION/ $PKG/usr/share/aeolus/
+rm $PKG/usr/share/aeolus/$PRGNAM-$VERSION/Makefile
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/stops/stops.info b/audio/stops/stops.info
new file mode 100644
index 0000000000..5589782749
--- /dev/null
+++ b/audio/stops/stops.info
@@ -0,0 +1,10 @@
+PRGNAM="stops"
+VERSION="0.3.0"
+HOMEPAGE="http://kokkinizita.linuxaudio.org/linuxaudio/aeolus/index.html"
+DOWNLOAD="http://kokkinizita.linuxaudio.org/linuxaudio/downloads/stops-0.3.0.tar.bz2"
+MD5SUM="2a7b1cae820408fa1cc655800d08d88f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Michales Michaloudes"
+EMAIL="korgie@gmail.com"
+APPROVED="dsomero"