summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author B. Watson2011-08-09 20:24:32 +0200
committer Niels Horn2011-08-09 20:24:32 +0200
commitd2dd7e84f591d429b3a897b558f7c027d36f7e8a (patch)
tree4427736b81d6803111e811648226f31826fdf36a /audio
parentb8bedd097ac5cd882f7241cabfc3069ae8e0f768 (diff)
downloadslackbuilds-d2dd7e84f591d429b3a897b558f7c027d36f7e8a.tar.gz
audio/tap_plugins: Added (audio plugins for LADSPA)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/tap_plugins/README11
-rw-r--r--audio/tap_plugins/reverbed.sh14
-rw-r--r--audio/tap_plugins/slack-desc19
-rw-r--r--audio/tap_plugins/tap_plugins.SlackBuild146
-rw-r--r--audio/tap_plugins/tap_plugins.info14
5 files changed, 204 insertions, 0 deletions
diff --git a/audio/tap_plugins/README b/audio/tap_plugins/README
new file mode 100644
index 0000000000..11e0bc64b2
--- /dev/null
+++ b/audio/tap_plugins/README
@@ -0,0 +1,11 @@
+tap (audio plugins for LADSPA)
+
+Tom's Audio Processing plugins is a selection of LADSPA plugins for audio
+engineering on the Linux platform. Intended for use in a professional
+DAW environment such as Ardour, it includes high quality reverberation,
+echo, eq, limiter & more.
+
+This package includes the main tap-plugins distribution, plus the
+tap-plugins-doc and tap-reverbed (TAP Reverb Editor) distributions.
+
+This requires ladspa_sdk and jack-audio-connection-kit.
diff --git a/audio/tap_plugins/reverbed.sh b/audio/tap_plugins/reverbed.sh
new file mode 100644
index 0000000000..b1cb7c2cfe
--- /dev/null
+++ b/audio/tap_plugins/reverbed.sh
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+# Wrapper script for reverbed. When reverbed is run, it requires its
+# config file to already be present in the user's home directory. If not,
+# it'll exit, printing a message on the terminal... but if the user launched
+# it via an icon from a desktop environment, he won't see the error (it will
+# appear to silently fail to run). To avoid confusion, this script creates
+# the config file if & only if it doesn't already exist.
+
+if [ ! -e ~/.reverbed ]; then
+ cat /usr/doc/tap_plugins-@VERSION@/dot.reverbed.default > ~/.reverbed
+fi
+
+exec /usr/bin/reverbed.bin
diff --git a/audio/tap_plugins/slack-desc b/audio/tap_plugins/slack-desc
new file mode 100644
index 0000000000..c5c577d521
--- /dev/null
+++ b/audio/tap_plugins/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+tap_plugins: tap (audio plugins for LADSPA)
+tap_plugins:
+tap_plugins: Tom's Audio Processing plugins is a selection of LADSPA plugins
+tap_plugins: for audio engineering on the Linux platform. Intended for use in a
+tap_plugins: professional DAW environment such as Ardour, it includes high quality
+tap_plugins: reverberation, echo, eq, limiter & more.
+tap_plugins:
+tap_plugins: This packages includes the main tap-plugins distribution, plus the
+tap_plugins: tap-plugins-doc and tap-reverbed (TAP Reverb Editor) distributions.
+tap_plugins:
+tap_plugins:
diff --git a/audio/tap_plugins/tap_plugins.SlackBuild b/audio/tap_plugins/tap_plugins.SlackBuild
new file mode 100644
index 0000000000..6896331416
--- /dev/null
+++ b/audio/tap_plugins/tap_plugins.SlackBuild
@@ -0,0 +1,146 @@
+#!/bin/sh
+
+# Slackware build script for tap_plugins
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+PRGNAM=tap_plugins
+VERSION=${VERSION:-0.7.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+# You almost certainly do NOT want FORCE_SLACK_CFLAGS=yes
+# (it's here for purists, and for troubleshooting purposes)
+FORCE_SLACK_CFLAGS=${FORCE_SLACK_CFLAGS:-no}
+
+# You may need FORCE_SYSTEM_LADSPA_H=yes if building against a version
+# of ladspa_sdk other than 1.13 (try without first)
+FORCE_SYSTEM_LADSPA_H=${FORCE_SYSTEM_LADSPA_H:-no}
+
+PLUGINS_SRCNAM=tap-plugins
+DOCS_SRCNAM=tap-plugins-doc
+DOCS_VERSION=20040817
+REVERBED_SRCNAM=tap-reverbed
+REVERBED_VERSION=r0
+
+set -e
+
+# First build the plugins
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PLUGINS_SRCNAM-$VERSION
+tar xvf $CWD/$PLUGINS_SRCNAM-$VERSION.tar.gz
+cd $PLUGINS_SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+if [ "$FORCE_SLACK_CFLAGS" = "yes" ]; then
+ sed -i '/^CFLAGS/s/\(=.*\) -O3 \(.*\)\(-c\)/\1 '"$SLKCFLAGS"' \3/' Makefile
+fi
+
+if [ "$FORCE_SYSTEM_LADSPA_H" = "yes" ]; then
+ rm -f ladspa.h
+ cp /usr/include/ladspa.h .
+fi
+
+make
+strip *.so
+make install \
+ INSTALL_PLUGINS_DIR=$PKG/usr/lib$LIBDIRSUFFIX/ladspa/ \
+ INSTALL_LRDF_DIR=$PKG/usr/share/ladspa/rdf/
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+for i in COPYING CREDITS README; do
+ cat $i > $PKG/usr/doc/$PRGNAM-$VERSION/$i.plugins
+done
+
+# Now build the reverb editor
+cd $TMP
+rm -rf $REVERBED_SRCNAM-$REVERBED_VERSION
+tar xvf $CWD/$REVERBED_SRCNAM-$REVERBED_VERSION.tar.gz
+cd $REVERBED_SRCNAM-$REVERBED_VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --build=$ARCH-slackware-linux
+
+if [ "$FORCE_SLACK_CFLAGS" = "yes" ]; then
+ # CFLAGS not supported by autoconf!
+ sed -i '/^CFLAGS/s/=.*-fPIC/= '"$SLKCFLAGS"' -fPIC/' src/Makefile
+fi
+
+make
+
+# more trouble than it's worth to get 'make install' to handle DESTDIR
+strip src/reverbed
+mkdir -p $PKG/usr/bin
+cp src/reverbed $PKG/usr/bin/reverbed.bin
+cat src/.reverbed > $PKG/usr/doc/$PRGNAM-$VERSION/dot.reverbed.default
+
+# Shell script wrapper
+sed 's/@VERSION@/'$VERSION'/g' < $CWD/reverbed.sh > $PKG/usr/bin/reverbed
+chmod 0755 $PKG/usr/bin/reverbed
+
+# ChangeLog and NEWS are 0-length placeholders
+for i in AUTHORS COPYING README; do
+ cat $i > $PKG/usr/doc/$PRGNAM-$VERSION/$i.reverbed
+done
+
+# Now package up the HTML docs
+cd $PKG/usr/doc/$PRGNAM-$VERSION
+ tar xvf $CWD/$DOCS_SRCNAM-$DOCS_VERSION.tar.gz
+ chown -R root:root .
+ find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+cd -
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.SBo
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/tap_plugins/tap_plugins.info b/audio/tap_plugins/tap_plugins.info
new file mode 100644
index 0000000000..6ba5f44119
--- /dev/null
+++ b/audio/tap_plugins/tap_plugins.info
@@ -0,0 +1,14 @@
+PRGNAM="tap_plugins"
+VERSION="0.7.1"
+HOMEPAGE="http://tap-plugins.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/project/tap-plugins/tap-plugins/0.7.1/tap-plugins-0.7.1.tar.gz \
+ http://downloads.sourceforge.net/project/tap-plugins/tap-reverbed/Release%200/tap-reverbed-r0.tar.gz \
+ http://downloads.sourceforge.net/project/tap-plugins/tap-plugins-doc/2004-08-17/tap-plugins-doc-20040817.tar.gz"
+MD5SUM="87a7d378c4186ad83d98518e003c68a1 \
+ f8b15df131b45d2d5ef2e8d7c34e9a29 \
+ 9a320210a7a9417487ceb31d6e5c21be"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
+APPROVED="Niels Horn"