summaryrefslogtreecommitdiffstats
path: root/audio/vocoder
diff options
context:
space:
mode:
author B. Watson2017-03-13 00:19:25 +0100
committer Willy Sudiarto Raharjo2017-03-18 00:58:56 +0100
commitbf15ef836848839a507b2ecd95f115f8f8528e91 (patch)
tree02f234e8ed1b108b27996e2c1f776fd59f98576f /audio/vocoder
parentfd27d2b6932c414351c63fa70346e94753012754 (diff)
downloadslackbuilds-bf15ef836848839a507b2ecd95f115f8f8528e91.tar.gz
audio/vocoder: Minor hygiene fixes.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'audio/vocoder')
-rw-r--r--audio/vocoder/vocoder.SlackBuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/audio/vocoder/vocoder.SlackBuild b/audio/vocoder/vocoder.SlackBuild
index 2e05b2b34b..be9c003c93 100644
--- a/audio/vocoder/vocoder.SlackBuild
+++ b/audio/vocoder/vocoder.SlackBuild
@@ -6,9 +6,15 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20170312 bkw:
+# - actually use SLKCFLAGS
+# - stop fluid from writing to /root/.fltk/
+# - use "-include unistd.h" compiler opt instead of a patch
+# - BUILD=2
+
PRGNAM=vocoder
VERSION=${VERSION:-0.29}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -53,10 +59,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Add a couple missing #include <unistd.h>
-patch -p1 < $CWD/compile_fix.diff
+sed -i "s,-O2,$SLKCFLAGS -include unistd.h," src/Makefile
+sed -i "/^CFLAGS/s,\$, $SLKCFLAGS -include unistd.h," util/Makefile
-make
+# Override $HOME since fluid insists on writing useless stuff there.
+# In case the user's using ccache, this changes the cache dir, so we
+# put it back like it was (no harm done if user not using ccache).
+CCACHE_DIR=${CCACHE_DIR:-$HOME/.ccache} \
+HOME=$( pwd ) \
+ make
# manual install (no install target in Makefile)
mkdir -p $PKG/usr/bin