summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Fellype do Nascimento2021-12-30 13:45:28 +0100
committer Willy Sudiarto Raharjo2021-12-31 02:27:05 +0100
commit89584b4e7417809bd47b8566c1b5db7112463894 (patch)
tree6539b8ee369798c3ce353fd18b7b6e4b7b9f77af /academic
parentef32447ddb0406f0795430ac4ff2d7b1f16c74cf (diff)
downloadslackbuilds-89584b4e7417809bd47b8566c1b5db7112463894.tar.gz
academic/gmsh: Updated for version 4.9.2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/gmsh/README6
-rw-r--r--academic/gmsh/gmsh.SlackBuild31
-rw-r--r--academic/gmsh/gmsh.info6
3 files changed, 35 insertions, 8 deletions
diff --git a/academic/gmsh/README b/academic/gmsh/README
index e2980522f6..2a501768db 100644
--- a/academic/gmsh/README
+++ b/academic/gmsh/README
@@ -20,3 +20,9 @@ the documentation of the C++, C, Python and Julia API.
The source code repository contains many examples written using both
the built-in script language (see e.g. the tutorials and demos) and
the API.
+
+Note:
+If you want to build Getdp with Gmsh support is necessary to compile
+also a static gmsh library (libgmsh.a). This can be done by passing
+BUILDSTATICLIB=yes
+prior to run gmsh.SlackBuild
diff --git a/academic/gmsh/gmsh.SlackBuild b/academic/gmsh/gmsh.SlackBuild
index 32d8a75d81..029fada39a 100644
--- a/academic/gmsh/gmsh.SlackBuild
+++ b/academic/gmsh/gmsh.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for gmsh
-# Copyright 2020 Fellype do Nascimento, Campinas, Brazil
+# Copyright 2020-2022 Fellype do Nascimento, Guaratingueta, Brazil
#
# Based on SlackBuild by Loris Vincenzi and PKGBUILD for gmsh at AUR
#
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gmsh
-VERSION=${VERSION:-4.5.4}
+VERSION=${VERSION:-4.9.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,13 +79,36 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# In order build getdp with gmsh support it is needed to build
+# a small static Gmsh library first
+# do it using BUILDSTATICLIB=yes ./gmsh.SlackBuild
+# default is BUILDSTATICLIB=no
+if [ "${BUILDSTATICLIB:-no}" = "yes" ]; then
+ echo "**building a static library for gmsh**"
+ mkdir lib
+ cd lib
+ cmake -DDEFAULT=0 \
+ -DENABLE_PARSER=1 \
+ -DENABLE_POST=1 \
+ -DENABLE_ANN=1 \
+ -DENABLE_BLAS_LAPACK=1 \
+ -DENABLE_BUILD_LIB=1 \
+ -DENABLE_PRIVATE_API=1 \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ ..
+ make lib
+ make install/fast DESTDIR=$PKG/
+ cd ..
+fi
+
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr \
-DCMAKE_INSTALL_DOCDIR:PATH=/usr/share/gmsh \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DENABLE_BUILD_SHARED=ON \
+ -DENABLE_BLAS_LAPACK=1 \
+ -DENABLE_BUILD_SHARED=1 \
-DENABLE_PETSC=OFF \
-DENABLE_SLEPC=OFF \
..
@@ -100,7 +123,6 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
install -d "$PKG/usr/share/pixmaps/$PRGNAM"
install -m644 utils/icons/*.png "$PKG/usr/share/pixmaps/$PRGNAM"
-install -D -m644 utils/icons/solid_32x32.png "$PKG/usr/share/icons/$PRGNAM.png"
install -D -m644 utils/icons/$PRGNAM.svg "$PKG/usr/share/icons/hicolor/scalable/apps/$PRGNAM.svg"
desktop-file-install --dir="$PKG/usr/share/applications" "$CWD/$PRGNAM.desktop"
@@ -116,7 +138,6 @@ mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGELOG.txt CREDITS.txt LICENSE.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
rm $PKG/usr/share/gmsh/*.txt
-rm -Rf $PKG/tmp
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/academic/gmsh/gmsh.info b/academic/gmsh/gmsh.info
index f628e2a4c5..9ff8693389 100644
--- a/academic/gmsh/gmsh.info
+++ b/academic/gmsh/gmsh.info
@@ -1,8 +1,8 @@
PRGNAM="gmsh"
-VERSION="4.5.4"
+VERSION="4.9.2"
HOMEPAGE="http://gmsh.info/"
-DOWNLOAD="http://gmsh.info/src/gmsh-4.5.4-source.tgz"
-MD5SUM="dc225d64508468107eda763915d9c959"
+DOWNLOAD="http://gmsh.info/src/gmsh-4.9.2-source.tgz"
+MD5SUM="be2fe474662d09431b5abf43a4e1c41b"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="fltk lapack med OpenCASCADE"