summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Aleksandar Samardzic2010-05-11 20:00:01 +0200
committer Robby Workman2010-05-11 20:00:01 +0200
commitca5958b5695936d176ff8a07b07bf12e9d327f86 (patch)
treec23e46e4e24b12b21625911d5b542f08623e9406 /academic
parent4994e71c55c551c7d23b4c5530c5430bdd6b7f23 (diff)
downloadslackbuilds-ca5958b5695936d176ff8a07b07bf12e9d327f86.tar.gz
academic/matplotlib: Added to 12.0 repository
Diffstat (limited to 'academic')
-rw-r--r--academic/matplotlib/README9
-rw-r--r--academic/matplotlib/matplotlib.SlackBuild51
-rw-r--r--academic/matplotlib/matplotlib.info8
-rw-r--r--academic/matplotlib/slack-desc19
4 files changed, 87 insertions, 0 deletions
diff --git a/academic/matplotlib/README b/academic/matplotlib/README
new file mode 100644
index 0000000000..9ca76c5376
--- /dev/null
+++ b/academic/matplotlib/README
@@ -0,0 +1,9 @@
+Matplotlib is a plotting library for Python which uses syntax similar to
+MATLAB. The library provides a "pylab" interface which is procedural
+and based on a state machine, like OpenGL. There is also an OOP
+interface which has less thorough documentation and greater complexity.
+Using the OOP interface, matplotlib plots can be embedded in
+applications using generic GUI toolkits like wxPython, Qt or GTK.
+
+Matplotlib requires NumPy, which is also available at SlackBuilds.org.
+Also, pygtk is an optional dependency.
diff --git a/academic/matplotlib/matplotlib.SlackBuild b/academic/matplotlib/matplotlib.SlackBuild
new file mode 100644
index 0000000000..3e49aa3e00
--- /dev/null
+++ b/academic/matplotlib/matplotlib.SlackBuild
@@ -0,0 +1,51 @@
+#!/bin/sh
+
+# Slackware build script for matplotlib
+
+# Written by Aleksandar B. Samardzic <asamardzic@matf.bg.ac.yu>
+
+NAME=matplotlib
+VERSION=0.90.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$NAME}
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP || exit 1
+rm -rf $NAME-$VERSION
+tar xvf $CWD/$NAME-$VERSION.tar.gz || exit 1
+cd $NAME-$VERSION || exit 1
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py build
+python setup.py install --root $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$NAME-$VERSION
+install -m 0644 API_CHANGES CHANGELOG INSTALL INTERACTIVE KNOWN_BUGS \
+ NUMARRAY_ISSUES README TODO $PKG/usr/doc/$NAME-$VERSION
+cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$NAME-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/academic/matplotlib/matplotlib.info b/academic/matplotlib/matplotlib.info
new file mode 100644
index 0000000000..5c82bc49f4
--- /dev/null
+++ b/academic/matplotlib/matplotlib.info
@@ -0,0 +1,8 @@
+PRGNAM="matplotlib"
+VERSION="0.90.1"
+HOMEPAGE="http://matplotlib.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/matplotlib/matplotlib-0.90.1.tar.gz"
+MD5SUM="e1344bd72660e7c9c0b7540a72cc45b8"
+MAINTAINER="Aleksandar B. Samardzic"
+EMAIL="asamardzic@matf.bg.ac.yu"
+APPROVED="rworkman"
diff --git a/academic/matplotlib/slack-desc b/academic/matplotlib/slack-desc
new file mode 100644
index 0000000000..30b477b4d5
--- /dev/null
+++ b/academic/matplotlib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+matplotlib: matplotlib (a Python 2D plotting library)
+matplotlib:
+matplotlib: Matplotlib is a plotting library for Python which uses
+matplotlib: syntax similar to MATLAB. Matplotlib produces publication
+matplotlib: quality figures in a variety of hardcopy formats and
+matplotlib: interactive environments across platforms.
+matplotlib:
+matplotlib: Matplotlib home page is: http://matplotlib.sourceforge.net/
+matplotlib:
+matplotlib:
+matplotlib: