summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Fellype do Nascimento2019-09-21 17:25:32 +0200
committer Willy Sudiarto Raharjo2019-09-21 17:25:32 +0200
commitcf8191f45087d44be89dd6b4eb41021ac5c5340f (patch)
tree6eea6c2834efeba35b6a8e3169fff6a2bcd3f4f9 /academic
parent7dd6c37a54452fa8873db62f1e645dea3374af45 (diff)
downloadslackbuilds-cf8191f45087d44be89dd6b4eb41021ac5c5340f.tar.gz
academic/FreeFem: Added (non-linear multiphysics software).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/FreeFem/FreeFem.SlackBuild104
-rw-r--r--academic/FreeFem/FreeFem.info14
-rw-r--r--academic/FreeFem/README12
-rw-r--r--academic/FreeFem/slack-desc19
4 files changed, 149 insertions, 0 deletions
diff --git a/academic/FreeFem/FreeFem.SlackBuild b/academic/FreeFem/FreeFem.SlackBuild
new file mode 100644
index 0000000000..392e25396d
--- /dev/null
+++ b/academic/FreeFem/FreeFem.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/sh
+
+# Slackware build script for SciDAVis
+# Based on the Slackware 14.2 SlackBuild and on PKGBUILD script for freefem from AUR
+#
+# Copyright 2019, Fellype do Nascimento, Campinas - Brazil
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=FreeFem
+VERSION=${VERSION:-4.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ SPEC=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ SPEC=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ SPEC="-spec linux-g++-64"
+fi
+
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-sources-$VERSION
+tar xvf $CWD/$PRGNAM-sources-$VERSION.tar.gz
+cd $PRGNAM-sources-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p 3rdparty/pkg
+cp $CWD/metis-5.1.0.tar.gz 3rdparty/pkg
+cp $CWD/tetgen1.5.1-beta1.tar.gz 3rdparty/pkg
+
+autoreconf -i
+
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-mumps \
+ --with-mpi=/usr/bin/mpic++ \
+ --enable-hpddm \
+ --enable-opengl
+
+find . -name Makefile -exec sed -i 's+^gcc+gcc =+' {} \;
+find . -name Makefile -exec sed -i 's+^dir+dir =+' {} \;
+
+## TODO: Enable mumps - FreeFem fails to compile with this option enabled up to now
+
+make
+make install DESTDIR=$PKG
+
+find "$PKG"/usr/lib/ff++/ -name "*.h" -exec chmod o+r {} \;
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/FreeFem/FreeFem.info b/academic/FreeFem/FreeFem.info
new file mode 100644
index 0000000000..2f74b29ae1
--- /dev/null
+++ b/academic/FreeFem/FreeFem.info
@@ -0,0 +1,14 @@
+PRGNAM="FreeFem"
+VERSION="4.4"
+HOMEPAGE="https://freefem.org/"
+DOWNLOAD="https://github.com/FreeFem/FreeFem-sources/archive/v4.4/FreeFem-sources-4.4.tar.gz \
+ http://glaros.dtc.umn.edu/gkhome/fetch/sw/metis/metis-5.1.0.tar.gz \
+ http://www.tetgen.org/1.5/src/tetgen1.5.1-beta1.tar.gz"
+MD5SUM="f839e7d80344552f07a195ef7a2d47eb \
+ 5465e67079419a69e0116de24fce58fe \
+ 3d55c197bcbfc611b7ced6f343643756"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="arpack-ng hdf5 openmpi suitesparse"
+MAINTAINER="Fellype do Nascimento"
+EMAIL="fellype(at)gmail.com"
diff --git a/academic/FreeFem/README b/academic/FreeFem/README
new file mode 100644
index 0000000000..99703a0063
--- /dev/null
+++ b/academic/FreeFem/README
@@ -0,0 +1,12 @@
+FreeFem is a high level multiphysics finite element software
+
+FreeFEM is a popular 2D and 3D partial differential equations (PDE) solver used
+by thousands of researchers across the world. It allows you to easily implement
+your own physics modules using the provided FreeFEM language. FreeFEM offers a
+large list of finite elements, like the Lagrange, Taylor-Hood, etc., usable in
+the continuous and discontinuous Galerkin method framework.
+
+FreeFEM has it own internal mesher, called BAMG, and is compatible with the best
+open-source mesh and visualization software like Tetgen, Gmsh, Mmg and ParaView.
+Written in C++ to optimize for speed, FreeFEM is interfaced with the popular
+mumps, PETSc and HPDDM solvers.
diff --git a/academic/FreeFem/slack-desc b/academic/FreeFem/slack-desc
new file mode 100644
index 0000000000..d2225acde6
--- /dev/null
+++ b/academic/FreeFem/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+FreeFem: FreeFem (A high level multiphysics finite element software)
+FreeFem:
+FreeFem: FreeFem is a software aimed for non-linear multiphysics in 2D and 3D
+FreeFem:
+FreeFem: FreeFem++ offers a fast interpolation algorithm and a language for
+FreeFem: the manipulation of data on multiple meshes.
+FreeFem:
+FreeFem: For more information visit: https://freefem.org/
+FreeFem:
+FreeFem:
+FreeFem: