summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Petar Petrov2019-08-03 01:41:13 +0200
committer Willy Sudiarto Raharjo2019-08-03 01:41:13 +0200
commit70cfe3be3f6e3d846459348be614e9b4bc9a621b (patch)
treec53e64556aa742d664a34b0dc789e951ee57e7af /academic
parentf5f045803ac16d10ff0ea450a8ae04aad3e2dd50 (diff)
downloadslackbuilds-70cfe3be3f6e3d846459348be614e9b4bc9a621b.tar.gz
academic/biopython: Added (Python tools for biological computation).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/biopython/README23
-rw-r--r--academic/biopython/References7
-rw-r--r--academic/biopython/biopython.SlackBuild86
-rw-r--r--academic/biopython/biopython.info10
-rw-r--r--academic/biopython/slack-desc19
5 files changed, 145 insertions, 0 deletions
diff --git a/academic/biopython/README b/academic/biopython/README
new file mode 100644
index 0000000000..9c61e5c495
--- /dev/null
+++ b/academic/biopython/README
@@ -0,0 +1,23 @@
+The Biopython Project is an international association of developers of
+freely available Python tools for computational molecular biology.
+
+The Biopython web site provides an online resource for modules,
+scripts, and web links for developers of Python-based software for
+bioinformatics use and research. Basically, the goal of Biopython is
+to make it as easy as possible to use Python for bioinformatics by
+creating high-quality, reusable modules and classes. Biopython
+features include parsers for various Bioinformatics file formats
+(BLAST, Clustalw, FASTA, Genbank,...), access to online services
+(NCBI, Expasy,...), interfaces to common and not-so-common programs
+(Clustalw, DSSP, MSMS,...), a standard sequence class, various
+clustering modules, a KD tree data structure etc. and even
+documentation.
+
+If you use Biopython in work contributing to a scientific publication,
+please cite the application note (below) or one of the module specific
+publications (listed on Biopython's website):
+
+Cock, P.J.A. et al. Biopython: freely available Python tools for
+computational molecular biology and bioinformatics. Bioinformatics
+2009 Jun 1; 25(11) 1422-3
+http://dx.doi.org/10.1093/bioinformatics/btp163 pmid:19304878
diff --git a/academic/biopython/References b/academic/biopython/References
new file mode 100644
index 0000000000..cb4bbf6471
--- /dev/null
+++ b/academic/biopython/References
@@ -0,0 +1,7 @@
+If you use Biopython in work contributing to a scientific publication, we ask
+that you cite our application note (below) or one of the module specific
+publications (listed on our website):
+
+Cock, P.J.A. et al. Biopython: freely available Python tools for computational
+molecular biology and bioinformatics. Bioinformatics 2009 Jun 1; 25(11) 1422-3
+http://dx.doi.org/10.1093/bioinformatics/btp163 pmid:19304878 \ No newline at end of file
diff --git a/academic/biopython/biopython.SlackBuild b/academic/biopython/biopython.SlackBuild
new file mode 100644
index 0000000000..22bd291d1f
--- /dev/null
+++ b/academic/biopython/biopython.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for biopython
+
+# Copyright 2019 Petar Petrov slackalaxy@gmail.com
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=biopython
+VERSION=${VERSION:-1.74}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/biopython/biopython.info b/academic/biopython/biopython.info
new file mode 100644
index 0000000000..9906f1df81
--- /dev/null
+++ b/academic/biopython/biopython.info
@@ -0,0 +1,10 @@
+PRGNAM="biopython"
+VERSION="1.74"
+HOMEPAGE="https://biopython.org/"
+DOWNLOAD="http://biopython.org/DIST/biopython-1.74.tar.gz"
+MD5SUM="cead2bfe9e7be45267eba00635f68d5c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="numpy"
+MAINTAINER="Petar Petrov"
+EMAIL="slackalaxy@gmail.com"
diff --git a/academic/biopython/slack-desc b/academic/biopython/slack-desc
new file mode 100644
index 0000000000..14374d1dfd
--- /dev/null
+++ b/academic/biopython/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+biopython: biopython (A set of Python tools for biological computation)
+biopython:
+biopython: Biopython is a set of freely available tools for biological
+biopython: computation written in Python. Biopython features include parsers
+biopython: for various Bioinformatics file formats (BLAST, Clustalw, FASTA,
+biopython: Genbank), access to online services (NCBI, Expasy), interfaces to
+biopython: common and not-so-common programs (Clustalw, DSSP, MSMS), a
+biopython: standard sequence class, various clustering modules, a KD tree
+biopython: data structure etc. and even documentation.
+biopython:
+biopython: https://biopython.org/