summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Rob van Nues2019-04-12 18:12:41 +0200
committer Willy Sudiarto Raharjo2019-04-12 18:12:41 +0200
commit706e25f22e6a38449cb7ba529a4b3480a264255d (patch)
treed7675ec78d1d31ccd5179d4a8361e47f2bbfa726 /academic
parente0472971fa3956f91f1d56ace7906a75b5a199a4 (diff)
downloadslackbuilds-706e25f22e6a38449cb7ba529a4b3480a264255d.tar.gz
academic/locarna: Added (Local RNA alignment on structural basis).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/locarna/README48
-rw-r--r--academic/locarna/locarna.SlackBuild107
-rw-r--r--academic/locarna/locarna.info10
-rw-r--r--academic/locarna/slack-desc19
4 files changed, 184 insertions, 0 deletions
diff --git a/academic/locarna/README b/academic/locarna/README
new file mode 100644
index 0000000000..ff32b839d9
--- /dev/null
+++ b/academic/locarna/README
@@ -0,0 +1,48 @@
+LocARNA: Alignment of RNAs
+==========================
+
+LocARNA is a collection of alignment tools for the structural analysis
+of RNA. Given a set of RNA sequences, LocARNA simultaneously aligns
+and predicts common structures for your RNAs. In this way, LocARNA
+performs Sankoff-like alignment and is in particular suited for
+analyzing sets of related RNAs without known common structure.
+
+LocARNA distinguishes itself from many other Sankoff-style multiple
+alignment programs by its performance and low memory complexity, high
+accuracy, and richness of features. As unique features, it offers
+structure-local alignment, flexible structure and anchor constraints,
+and provides efficient computation of reliabilities in
+sequence-structure alignment. The package offers a robust core of
+features and is used as experimental platform for the incorporation of
+new features in RNA sequence-structure alignment.
+
+
+At its core, the package offers global and local multiple alignment of
+RNAs.
+
+Multiple alignment can be performed in one of several different ways:
+
+* progressive alignment using sequence-structure alignment of profiles
+
+* progressive alignment after consistency transformation using
+T-Coffee
+
+* progressive alignment using probabilistic consistency transformation
+ and sequence-structure profile alignments, optionally followed by
+ iterative refinement.
+
+
+Besides of global alignment, LocARNA supports two kinds of
+locality. Local alignment as it is known from sequence alignment,
+identifies and aligns the best matching subsequences. This form of
+locality is called sequence local to distinguish it from structural
+locality. When performing structure local alignment, LocARNA
+identifies and aligns the best matching substructures in the RNAs. The
+sequences of those substructures can be discontinuous on the sequence
+level, but remain connected via structural bonds.
+
+Alignment Reliabilities (LocARNA-P). In this special, probabilistic
+mode of operation LocARNA supports the efficient computation of match
+probabilities, probabilistic consistency transformation for more
+accurate multiple alignment, and generates reliability profiles of
+multiple alignments.
diff --git a/academic/locarna/locarna.SlackBuild b/academic/locarna/locarna.SlackBuild
new file mode 100644
index 0000000000..488e2cfec2
--- /dev/null
+++ b/academic/locarna/locarna.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/sh
+
+# Slackware build script for locarna
+
+# Copyright 2019 Rob van Nues <sborg63@disroot.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=locarna
+VERSION=${VERSION:-1.9.2.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+#from https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=locarna
+
+install -d $PKG/usr/lib${LIBDIRSUFFIX}/perl5
+# seems to be 'private': https://github.com/s-will/LocARNA/issues/34
+mv $PKG/usr/lib/perl $PKG/usr/lib${LIBDIRSUFFIX}/perl5/vendor_perl
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS README INSTALL COPYING ChangeLog \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/locarna/locarna.info b/academic/locarna/locarna.info
new file mode 100644
index 0000000000..3614b6a9f2
--- /dev/null
+++ b/academic/locarna/locarna.info
@@ -0,0 +1,10 @@
+PRGNAM="locarna"
+VERSION="1.9.2.2"
+HOMEPAGE="http://www.bioinf.uni-freiburg.de/Software/LocARNA/"
+DOWNLOAD="https://github.com/s-will/LocARNA/releases/download/v1.9.2.2/locarna-1.9.2.2.tar.gz"
+MD5SUM="24901cf57d3ef4a615f1f7b886d08eb3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="ViennaRNA"
+MAINTAINER="Rob van Nues"
+EMAIL="sborg63@disroot.org"
diff --git a/academic/locarna/slack-desc b/academic/locarna/slack-desc
new file mode 100644
index 0000000000..b913a794a6
--- /dev/null
+++ b/academic/locarna/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+locarna: locarna (Local RNA alignment on structural basis)
+locarna:
+locarna: LocARNA is a collection of alignment tools for the structural
+locarna: analysis of RNA. Given a set of RNA sequences, LocARNA simultaneously
+locarna: aligns and predicts common structures for your RNAs. In this way,
+locarna: LocARNA performs Sankoff-like alignment and is in particular suited
+locarna: for analyzing sets of related RNAs without known common structure.
+locarna:
+locarna: Home:https://www.bioinf.uni-freiburg.de/Software/LocARNA/
+locarna:
+locarna: