summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Serban Udrea2022-11-06 23:01:56 +0100
committer Willy Sudiarto Raharjo2022-11-12 16:33:19 +0100
commitd6441a69ae7f3bd9dce5d838659a84fe7d7ffcda (patch)
tree7d7523af66bb6478719a9d3ba3e14c2323ff73e4 /academic
parent4314cff904ea434233a3e4183aaa365af7e1013c (diff)
downloadslackbuilds-d6441a69ae7f3bd9dce5d838659a84fe7d7ffcda.tar.gz
academic/scipy: Removed (renamed python2-scipy).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/scipy/README26
-rw-r--r--academic/scipy/scipy.SlackBuild100
-rw-r--r--academic/scipy/scipy.info10
-rw-r--r--academic/scipy/slack-desc19
4 files changed, 0 insertions, 155 deletions
diff --git a/academic/scipy/README b/academic/scipy/README
deleted file mode 100644
index 81198ddbe7..0000000000
--- a/academic/scipy/README
+++ /dev/null
@@ -1,26 +0,0 @@
-SciPy (pronounced "Sigh Pie") is open-source software for mathematics,
-science, and engineering.
-
-The SciPy library is built to work with NumPy arrays, and provides
-many user-friendly and efficient numerical routines such as routines
-for numerical integration and optimization. Together, they run on
-all popular operating systems, are quick to install, and are free of
-charge. NumPy and SciPy are easy to use, but powerful enough to be
-depended upon by some of the world's leading scientists and engineers.
-
-matplotlib and ipython are nice to have in connection with scipy, but
-scipy does not depend on them.
-
-Since ver. 0.14.0 scipy uses SuperLU instead of UMFPACK for solving
-unsymmetric sparse linear systems. If you want to use UMFPACK you
-must install it in advance of numpy and build numpy accordingly (see
-the README to numpy's SlackBuild). Moreover, after installing scipy,
-you have to install scikit-umfpack, which presently is not available on
-SlackBuilds.org.
-
-If you need to build scipy for debugging, set DEBUG=y.
-
-NOTE: If you use this SlackBuild scipy will run with the python version
- provided by Slackware Linux, which is presently 2.7.xx. If you'd
- like to use python 3.x then you have to install scipy with the
- scipy3 SlackBuild.
diff --git a/academic/scipy/scipy.SlackBuild b/academic/scipy/scipy.SlackBuild
deleted file mode 100644
index 273d144b3e..0000000000
--- a/academic/scipy/scipy.SlackBuild
+++ /dev/null
@@ -1,100 +0,0 @@
-#!/bin/bash
-
-# Build script for the Python SciPy package
-
-# Copyright 2011-2018 Serban Udrea <s.udrea@gsi.de>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification,
-# is permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
-# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
-# INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-# SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-# STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
-# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
-# POSSIBILITY OF SUCH DAMAGE.
-
-# Written by Eugene Suter <easuter@gmail.com>
-# Updated to 0.7.2 by João Felipe Santos <joao.eel@gmail.com>
-# Updated up to 1.1.0 by Serban Udrea <S.Udrea@gsi.de>
-# Added support for building with debugging symbols (S. Udrea)
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=scipy
-VERSION=${VERSION:-1.2.2}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=${PKG:-$TMP/package-$PRGNAM}
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf "$PRGNAM-$VERSION"
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd "$PRGNAM-$VERSION"
-chown -R root:root .
-
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-export FFLAGS="-fallow-argument-mismatch -fPIC"
-
-DEBUG=${DEBUG:-no}
-DEBUG=$(echo "$DEBUG"|cut -b 1|tr a-z A-Z)
-
-if [ "$DEBUG" = "N" ]
-then
- python setup.py install --root $PKG
- find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-else
- python setup.py build --debug
- python setup.py install --root $PKG
-fi
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE.txt THANKS.txt INSTALL.rst.txt HACKING.rst.txt PKG-INFO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc -type f -exec chmod 0644 {} \;
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/scipy/scipy.info b/academic/scipy/scipy.info
deleted file mode 100644
index d6f9f0522c..0000000000
--- a/academic/scipy/scipy.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="scipy"
-VERSION="1.2.2"
-HOMEPAGE="https://www.scipy.org/"
-DOWNLOAD="https://github.com/scipy/scipy/releases/download/v1.2.2/scipy-1.2.2.tar.gz"
-MD5SUM="d94de858fba4f24de7d6dd16f1caeb5d"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="numpy lapack"
-MAINTAINER="Serban Udrea"
-EMAIL="S.Udrea@gsi.de"
diff --git a/academic/scipy/slack-desc b/academic/scipy/slack-desc
deleted file mode 100644
index 9dd00a3d2c..0000000000
--- a/academic/scipy/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-scipy: scipy (python library for math, science, and engineering)
-scipy:
-scipy: The SciPy library is built to work with NumPy arrays, and provides
-scipy: many user-friendly and efficient numerical routines such as routines
-scipy: for numerical integration and optimization. Together, they run on all
-scipy: popular operating systems, are quick to install, and are free of
-scipy: charge. NumPy and SciPy are easy to use, but powerful enough to be
-scipy: depended upon by some of the world's leading scientists and engineers.
-scipy:
-scipy: https://www.scipy.org/
-scipy: