summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Serban Udrea2019-02-08 14:26:26 +0100
committer Willy Sudiarto Raharjo2019-02-08 14:26:26 +0100
commitbcb4c87b7f407035a7ac8de4a7e19dde2f717573 (patch)
tree533d14cda846e299ad40bd55a07a0979b271e801 /academic
parentf5812aad13f0accf42fc6bba7a454f8c927c20aa (diff)
downloadslackbuilds-bcb4c87b7f407035a7ac8de4a7e19dde2f717573.tar.gz
academic/scipy3: Updated for version 1.1.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/scipy3/README3
-rw-r--r--academic/scipy3/scipy3.SlackBuild16
-rw-r--r--academic/scipy3/scipy3.info6
3 files changed, 12 insertions, 13 deletions
diff --git a/academic/scipy3/README b/academic/scipy3/README
index 195c073545..5a72b73476 100644
--- a/academic/scipy3/README
+++ b/academic/scipy3/README
@@ -21,4 +21,5 @@ If you need to build scipy for debugging, set DEBUG=y.
NOTE: If you use this SlackBuild scipy will run with the python 3 version
installed on your system. If you'd like to use python 2.7.xx as
- provided by Slackware Linux then you have to install scipy.
+ provided by Slackware Linux then you have to install it with the scipy
+ SlackBuild.
diff --git a/academic/scipy3/scipy3.SlackBuild b/academic/scipy3/scipy3.SlackBuild
index 8c0af2f33c..22cbb37f31 100644
--- a/academic/scipy3/scipy3.SlackBuild
+++ b/academic/scipy3/scipy3.SlackBuild
@@ -2,7 +2,7 @@
# Build script for the Python SciPy package to be used with python 3
-# Copyright 2016 Serban Udrea <s.udrea@gsi.de>
+# Copyright 2016-2019 Serban Udrea <s.udrea@gsi.de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification,
@@ -25,12 +25,12 @@
# Written by Eugene Suter <easuter@gmail.com>
# Updated to 0.7.2 by João Felipe Santos <joao.eel@gmail.com>
-# Updated up to 0.18.0 by Serban Udrea <S.Udrea@gsi.de>
+# Updated up to 1.1.0 by Serban Udrea <S.Udrea@gsi.de>
# Added support for building with debugging symbols (S. Udrea)
PRGNAM="scipy3"
SRCNAM="scipy"
-VERSION=${VERSION:-0.18.0}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,7 +53,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf "$SRCNAM-$VERSION"
-tar xvf $CWD/$SRCNAM-$VERSION.tar.xz
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
cd "$SRCNAM-$VERSION"
chown -R root:root .
@@ -64,12 +64,10 @@ find -L . \
-exec chmod 644 {} \;
DEBUG=${DEBUG:-no}
-case "$DEBUG" in
- [yY]|[yY][eE][sS]) DEBUG="y" ;;
- *) DEBUG="" ;;
-esac
+DEBUG=$(echo "$DEBUG"|cut -b 1|tr a-z A-Z)
-if [ ! "$DEBUG" ]; then
+if [ "$DEBUG" = "N" ]
+then
python3 setup.py install --root $PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/academic/scipy3/scipy3.info b/academic/scipy3/scipy3.info
index 70d7385422..afdc113a2e 100644
--- a/academic/scipy3/scipy3.info
+++ b/academic/scipy3/scipy3.info
@@ -1,8 +1,8 @@
PRGNAM="scipy3"
-VERSION="0.18.0"
+VERSION="1.1.0"
HOMEPAGE="https://www.scipy.org/"
-DOWNLOAD="https://github.com/scipy/scipy/releases/download/v0.18.0/scipy-0.18.0.tar.xz"
-MD5SUM="59bceff108f58b0e72dfac6fb719476e"
+DOWNLOAD="https://github.com/scipy/scipy/releases/download/v1.1.0/scipy-1.1.0.tar.gz"
+MD5SUM="aa6bcc85276b6f25e17bcfc4dede8718"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="numpy3 lapack"