summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Kyle Guinn2015-06-09 07:46:09 +0200
committer Willy Sudiarto Raharjo2015-06-14 02:55:32 +0200
commitaec10984ce84079ea64e972c120bc68a36633fff (patch)
tree09b1e614f662c2f80ed338606d0fe88af5d2eeac /academic
parent2783a26a3976ed77b67262a2711375e76b38e40a (diff)
downloadslackbuilds-aec10984ce84079ea64e972c120bc68a36633fff.tar.gz
academic/suitesparseconfig: Updated for version 4.4.4.
Signed-off-by: Kyle Guinn <elyk03@gmail.com>
Diffstat (limited to 'academic')
-rw-r--r--academic/suitesparseconfig/autotoolize.diff19
-rw-r--r--academic/suitesparseconfig/suitesparseconfig.SlackBuild44
-rw-r--r--academic/suitesparseconfig/suitesparseconfig.info8
3 files changed, 39 insertions, 32 deletions
diff --git a/academic/suitesparseconfig/autotoolize.diff b/academic/suitesparseconfig/autotoolize.diff
index 495a940f10..2ac9afc27e 100644
--- a/academic/suitesparseconfig/autotoolize.diff
+++ b/academic/suitesparseconfig/autotoolize.diff
@@ -2,7 +2,7 @@ diff --git a/Makefile.am b/Makefile.am
new file mode 100644
--- /dev/null
+++ b/Makefile.am
-@@ -0,0 +1,15 @@
+@@ -0,0 +1,16 @@
+SUBDIRS = xerbla
+
+EXTRA_DIST = README.txt
@@ -17,17 +17,18 @@ new file mode 100644
+
+lib_LTLIBRARIES = libsuitesparseconfig.la
+libsuitesparseconfig_la_SOURCES = SuiteSparse_config.c
-+libsuitesparseconfig_la_LDFLAGS = -no-undefined -version-number 4:2:1
++libsuitesparseconfig_la_LIBADD = -lm
++libsuitesparseconfig_la_LDFLAGS = -no-undefined -release $(PACKAGE_VERSION)
diff --git a/configure.ac b/configure.ac
new file mode 100644
--- /dev/null
+++ b/configure.ac
-@@ -0,0 +1,32 @@
+@@ -0,0 +1,37 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.69])
-+AC_INIT([SuiteSparse_config],[4.2.1],[DrTimothyAldenDavis@gmail.com],[suitesparseconfig],[http://www.suitesparse.com/])
++AC_INIT([SuiteSparse_config],[4.4.4],[DrTimothyAldenDavis@gmail.com],[suitesparseconfig],[http://www.suitesparse.com/])
+AC_CONFIG_SRCDIR([SuiteSparse_config.c])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([foreign])
@@ -38,7 +39,10 @@ new file mode 100644
+AC_PROG_CC
+AC_PROG_F77
+
++LIBS_SAVED=$LIBS
++
+# Checks for libraries.
++AC_CHECK_LIB([m], [sqrt])
+
+# Checks for header files.
+AC_CHECK_HEADERS([limits.h stdlib.h])
@@ -48,7 +52,9 @@ new file mode 100644
+
+# Checks for library functions.
+AC_FUNC_MALLOC
-+AC_CHECK_FUNCS([clock_gettime])
++AC_CHECK_FUNCS([clock_gettime sqrt])
++
++LIBS=$LIBS_SAVED
+
+AC_CONFIG_FILES([
+ suitesparseconfig.pc
@@ -59,7 +65,7 @@ diff --git a/suitesparseconfig.pc.in b/suitesparseconfig.pc.in
new file mode 100644
--- /dev/null
+++ b/suitesparseconfig.pc.in
-@@ -0,0 +1,11 @@
+@@ -0,0 +1,12 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
@@ -70,6 +76,7 @@ new file mode 100644
+Version: @PACKAGE_VERSION@
+URL: @PACKAGE_URL@
+Libs: -L${libdir} -lsuitesparseconfig
++Libs.private: -lm
+Cflags: -I${includedir}
diff --git a/xerbla/Makefile.am b/xerbla/Makefile.am
new file mode 100644
diff --git a/academic/suitesparseconfig/suitesparseconfig.SlackBuild b/academic/suitesparseconfig/suitesparseconfig.SlackBuild
index f33ac33455..4ae80f990f 100644
--- a/academic/suitesparseconfig/suitesparseconfig.SlackBuild
+++ b/academic/suitesparseconfig/suitesparseconfig.SlackBuild
@@ -2,29 +2,31 @@
# Slackware build script for SuiteSparse_config
-# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
+# Copyright 2013-2015 Kyle Guinn <elyk03@gmail.com>, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
+# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=suitesparseconfig
-SRCNAM=SuiteSparse_config
-VERSION=${VERSION:-4.2.1}
+SRCNAM=SuiteSparse
+SUBDIR=SuiteSparse_config
+VERSION=${VERSION:-4.4.4}
+SRCVER=${SRCVER:-4.4.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -58,7 +60,7 @@ else
fi
# Recommended by SuiteSparse
-SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
+SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64"
set -e
@@ -66,14 +68,10 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM
+tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
+cd $SRCNAM/$SUBDIR
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+chmod -R u+w,go-w,a+rX-st .
patch -p1 < $CWD/autotoolize.diff
autoreconf -vif
@@ -97,6 +95,8 @@ make
make check
make install-strip DESTDIR=$PKG
+find $PKG/usr/lib${LIBDIRSUFFIX} -name '*.la' -delete
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/academic/suitesparseconfig/suitesparseconfig.info b/academic/suitesparseconfig/suitesparseconfig.info
index bdcc90b4db..8941609d14 100644
--- a/academic/suitesparseconfig/suitesparseconfig.info
+++ b/academic/suitesparseconfig/suitesparseconfig.info
@@ -1,8 +1,8 @@
PRGNAM="suitesparseconfig"
-VERSION="4.2.1"
-HOMEPAGE="https://www.cise.ufl.edu/research/sparse/SuiteSparse_config/"
-DOWNLOAD="https://www.cise.ufl.edu/research/sparse/SuiteSparse_config/SuiteSparse_config-4.2.1.tar.gz"
-MD5SUM="f9d709f442ab13e0cf0f53d6b516abd1"
+VERSION="4.4.4"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+DOWNLOAD="http://faculty.cse.tamu.edu/davis/SuiteSparse/SuiteSparse-4.4.4.tar.gz"
+MD5SUM="e0af74476935c9ff6d971df8bb6b82fc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""