summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Dan-Simon Myrland2014-03-31 18:43:23 +0200
committer Willy Sudiarto Raharjo2014-04-07 09:43:45 +0200
commita05ffd96b69fe821a05824cca8ef8d0dec49d901 (patch)
treee38296ebe35560bba681ac233adab25a16a40db2 /academic
parent2bdc039a592427d995650e68e08b64f8f6d68d3a (diff)
downloadslackbuilds-a05ffd96b69fe821a05824cca8ef8d0dec49d901.tar.gz
academic/evopedia_qt: Added (Offline Wikipedia viewer).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/evopedia_qt/README8
-rw-r--r--academic/evopedia_qt/evopedia_qt.SlackBuild55
-rw-r--r--academic/evopedia_qt/evopedia_qt.info10
-rw-r--r--academic/evopedia_qt/slack-desc19
4 files changed, 92 insertions, 0 deletions
diff --git a/academic/evopedia_qt/README b/academic/evopedia_qt/README
new file mode 100644
index 0000000000..64d8727e93
--- /dev/null
+++ b/academic/evopedia_qt/README
@@ -0,0 +1,8 @@
+evopedia_qt (offline wikipedia)
+
+evopedia_qt is an offline wikipedia viewer. If you are troubled by a
+slow Internet connection or none at all, this package might be very
+useful. You can also use this to make your own local wikipedia
+server.
+
+Evopedia is accessible through http://127.0.0.1:8080/
diff --git a/academic/evopedia_qt/evopedia_qt.SlackBuild b/academic/evopedia_qt/evopedia_qt.SlackBuild
new file mode 100644
index 0000000000..783878ba4a
--- /dev/null
+++ b/academic/evopedia_qt/evopedia_qt.SlackBuild
@@ -0,0 +1,55 @@
+#!/bin/sh
+#
+# Slackware build script for evopedia
+#
+# Written by Dan-Simon Myrland <dansimon@radiotube.org>
+
+PRGNAM=evopedia_qt
+VERSION=${VERSION:-0.4.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+unzip $CWD/v${VERSION}.zip || unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# uncomment NO_GUI option for a gui less installation
+qmake PREFIX=$PKG/usr #DEFINES+=NO_GUI
+make
+make install
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md debian/changelog debian/copyright $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/evopedia_qt/evopedia_qt.info b/academic/evopedia_qt/evopedia_qt.info
new file mode 100644
index 0000000000..745056024e
--- /dev/null
+++ b/academic/evopedia_qt/evopedia_qt.info
@@ -0,0 +1,10 @@
+PRGNAM="evopedia_qt"
+VERSION="0.4.4"
+HOMEPAGE="http://evopedia.info"
+DOWNLOAD="https://github.com/evopedia/evopedia_qt/archive/v0.4.4.zip"
+MD5SUM="5d3745df1e21c6c83ff84eff69da18b9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dan-Simon Myrland"
+EMAIL="dansimon@radiotube.org"
diff --git a/academic/evopedia_qt/slack-desc b/academic/evopedia_qt/slack-desc
new file mode 100644
index 0000000000..03bc440508
--- /dev/null
+++ b/academic/evopedia_qt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler---------------------------------------------------|
+evopedia_qt: evopedia_qt (Offline Wikipedia viewer)
+evopedia_qt:
+evopedia_qt: Evopedia manages offline Wikipedia snapshots. Handy if you have a
+evopedia_qt: slow Internet connection or no Internet access from time to
+evopedia_qt: time. You can also use evopedia to host your own local Wikipedia
+evopedia_qt: server.
+evopedia_qt:
+evopedia_qt:
+evopedia_qt:
+evopedia_qt:
+evopedia_qt: http://evopedia.info