summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Petar Petrov2014-01-27 07:39:55 +0100
committer Erik Hanson2014-01-30 06:21:16 +0100
commit9d8a8a88ef1b8cd92fe31b205d5f5a0b50ef4428 (patch)
tree3073c98e870c45aded076d3c1c13ef9db1e6fbae /academic
parent234ecffbe2b49f3a8a96326326ddeb433524247c (diff)
downloadslackbuilds-9d8a8a88ef1b8cd92fe31b205d5f5a0b50ef4428.tar.gz
academic/staden: Updated for version 2.0.0b10.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/staden/README9
-rw-r--r--academic/staden/staden.SlackBuild93
-rw-r--r--academic/staden/staden.info14
3 files changed, 23 insertions, 93 deletions
diff --git a/academic/staden/README b/academic/staden/README
index 26b87b4c05..0d8a67c590 100644
--- a/academic/staden/README
+++ b/academic/staden/README
@@ -18,12 +18,3 @@ TREV - A rapid and flexible viewer and editor for ABI, ALF or SCF
For more information and citing, visit Staden's web page and check the
"References" file in the documentation.
-
-Notes:
-1) You should run the SlackBuild in real root environment (su -)!
-2) Make sure you have Emacs and Tetex installed at build time.
-3) Although unsupported at the moment, SPIN can provide a GUI for the
- EMBOSS suite programs. If you want to give it a try, run as root
- "create_emboss_files" (EMBOSS should be installed, of course). This
- generates some files in /usr/share/staden/tcl/spin_emboss/acdtcl,
- so remember to manually clean them if you later uninstall staden.
diff --git a/academic/staden/staden.SlackBuild b/academic/staden/staden.SlackBuild
index cb3ee341df..3c132c0b6d 100644
--- a/academic/staden/staden.SlackBuild
+++ b/academic/staden/staden.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for staden
-# Copyright 2011-2012 Petar Petrov, ppetrov@paju.oulu.fi
+# Copyright 2011-2014 Petar Petrov, petar.petrov@student.oulu.fi
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=staden
-VERSION=${VERSION:-2.0.0b9}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-2.0.0b10}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -35,9 +35,7 @@ if [ -z "$ARCH" ]; then
esac
fi
-SLKTCL=tcl8.6.1 # Slackware 14.1 sources for TCL
-SLKTK=tk8.6.1 # Slackware 14.1 sources for TK
-TKLIB=tklib0.5 # Folder name of TKLIB
+TKLIB=tklib0.5 # Folder name of TKLIB
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
@@ -63,51 +61,19 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-mkdir $PRGNAM-$VERSION
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$VERSION-src
tar xvf $CWD/$PRGNAM-$VERSION-src.tar.gz
-tar xvf $CWD/${PRGNAM}_doc-$VERSION-src.tar.gz
-
-# The sources of TCL and TK are expected to be in /tmp at build time,
-# so we unpack them in the build directory and create symlinks in /tmp.
-rm -f /tmp/$SLKTCL
-rm -f /tmp/$SLKTK
-tar xvf $CWD/$SLKTCL-src.tar.xz
-tar xvf $CWD/$SLKTK-src.tar.xz
-ln -s $TMP/$PRGNAM-$VERSION/$SLKTCL /tmp/$SLKTCL
-ln -s $TMP/$PRGNAM-$VERSION/$SLKTK /tmp/$SLKTK
-
-chown -R root:root $PRGNAM-$VERSION-src ${PRGNAM}_doc-$VERSION-src
-find $PRGNAM-$VERSION-src ${PRGNAM}_doc-$VERSION-src \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
cd $PRGNAM-$VERSION-src
-
-# On Slackware64, the components of staden (like GAP4, GAP5, PREGAP4,
-# SPIN, TREV) will not run, as they still expect their libraries to be
-# in /usr/lib not /usr/lib64. Let's correct the libraries path.
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Make sure libraries path is correct.
sed -i "s:$STADENROOT/lib:$STADENROOT/lib${LIBDIRSUFFIX}:g" \
- global.mk staden.profile copy_reads/copy_reads gap4/gap4 gap5/gap5 \
- gap5/gap5_consensus gap5/gap5_export gap5/tg_index gap5/tg_view \
- prefinish/finish_sanger prefinish/prefinish pregap4/pregap4 spin/spin \
- spin_emboss/create_emboss_files trev/trev
-
-# Point to the right place of the EMBOSS .acd and data files. This is
-# needed if the "create_emboss_files" script is run after install.
-sed -i "133 c set acd_dir /usr/share/EMBOSS/acd" spin_emboss/create_emboss_files.tcl
-sed -i "73 a EMBOSS_DATA=/usr/share/EMBOSS/data; export EMBOSS_DATA" spin/spin
-
-# Correct the path where staden components look for their manual.
-sed -i "s:/share/doc/staden/manual:/doc/$PRGNAM-$VERSION/manual:" tk_utils/help_config
-
-# These fixes are from Arch linux AUR
-# http://aur.archlinux.org/packages/st/staden/PKGBUILD
-sed -i 's:-DSVN_VERSION=$(SVNVERS)::' system.mk.in
-sed -i "s/gzFile\ \*gz/gzFile\ gz/" gap5/zfio.h
+ global.mk staden.profile
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -124,41 +90,20 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-# Build documentation. In the process, texi2dvi looks for tex and
-# that's why the SlackBuild should be run as real root (su -).
-# ## (or just source /etc/profile ) --rworkman
-cd $TMP/$PRGNAM-$VERSION/${PRGNAM}_doc-$VERSION-src
-
-# Fix the doc and man pages paths
-sed "s:{datarootdir}/doc/staden:{prefix}/doc/$PRGNAM-$VERSION:" -i Makefile
-sed "s:{datarootdir}/man:{prefix}/man:" -i Makefile
-
-# Remove this, or there will be an error at the "make install" line.
-rm -rf i/i
-
-# Generate documentation. If you want it in the US letter format,
-# change the next line to "make unix PAPER=us".
-make unix
-make install DESTDIR=$PKG
-
-# Now that we're done building, let's remove those symlinks from earlier...
-rm -f /tmp/$SLKTCL /tmp/$SLKTK
-
-# This is empty
+# These are empty
rm -rf $PKG/usr/share/doc
+rm -rf $PKG/usr/man
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
mkdir -p $PKG/usr/share/{applications,pixmaps}
cp $CWD/desktop/*.desktop $PKG/usr/share/applications
cp $CWD/desktop/*.png $PKG/usr/share/pixmaps
-cd ../$PRGNAM-$VERSION-src
-cp -a ChangeLog NEWS README.build $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ChangeLog LICENCE.txt NEWS README.build \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
diff --git a/academic/staden/staden.info b/academic/staden/staden.info
index d3a31aedeb..15238270ef 100644
--- a/academic/staden/staden.info
+++ b/academic/staden/staden.info
@@ -1,16 +1,10 @@
PRGNAM="staden"
-VERSION="2.0.0b9"
+VERSION="2.0.0b10"
HOMEPAGE="http://staden.sourceforge.net/"
-DOWNLOAD="http://sourceforge.net/projects/staden/files/staden/2.0.0b9/staden-2.0.0b9-src.tar.gz \
- http://sourceforge.net/projects/staden/files/staden/2.0.0b9/staden_doc-2.0.0b9-src.tar.gz \
- http://slackware.osuosl.org/slackware-14.1/source/tcl/tcl/tcl8.6.1-src.tar.xz \
- http://slackware.osuosl.org/slackware-14.1/source/tcl/tk/tk8.6.1-src.tar.xz"
-MD5SUM="94dc304b00d18b95f783136c9ffd934f \
- 730b433d8344624925b662ec37ac0804 \
- 59d2b6a9ac7dacee4c2f61b79f99b300 \
- 2937055d4d0693271f7485de94c761d2"
+DOWNLOAD="http://sourceforge.net/projects/staden/files/staden/2.0.0b10/staden-2.0.0b10-src.tar.gz"
+MD5SUM="81ad0b840253774e41d3089fca7af688"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="io_lib tklib"
MAINTAINER="Petar Petrov"
-EMAIL="ppetrov@paju.oulu.fi"
+EMAIL="petar.petrov@student.oulu.fi"