summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Kyle Guinn2014-01-25 03:41:56 +0100
committer Robby Workman2014-01-31 07:53:38 +0100
commit630bc18117b5c316cdf0d27458e5bc1338a7b70d (patch)
tree59d5665201219fedbe2bd0b2071492b1d5b9df26 /academic
parent1eee7e8781d7d9998ababee985dfc085b460d396 (diff)
downloadslackbuilds-630bc18117b5c316cdf0d27458e5bc1338a7b70d.tar.gz
academic/ccolamd: Renamed and moved from libraries.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/ccolamd/README4
-rw-r--r--academic/ccolamd/autotoolize.diff139
-rw-r--r--academic/ccolamd/ccolamd.SlackBuild107
-rw-r--r--academic/ccolamd/ccolamd.info10
-rw-r--r--academic/ccolamd/slack-desc19
5 files changed, 279 insertions, 0 deletions
diff --git a/academic/ccolamd/README b/academic/ccolamd/README
new file mode 100644
index 0000000000..0732b61e8d
--- /dev/null
+++ b/academic/ccolamd/README
@@ -0,0 +1,4 @@
+CCOLAMD computes a column approximate minimum degree ordering algorithm
+(like COLAMD), but it can also be given a set of ordering constraints.
+
+This package is part of SuiteSparse.
diff --git a/academic/ccolamd/autotoolize.diff b/academic/ccolamd/autotoolize.diff
new file mode 100644
index 0000000000..a3058ca550
--- /dev/null
+++ b/academic/ccolamd/autotoolize.diff
@@ -0,0 +1,139 @@
+diff --git a/Demo/Makefile.am b/Demo/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Demo/Makefile.am
+@@ -0,0 +1,30 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
++LDADD = $(top_builddir)/Source/libccolamd.la
++
++EXTRA_DIST = \
++ ccolamd_example.out \
++ ccolamd_l_example.out
++
++# Disable the .out implicit pattern rule. Prevents GNU make from
++# adding bogus dependencies for the .out files listed above.
++%.out: %
++
++check_PROGRAMS = \
++ ccolamd_example \
++ ccolamd_l_example
++
++ccolamd_example_SOURCES = ccolamd_example.c
++ccolamd_l_example_SOURCES = ccolamd_l_example.c
++
++check-local: $(check_PROGRAMS) $(check_PROGRAMS:=.out)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i$(EXEEXT) > my_$$i.out; \
++ if diff -u $(srcdir)/$$i.out my_$$i.out; then \
++ echo "Test $$i PASSED."; \
++ else \
++ echo "Test $$i FAILED."; \
++ fi; \
++ done
++
++CLEANFILES = my_*.out
+diff --git a/Include/Makefile.am b/Include/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Include/Makefile.am
+@@ -0,0 +1 @@
++pkginclude_HEADERS = ccolamd.h
+diff --git a/Makefile.am b/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Makefile.am
+@@ -0,0 +1,5 @@
++SUBDIRS = Include Source Demo
++EXTRA_DIST = README.txt Doc/ChangeLog Doc/lesser.txt
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = ccolamd.pc
+diff --git a/Source/Makefile.am b/Source/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Source/Makefile.am
+@@ -0,0 +1,18 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
++
++CCOLAMDSRC = \
++ ccolamd.c
++
++lib_LTLIBRARIES = libccolamd.la
++noinst_LTLIBRARIES = libccolamdl.la libccolamdi.la
++
++libccolamdi_la_SOURCES = $(CCOLAMDSRC)
++libccolamdi_la_LIBADD = -lm
++
++libccolamdl_la_SOURCES = $(CCOLAMDSRC)
++libccolamdl_la_LIBADD = -lm
++libccolamdl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++libccolamd_la_SOURCES = ccolamd_global.c
++libccolamd_la_LIBADD = libccolamdi.la libccolamdl.la
++libccolamd_la_LDFLAGS = -no-undefined -version-number 2:8:0
+diff --git a/ccolamd.pc.in b/ccolamd.pc.in
+new file mode 100644
+--- /dev/null
++++ b/ccolamd.pc.in
+@@ -0,0 +1,13 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: @PACKAGE_NAME@
++Description: Constrained column approximate minimum degree ordering
++Version: @PACKAGE_VERSION@
++URL: @PACKAGE_URL@
++Requires.private: suitesparseconfig
++Libs: -L${libdir} -lccolamd
++Libs.private: -lm
++Cflags: -I${includedir}/ccolamd
+diff --git a/configure.ac b/configure.ac
+new file mode 100644
+--- /dev/null
++++ b/configure.ac
+@@ -0,0 +1,42 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([CCOLAMD],[2.8.0],[DrTimothyAldenDavis@gmail.com],[ccolamd],[http://www.suitesparse.com/])
++AC_CONFIG_SRCDIR([Source/ccolamd_global.c])
++AC_CONFIG_HEADERS([config.h])
++AM_INIT_AUTOMAKE([foreign])
++LT_INIT
++
++# Checks for programs.
++AC_PROG_INSTALL
++AC_PROG_CC
++
++LIBS_SAVED=$LIBS
++
++# Checks for libraries.
++AC_CHECK_LIB([m], [sqrt])
++
++PKG_PROG_PKG_CONFIG
++PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
++ [],
++ [AC_MSG_ERROR([cannot find suitesparseconfig])])
++
++# Checks for header files.
++AC_CHECK_HEADERS([limits.h stdlib.h])
++
++# Checks for typedefs, structures, and compiler characteristics.
++AC_TYPE_SIZE_T
++
++# Checks for library functions.
++AC_CHECK_FUNCS([sqrt])
++
++LIBS=$LIBS_SAVED
++
++AC_CONFIG_FILES([
++ ccolamd.pc
++ Makefile
++ Demo/Makefile
++ Include/Makefile
++ Source/Makefile])
++AC_OUTPUT
diff --git a/academic/ccolamd/ccolamd.SlackBuild b/academic/ccolamd/ccolamd.SlackBuild
new file mode 100644
index 0000000000..31b9f2cf70
--- /dev/null
+++ b/academic/ccolamd/ccolamd.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/sh
+
+# Slackware build script for CCOLAMD
+
+# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ccolamd
+SRCNAM=CCOLAMD
+VERSION=${VERSION:-2.8.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$(uname -m) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="README.txt Doc/ChangeLog Doc/lesser.txt"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# Recommended by SuiteSparse
+SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/autotoolize.diff
+autoreconf -vif
+
+CFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-shared \
+ --disable-static \
+ --disable-dependency-tracking \
+ --build=$ARCH-slackware-linux
+
+make
+make check
+make install-strip DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/ccolamd/ccolamd.info b/academic/ccolamd/ccolamd.info
new file mode 100644
index 0000000000..4a293cad24
--- /dev/null
+++ b/academic/ccolamd/ccolamd.info
@@ -0,0 +1,10 @@
+PRGNAM="ccolamd"
+VERSION="2.8.0"
+HOMEPAGE="https://www.cise.ufl.edu/research/sparse/ccolamd/"
+DOWNLOAD="https://www.cise.ufl.edu/research/sparse/ccolamd/CCOLAMD-2.8.0.tar.gz"
+MD5SUM="a0af8b91c3d24eba5d4818e88c6c288c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="suitesparseconfig"
+MAINTAINER="Kyle Guinn"
+EMAIL="elyk03@gmail.com"
diff --git a/academic/ccolamd/slack-desc b/academic/ccolamd/slack-desc
new file mode 100644
index 0000000000..7aaf01b05b
--- /dev/null
+++ b/academic/ccolamd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ccolamd: CCOLAMD (sparse matrix ordering routines)
+ccolamd:
+ccolamd: CCOLAMD computes a column approximate minimum degree ordering
+ccolamd: algorithm (like COLAMD), but it can also be given a set of
+ccolamd: ordering constraints.
+ccolamd:
+ccolamd:
+ccolamd:
+ccolamd:
+ccolamd:
+ccolamd: