summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Petar Petrov2011-09-03 03:12:41 +0200
committer Niels Horn2011-09-03 03:12:41 +0200
commit34ea59f9a15c468cef83c81ac23a3d850c1c04aa (patch)
tree759f2e5b02f85bcb7ea01f852af8e84be40215c7 /academic
parentfb66124312ad317a7dd878cf92f4c00270671e56 (diff)
downloadslackbuilds-34ea59f9a15c468cef83c81ac23a3d850c1c04aa.tar.gz
academic/clustalx: Added (Multiple Sequence Alignment GUI)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/clustalx/README6
-rw-r--r--academic/clustalx/References38
-rw-r--r--academic/clustalx/clustalx.SlackBuild104
-rw-r--r--academic/clustalx/clustalx.desktop7
-rw-r--r--academic/clustalx/clustalx.info10
-rw-r--r--academic/clustalx/clustalx.pngbin0 -> 4418 bytes
-rw-r--r--academic/clustalx/doinst.sh3
-rw-r--r--academic/clustalx/fix-static.patch28
-rw-r--r--academic/clustalx/slack-desc19
9 files changed, 215 insertions, 0 deletions
diff --git a/academic/clustalx/README b/academic/clustalx/README
new file mode 100644
index 0000000000..4ca29e48fc
--- /dev/null
+++ b/academic/clustalx/README
@@ -0,0 +1,6 @@
+Clustal is a widely used, multiple sequence alignment program. This
+is ClustalX, the graphical user interface.
+
+For details and citation:
+Clustal W and Clustal X version 2.0, Larkin M., et al. Bioinformatics
+2007 23(21):2947-2948
diff --git a/academic/clustalx/References b/academic/clustalx/References
new file mode 100644
index 0000000000..657db37a3b
--- /dev/null
+++ b/academic/clustalx/References
@@ -0,0 +1,38 @@
+References
+
+Larkin MA, Blackshields G, Brown NP, Chenna R, McGettigan PA, McWilliam
+H, Valentin F, Wallace IM, Wilm A, Lopez R, Thompson JD, Gibson TJ,
+Higgins DG. (2007). Clustal W and Clustal X version 2.0. Bioinformatics,
+23, 2947-2948.
+
+Chenna R, Sugawara H, Koike T, Lopez R, Gibson TJ, Higgins DG, Thompson
+JD. (2003). Multiple sequence alignment with the Clustal series of
+programs. Nucleic Acids Res., 31, 3497-3500.
+
+Jeanmougin F, Thompson JD, Gouy M, Higgins DG, Gibson TJ. (1998). Multiple
+sequence alignment with Clustal X. Trends Biochem Sci., 23, 403-405.
+
+Thompson JD, Gibson TJ, Plewniak F, Jeanmougin F, Higgins DG. (1997). The
+CLUSTAL_X windows interface: flexible strategies for multiple sequence
+alignment aided by quality analysis tools. Nucleic Acids Res., 25,
+4876-4882.
+
+Higgins DG, Thompson JD, Gibson TJ. (1996). Using CLUSTAL for multiple
+sequence alignments. Methods Enzymol., 266, 383-402.
+
+Thompson JD, Higgins DG, Gibson TJ. (1994). CLUSTAL W: improving
+the sensitivity of progressive multiple sequence alignment through
+sequence weighting, position-specific gap penalties and weight matrix
+choice. Nucleic Acids Res., 22, 4673-4680.
+
+Higgins DG. (1994). CLUSTAL V: multiple alignment of DNA and protein
+sequences. Methods Mol Biol., 25, 307-318
+
+Higgins DG, Bleasby AJ, Fuchs R. (1992). CLUSTAL V: improved software
+for multiple sequence alignment. Comput. Appl. Biosci., 8, 189-191.
+
+Higgins,DG and Sharp,PM (1989). Fast and sensitive multiple sequence
+alignments on a microcomputer. Comput. Appl. Biosci., 5, 151-153.
+
+Higgins,D.G. and Sharp,P.M. (1988). CLUSTAL: a package for performing
+multiple sequence alignment on a microcomputer. Gene, 73, 237-244.
diff --git a/academic/clustalx/clustalx.SlackBuild b/academic/clustalx/clustalx.SlackBuild
new file mode 100644
index 0000000000..4505745095
--- /dev/null
+++ b/academic/clustalx/clustalx.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/sh
+
+# Slackware build script for clustalx
+# Written by Petar Petrov, <ppetrov@paju.oulu.fi> and
+# hereby submitted to the public domain
+
+# Based on the clustalx PKGBUILD from Archlinux AUR
+# (http://aur.archlinux.org/packages.php?ID=25080).
+# PKGBUILD submitter is mickelliot and maintainer is
+# machoo02. Thank you!
+
+# THIS SLACKBUILD IS DISTRIBUTETD IN THE HOPE OF BEING
+# USEFUL BUT WITHOUT ANY WARRANTY. THE AUTHOR IS _NOT_
+# RESPONSIBLE FOR ANY DAMAGE OR DATA LOSS CAUSED BY IT.
+
+PRGNAM=clustalx
+VERSION=${VERSION:-2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+
+# The patch is from Archlinux AUR, as mentioned above.
+patch -p1 < $CWD/fix-static.patch
+
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i 's/static//g' clustalx.pro
+
+qmake
+
+#Use our CFLAGS/CXXFLAGS
+sed -i "/^C.*.*FLAGS/s/=/+=/" Makefile
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+ make
+
+install -D -m755 clustalx $PKG/usr/bin/clustalx
+install -D -m644 colprot.xml $PKG/usr/share/$PRGNAM/colprot.xml
+install -D -m644 coldna.xml $PKG/usr/share/$PRGNAM/coldna.xml
+install -D -m644 coldna.xml $PKG/usr/share/$PRGNAM/colprint.xml
+install -D -m644 clustalx.hlp $PKG/usr/share/$PRGNAM/clustalx.hlp
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Menu item and icon
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+cp $CWD/clustalx.desktop $PKG/usr/share/applications
+cp $CWD/clustalx.png $PKG/usr/share/pixmaps
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README COPYING \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/clustalx/clustalx.desktop b/academic/clustalx/clustalx.desktop
new file mode 100644
index 0000000000..728dbeaa28
--- /dev/null
+++ b/academic/clustalx/clustalx.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Categories=Education;
+Exec=clustalx
+Icon=clustalx.png
+Name=ClustalX
+StartupNotify=false
+Type=Application
diff --git a/academic/clustalx/clustalx.info b/academic/clustalx/clustalx.info
new file mode 100644
index 0000000000..0e49e82a85
--- /dev/null
+++ b/academic/clustalx/clustalx.info
@@ -0,0 +1,10 @@
+PRGNAM="clustalx"
+VERSION="2.1"
+HOMEPAGE="http://www.clustal.org/"
+DOWNLOAD="http://www.clustal.org/download/current/clustalx-2.1.tar.gz"
+MD5SUM="5b1f2f1cc8e939411ab0f934cafa072a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Petar Petrov"
+EMAIL="ppetrov@paju.oulu.fi"
+APPROVED="Niels Horn"
diff --git a/academic/clustalx/clustalx.png b/academic/clustalx/clustalx.png
new file mode 100644
index 0000000000..158cb560dd
--- /dev/null
+++ b/academic/clustalx/clustalx.png
Binary files differ
diff --git a/academic/clustalx/doinst.sh b/academic/clustalx/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/academic/clustalx/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/academic/clustalx/fix-static.patch b/academic/clustalx/fix-static.patch
new file mode 100644
index 0000000000..a23f0018c4
--- /dev/null
+++ b/academic/clustalx/fix-static.patch
@@ -0,0 +1,28 @@
+diff -urN clustalx-2.1/ClustalQtParams.h clustalx-2.1a/ClustalQtParams.h
+--- clustalx-2.1/ClustalQtParams.h 2010-11-17 05:12:30.000000000 -0500
++++ clustalx-2.1a/ClustalQtParams.h 2010-11-18 12:19:42.450866697 -0500
+@@ -13,9 +13,9 @@
+ #include "clustalW/alignment/Alignment.h"
+ #include <vector>
+
+-static QString psColorFile = "colprot.xml";
+-static QString psDNAFile = "coldna.xml";
+-static QString psPrintFile = "colprint.xml";
++static QString psColorFile = "/usr/share/clustalx/colprot.xml";
++static QString psDNAFile = "/usr/share/clustalx/coldna.xml";
++static QString psPrintFile = "/usr/share/clustalx/colprint.xml";
+
+ static const int BlackAndWhite = 1;
+ static const int ColorsBackGround = 2;
+diff -urN clustalx-2.1/HelpDisplayWidget.cpp clustalx-2.1a/HelpDisplayWidget.cpp
+--- clustalx-2.1/HelpDisplayWidget.cpp 2010-11-17 05:12:30.000000000 -0500
++++ clustalx-2.1a/HelpDisplayWidget.cpp 2010-11-18 12:20:34.727866697 -0500
+@@ -19,7 +19,7 @@
+ #include <QtGui>
+ #include "Resources.h"
+
+-const string HelpDisplayWidget::helpFileName = "clustalx.hlp";
++const string HelpDisplayWidget::helpFileName = "/usr/share/clustalx/clustalx.hlp";
+
+ HelpDisplayWidget::HelpDisplayWidget(char helpPointer)
+ {
diff --git a/academic/clustalx/slack-desc b/academic/clustalx/slack-desc
new file mode 100644
index 0000000000..5b45603636
--- /dev/null
+++ b/academic/clustalx/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+clustalx: clustalx (Multiple Sequence Alignment GUI)
+clustalx:
+clustalx: A GUI interface for the ClustalW multiple sequence alignment
+clustalx: program. It provides an integrated environment for performing
+clustalx: multiple sequence- and profile-alignments to analyse the results.
+clustalx:
+clustalx:
+clustalx:
+clustalx:
+clustalx: References: /usr/doc/clustalx-$VERSION/References
+clustalx: Home: http://www.clustal.org/