summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Nicky Chorley2011-11-16 00:38:48 +0100
committer Robby Workman2011-11-26 16:08:08 +0100
commit309849837aeb406008317c5abd330576be9b5d70 (patch)
treebf38f5e6d8a523f1ada74bd5d1c2c261b9eecf60 /academic
parent4aec71273805e086edcbc9ffa48a58b80edf98a7 (diff)
downloadslackbuilds-309849837aeb406008317c5abd330576be9b5d70.tar.gz
academic/pyfits: Added (a Python extension for working with FITS files)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/pyfits/README5
-rw-r--r--academic/pyfits/pyfits.SlackBuild56
-rw-r--r--academic/pyfits/pyfits.info10
-rw-r--r--academic/pyfits/slack-desc19
4 files changed, 90 insertions, 0 deletions
diff --git a/academic/pyfits/README b/academic/pyfits/README
new file mode 100644
index 0000000000..e1881b19d9
--- /dev/null
+++ b/academic/pyfits/README
@@ -0,0 +1,5 @@
+PyFITS provides an interface to FITS formatted files in the Python
+scripting language. PyFITS is a development project of the Science
+Software Branch at the Space Telescope Science Institute.
+
+PyFITS requies NumPy.
diff --git a/academic/pyfits/pyfits.SlackBuild b/academic/pyfits/pyfits.SlackBuild
new file mode 100644
index 0000000000..1efb400684
--- /dev/null
+++ b/academic/pyfits/pyfits.SlackBuild
@@ -0,0 +1,56 @@
+#!/bin/sh
+
+# Slackware build script for PyFITS.
+
+# Written by Nicky Chorley <nick.chorley@gmail.com>, but heavily
+# based on the NumPy SlackBuild by Aleksandar Samardzic.
+
+PRGNAM=pyfits
+VERSION=${VERSION:-3.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt LICENSE.txt README.txt\
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/pyfits/pyfits.info b/academic/pyfits/pyfits.info
new file mode 100644
index 0000000000..c2fbe25f49
--- /dev/null
+++ b/academic/pyfits/pyfits.info
@@ -0,0 +1,10 @@
+PRGNAM="pyfits"
+VERSION="3.0.3"
+HOMEPAGE="http://www.stsci.edu/resources/software_hardware/pyfits"
+DOWNLOAD="http://pypi.python.org/packages/source/p/pyfits/pyfits-3.0.3.tar.gz"
+MD5SUM="0edc6f59ca291e0447032b9b72fcfb37"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Nicky Chorley"
+EMAIL="nick.chorley@gmail.com"
+APPROVED="Erik Hanson"
diff --git a/academic/pyfits/slack-desc b/academic/pyfits/slack-desc
new file mode 100644
index 0000000000..e9205177e1
--- /dev/null
+++ b/academic/pyfits/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pyfits: PyFITS (a Python extension for working with FITS files)
+pyfits:
+pyfits: PyFITS provides an interface to FITS formatted files in the Python
+pyfits: scripting language. PyFITS is a development project of the Science
+pyfits: Software Branch at the Space Telescope Science Institute.
+pyfits:
+pyfits: Homepage: http://www.stsci.edu/resources/software_hardware/pyfits
+pyfits:
+pyfits:
+pyfits:
+pyfits: