summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Vincent Batts2010-10-17 15:10:09 +0200
committer Robby Workman2010-10-18 03:16:50 +0200
commitc638ad19b1dd5d4ac103fcd7285e561d2f9fe8b0 (patch)
tree6e799f6dc20cbc25333f807e4e72376fbc4a7495 /academic
parentf3cf70a37b1f6974be332c5fb4aba707dd776ac9 (diff)
downloadslackbuilds-c638ad19b1dd5d4ac103fcd7285e561d2f9fe8b0.tar.gz
academic/genius: Updated for version 1.0.11.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/genius/README5
-rw-r--r--academic/genius/genius.SlackBuild10
-rw-r--r--academic/genius/genius.info8
-rw-r--r--academic/genius/hidden-spaces.patch23
4 files changed, 36 insertions, 10 deletions
diff --git a/academic/genius/README b/academic/genius/README
index a2187b9c00..0051b21d48 100644
--- a/academic/genius/README
+++ b/academic/genius/README
@@ -9,7 +9,8 @@ is designed to mimic how mathematics is usually written.
Definite dependencies: rarian (as scrollkeeper replacement)
is available on SBo.
-Optional dependencies: libgnomeui (available on SBo)
-if you have the optional dependencies, pass the variable
+If you would like the GUI interface as well, it requires
+libgnomeui and gtksourceview (available on SBo)
+ If you have these dependencies, pass the variable
of GNOME=YES (or anything that isn't NO ;)
diff --git a/academic/genius/genius.SlackBuild b/academic/genius/genius.SlackBuild
index 4cb0512b7b..7def2c85f6 100644
--- a/academic/genius/genius.SlackBuild
+++ b/academic/genius/genius.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for genius
-# Copyright 2009 Vincent Batts, vbatts@hashbangbash.com, http://hashbangbash.com/
+# Copyright 2009,2010 Vincent Batts, vbatts@hashbangbash.com, http://hashbangbash.com/
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
#
PRGNAM=genius
-VERSION=${VERSION:-1.0.5}
+VERSION=${VERSION:-1.0.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -32,7 +32,6 @@ if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -68,7 +67,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
@@ -77,6 +76,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Appearantly, some do not know that Makefiles require tabs, not spaces...
+cat $CWD/hidden-spaces.patch | patch -p1
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/academic/genius/genius.info b/academic/genius/genius.info
index d1387dc0db..d478e70cfe 100644
--- a/academic/genius/genius.info
+++ b/academic/genius/genius.info
@@ -1,10 +1,10 @@
PRGNAM="genius"
-VERSION="1.0.5"
+VERSION="1.0.11"
HOMEPAGE="http://www.5z.com/jirka/genius.html"
-DOWNLOAD="http://ftp.5z.com/pub/genius/genius-1.0.5.tar.bz2"
-MD5SUM="c81d70d1d17b99536293b1231211a167"
+DOWNLOAD="http://ftp.5z.com/pub/genius/genius-1.0.11.tar.bz2"
+MD5SUM="7f4fdc29237c9f68a7b2b139b7788968"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Vincent Batts"
EMAIL="vbatts@hashbangbash.com"
-APPROVED="michiel"
+APPROVED="dsomero"
diff --git a/academic/genius/hidden-spaces.patch b/academic/genius/hidden-spaces.patch
new file mode 100644
index 0000000000..64e2888387
--- /dev/null
+++ b/academic/genius/hidden-spaces.patch
@@ -0,0 +1,23 @@
+diff -uar genius-1.0.11.orig//gtkextra/Makefile.in genius-1.0.11//gtkextra/Makefile.in
+--- genius-1.0.11.orig//gtkextra/Makefile.in 2010-09-10 01:49:00.000000000 -0400
++++ genius-1.0.11//gtkextra/Makefile.in 2010-09-27 22:33:46.531620992 -0400
+@@ -800,13 +800,13 @@
+
+
+ $(srcdir)/gtkextra-marshal.h: gtkextra-marshal.list
+- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
+- && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
+- || ( rm -f gtkextra-marshal.tmp && exit 1 )
++ ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --header > gtkextra-marshal.tmp \
++ && mv gtkextra-marshal.tmp gtkextra-marshal.h ) \
++ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+ $(srcdir)/gtkextra-marshal.c: gtkextra-marshal.h
+- ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
+- && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
+- || ( rm -f gtkextra-marshal.tmp && exit 1 )
++ ( @GLIB_GENMARSHAL@ --prefix=gtkextra gtkextra-marshal.list --body > gtkextra-marshal.tmp \
++ && mv gtkextra-marshal.tmp gtkextra-marshal.c ) \
++ || ( rm -f gtkextra-marshal.tmp && exit 1 )
+
+ $(srcdir)/gtkextratypebuiltins.h: $(public_h_sources)
+ ( cd $(srcdir) && glib-mkenums \