summaryrefslogtreecommitdiffstats
path: root/academic/veusz
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2018-09-16 08:39:25 +0200
committer Willy Sudiarto Raharjo2018-09-23 01:11:51 +0200
commitbb943e3a7e604c7b2e186a27f9d31aa3a9b83a6e (patch)
treeb6ae5e6dc216ac35adc274200eedfb559569be26 /academic/veusz
parent28d5d7e9c10dd1602cf7cdbda3259512279f984e (diff)
downloadslackbuilds-bb943e3a7e604c7b2e186a27f9d31aa3a9b83a6e.tar.gz
academic/veusz: Fix build against new Qt5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/veusz')
-rw-r--r--academic/veusz/veusz.SlackBuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/academic/veusz/veusz.SlackBuild b/academic/veusz/veusz.SlackBuild
index 21c0875fa3..119648fd3d 100644
--- a/academic/veusz/veusz.SlackBuild
+++ b/academic/veusz/veusz.SlackBuild
@@ -69,6 +69,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYTHONVER=$(python -V 2>&1 | cut -f 2 -d' ' | cut -f 1-2 -d.)
+export SIP_EXE=/usr/bin/python2-sip
+export SIP_INCLUDE_DIR="/usr/include/python$PYTHONVER/python2-sip"
+
python setup.py install --root $PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \