summaryrefslogtreecommitdiffstats
path: root/academic/sword/sword.SlackBuild
diff options
context:
space:
mode:
author Tim Dickson2016-09-30 14:33:50 +0200
committer Willy Sudiarto Raharjo2016-10-01 02:17:38 +0200
commita002aa8fc073dce4d602dd1a9376547f1f9cabc2 (patch)
tree80aec633afc16716e30b32b5fd419b8c39dc4c86 /academic/sword/sword.SlackBuild
parentcbdf5e312c415fbc1313099ff323762a32b21b48 (diff)
downloadslackbuilds-a002aa8fc073dce4d602dd1a9376547f1f9cabc2.tar.gz
academic/sword: Updated for version 1.7.5a1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/sword/sword.SlackBuild')
-rw-r--r--academic/sword/sword.SlackBuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/academic/sword/sword.SlackBuild b/academic/sword/sword.SlackBuild
index 8306633a8e..c556fc5224 100644
--- a/academic/sword/sword.SlackBuild
+++ b/academic/sword/sword.SlackBuild
@@ -5,7 +5,7 @@
# Copyright 2008-2011 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
-# changes updating to v1.7.4 Copyright 2015 Tim Dickson, Scotland
+# changes updating to v1.7.5a1 Copyright 2015-20166 Tim Dickson, Scotland
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -25,13 +25,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sword
-VERSION=${VERSION:-1.7.4}
+VERSION=${VERSION:-1.7.5a1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -42,8 +42,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -61,20 +61,23 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
+#rm -rf $PRGNAM-$VERSION #line changed because source directory doesn't follow its own version number
+rm -rf "${PRGNAM}-1.7.5"
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+#cd $PRGNAM-$VERSION 'the source extracted folder is different from it's version
+cd "${PRGNAM}-1.7.5"
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
-exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-#these patches don't appear to be needed for slackware 14.1 but
-#have been left in the package just in case someone descovers they are required.
-#patch -p1 < $CWD/curl.patch
-#patch -p1 < $CWD/multimap.patch
+#now patch the automake stuff so it doesn't error on slackware's newer version
+#thanks to aur.archlinux.org for the information
+#sed -i 's/AM_INIT_AUTOMAKE$/AM_INIT_AUTOMAKE\(\[subdir\-objects\]\)/g' configure.ac
+sed -i 's/ftemplate-depth-25/ftemplate-depth\=125/g' configure.ac
+./autogen.sh
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -85,10 +88,8 @@ CXXFLAGS="$SLKCFLAGS" \
--disable-static \
--with-icu \
--build=$ARCH-slackware-linux
-
make
make install-strip DESTDIR=$PKG
-
mv $PKG/etc/sword.conf $PKG/etc/sword.conf.new
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION