summaryrefslogtreecommitdiffstats
path: root/academic/solfege/solfege.SlackBuild
diff options
context:
space:
mode:
author Phillip Warner2010-05-12 17:36:42 +0200
committer David Somero2010-05-12 17:36:42 +0200
commit58114d9c9b8b8fc2367526690d05814f3cc46a5f (patch)
treede3bd19200ff0ce4f9dd29afe7d01c2575f35676 /academic/solfege/solfege.SlackBuild
parentc89d983f11fdf4b81a3fdf1fe6428ece51d216a8 (diff)
downloadslackbuilds-58114d9c9b8b8fc2367526690d05814f3cc46a5f.tar.gz
academic/solfege: Updated for version 3.14.4
Diffstat (limited to 'academic/solfege/solfege.SlackBuild')
-rw-r--r--academic/solfege/solfege.SlackBuild24
1 files changed, 16 insertions, 8 deletions
diff --git a/academic/solfege/solfege.SlackBuild b/academic/solfege/solfege.SlackBuild
index 8939aa8926..4f1a9f7e6b 100644
--- a/academic/solfege/solfege.SlackBuild
+++ b/academic/solfege/solfege.SlackBuild
@@ -4,7 +4,7 @@
# Written by Phillip Warner <pc_warner@yahoo.com>
PRGNAM=solfege
-VERSION=${VERSION:-3.10.4}
+VERSION=${VERSION:-3.14.4}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -16,10 +16,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -37,25 +40,30 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# fix Makefile.in so python scripts will compile correctly
-patch -p1 < $CWD/Makefile.in_fix.patch
-
-# This Makes mpd imports work correctly in case python-mpd is installed
-patch -p1 < $CWD/python-mpd_fix.patch
+# Fix Makefile.in so it does not require txt2man
+# We will copy over our own man page
+patch -p1 < $CWD/Makefile.in_fix_${PRGNAM}${VERSION}.patch
CFLAGS="$SLKCFLAGS" \
CPPFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--mandir=/usr/man
CFLAGS="$SLKCFLAGS" make
+
+# We either had to install this or txt2man
+cat $CWD/solfege.1 > $TMP/$PRGNAM-$VERSION/solfege.1
+
make install DESTDIR=$PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
( cd $PKG/usr/man