summaryrefslogtreecommitdiffstats
path: root/academic/papi
diff options
context:
space:
mode:
author Davidson Francis2016-12-30 01:24:28 +0100
committer Willy Sudiarto Raharjo2016-12-31 02:22:17 +0100
commit0808bb9e40f4e83f693af3f79b84272a3ac904cb (patch)
treea92915c10df26623eca73161b715bc6c15579fa3 /academic/papi
parent2966ffd6f17d15c9ee6cecb7ee51dadd2507b5ab (diff)
downloadslackbuilds-0808bb9e40f4e83f693af3f79b84272a3ac904cb.tar.gz
academic/papi: Added (Performance API).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/papi')
-rw-r--r--academic/papi/README11
-rw-r--r--academic/papi/papi.SlackBuild103
-rw-r--r--academic/papi/papi.info10
-rw-r--r--academic/papi/slack-desc19
4 files changed, 143 insertions, 0 deletions
diff --git a/academic/papi/README b/academic/papi/README
new file mode 100644
index 0000000000..efebdf834e
--- /dev/null
+++ b/academic/papi/README
@@ -0,0 +1,11 @@
+papi (Performance Application Programming Interface)
+
+PAPI provides the tool designer and application engineer with a
+consistent interface and methodology for use of the performance
+counter hardware found in most major microprocessors. PAPI enables
+software engineers to see, in near real time, the relation between
+software performance and processor events.
+
+In addition, PAPI provides access to a collection of components that
+expose performance measurement opportunites across the hardware and
+software stack.
diff --git a/academic/papi/papi.SlackBuild b/academic/papi/papi.SlackBuild
new file mode 100644
index 0000000000..9d42f2f398
--- /dev/null
+++ b/academic/papi/papi.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/sh
+#
+# Slackware build script for papi.
+#
+# Copyright 2016 Davidson Francis, Minas Gerais, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=papi
+VERSION=${VERSION:-5.5.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION/src
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --with-static-lib=no \
+ --with-shared-lib=yes \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cd ../
+cp -a ChangeLog* INSTALL.txt LICENSE.txt papi.spec README* RELEASENOTES.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/papi/papi.info b/academic/papi/papi.info
new file mode 100644
index 0000000000..42d8c1de7b
--- /dev/null
+++ b/academic/papi/papi.info
@@ -0,0 +1,10 @@
+PRGNAM="papi"
+VERSION="5.5.1"
+HOMEPAGE="http://icl.utk.edu/papi/"
+DOWNLOAD="http://icl.utk.edu/projects/papi/downloads/papi-5.5.1.tar.gz"
+MD5SUM="86a8a6f3d0f34cd83251da3514aae15d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Davidson Francis"
+EMAIL="davidsondfgl@gmail.com"
diff --git a/academic/papi/slack-desc b/academic/papi/slack-desc
new file mode 100644
index 0000000000..df4361148d
--- /dev/null
+++ b/academic/papi/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+papi: papi (Performance Application Programming Interface)
+papi:
+papi: PAPI provides the tool designer and application engineer with a
+papi: consistent interface and methodology for use of the performance
+papi: counter hardware found in most major microprocessors. PAPI enables
+papi: software engineers to see, in near real time, the relation between
+papi: software performance and processor events.
+papi:
+papi: Homepage: http://icl.cs.utk.edu/papi
+papi:
+papi: