summaryrefslogtreecommitdiffstats
path: root/academic/biopython
diff options
context:
space:
mode:
author Petar Petrov2021-05-18 14:43:20 +0200
committer Willy Sudiarto Raharjo2021-05-18 18:40:06 +0200
commitd8f1bb0ca5601c60bf8ca99a44ee206fcb3037f3 (patch)
tree841a38eafb10a2ecd33b53ace52a55eab2cb183a /academic/biopython
parentf1ba9aebb877959edc480c07bec94827f213b003 (diff)
downloadslackbuilds-d8f1bb0ca5601c60bf8ca99a44ee206fcb3037f3.tar.gz
academic/biopython: update for version 1.78 + fix build with python3
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/biopython')
-rw-r--r--academic/biopython/biopython.SlackBuild8
-rw-r--r--academic/biopython/biopython.info6
2 files changed, 8 insertions, 6 deletions
diff --git a/academic/biopython/biopython.SlackBuild b/academic/biopython/biopython.SlackBuild
index 22bd291d1f..70fdc87663 100644
--- a/academic/biopython/biopython.SlackBuild
+++ b/academic/biopython/biopython.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for biopython
-# Copyright 2019 Petar Petrov slackalaxy@gmail.com
+# Copyright 2019-2021 Petar Petrov slackalaxy@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=biopython
-VERSION=${VERSION:-1.74}
+VERSION=${VERSION:-1.78}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,7 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/academic/biopython/biopython.info b/academic/biopython/biopython.info
index 9906f1df81..065965da62 100644
--- a/academic/biopython/biopython.info
+++ b/academic/biopython/biopython.info
@@ -1,8 +1,8 @@
PRGNAM="biopython"
-VERSION="1.74"
+VERSION="1.78"
HOMEPAGE="https://biopython.org/"
-DOWNLOAD="http://biopython.org/DIST/biopython-1.74.tar.gz"
-MD5SUM="cead2bfe9e7be45267eba00635f68d5c"
+DOWNLOAD="http://biopython.org/DIST/biopython-1.78.tar.gz"
+MD5SUM="acb2e70be7a002108659f1856c60b123"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="numpy"