summaryrefslogtreecommitdiffstats
path: root/academic/STAR
diff options
context:
space:
mode:
author Rob van Nues2018-07-06 01:29:27 +0200
committer Willy Sudiarto Raharjo2018-07-07 01:54:17 +0200
commit7240d51d0c1534f9b7b73458b29159dee1fb6329 (patch)
tree8d13c79eb1fa4d21e8d8064bb3e33b39a5dc66e4 /academic/STAR
parentbf5695bd8d62f073d40b8750eeb6361481ff7ea9 (diff)
downloadslackbuilds-7240d51d0c1534f9b7b73458b29159dee1fb6329.tar.gz
academic/STAR: Update Script.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic/STAR')
-rw-r--r--academic/STAR/README6
-rw-r--r--academic/STAR/STAR.SlackBuild12
-rw-r--r--academic/STAR/STAR.info2
-rw-r--r--academic/STAR/reproducible.patch14
4 files changed, 13 insertions, 21 deletions
diff --git a/academic/STAR/README b/academic/STAR/README
index 3608afef93..24272d0a1f 100644
--- a/academic/STAR/README
+++ b/academic/STAR/README
@@ -1,7 +1,7 @@
STAR aligns short and long RNA-seq reads to a reference genome using
uncompressed suffix arrays, resulting in fast, accurate mapping.
-STAR is capable of unbiased de novo detection of canonical junctions,
-can discover non-canonical splices and chimeric (fusion) transcripts and
-can map full-length RNA sequences.
+STAR is capable of unbiased de novo detection of canonical splice
+junctions, can discover non-canonical splices and chimeric (fusion)
+transcripts and can map full-length RNA sequences.
Reference: https://www.ncbi.nlm.nih.gov/pubmed/23104886
diff --git a/academic/STAR/STAR.SlackBuild b/academic/STAR/STAR.SlackBuild
index aa89b2927f..d6f0453abe 100644
--- a/academic/STAR/STAR.SlackBuild
+++ b/academic/STAR/STAR.SlackBuild
@@ -63,9 +63,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# https://sources.debian.org/data/main/r/rna-star/2.6.0b+dfsg-1/debian/patches/reproducible.patch
-# (with minor modification)
-patch -p1 < $CWD/reproducible.patch
+# for using shared, externally-installed htslib (as done on debian)
+#rm -rf htslib
+# from https://salsa.debian.org/med-team/rna-star/tree/master/debian/patches
+#patch < $CWD/donotuse_own_htslib.patch
+
+# but Alex Dobin, the developer of STAR does not advise this due to hacks he made in htslib
+# https://github.com/alexdobin/STAR/issues/351
+# https://github.com/alexdobin/STAR/issues/447
+#so let's forget about this for now
cd source
diff --git a/academic/STAR/STAR.info b/academic/STAR/STAR.info
index 2ba024dafd..a5a7a64b31 100644
--- a/academic/STAR/STAR.info
+++ b/academic/STAR/STAR.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64="https://github.com/alexdobin/STAR/archive/2.6.0c/STAR-2.6.0c.ta
MD5SUM_x86_64="014e44faa78c13e781bb74d9b5cf00d8"
REQUIRES=""
MAINTAINER="Rob van Nues"
-EMAIL="rvnues { at } disroot { dot } org"
+EMAIL="sborg63@disroot.org"
diff --git a/academic/STAR/reproducible.patch b/academic/STAR/reproducible.patch
deleted file mode 100644
index f340376023..0000000000
--- a/academic/STAR/reproducible.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Description: make build reproducible
- Stops build hostname and directory from being recorded in the artifact.
-Author: Sascha Steinbiss <sascha@steinbiss.name>
---- a/source/Makefile
-+++ b/source/Makefile
-@@ -18,7 +18,7 @@
- LDFLAGS_Mac_static :=-pthread -lz -static-libgcc htslib/libhts.a
- LDFLAGS_gdb += $(LDFLAGS_shared)
-
--COMPTIMEPLACE := -D'COMPILATION_TIME_PLACE="$(shell echo `date` $(HOSTNAME):`pwd`)"'
-+COMPTIMEPLACE := -D'COMPILATION_TIME_PLACE="<unrecorded>"'
-
- CXXFLAGS_common := -pipe -std=c++11 -Wall -Wextra -fopenmp $(COMPTIMEPLACE) $(CCFLAGS_common_add)
- CXXFLAGS_main += -O3 $(CXXFLAGS_common)