summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author JW(Shinichi Abe)2022-11-19 04:06:18 +0100
committer Willy Sudiarto Raharjo2022-11-19 04:06:18 +0100
commitfd15dd31e7920bebdd97ba4390bf3088d302507c (patch)
treedbeb910c33011fc5b504d97b1e8ad72460045921
parente33b337f8bfb1916861a910e971bfe0b7c3d583b (diff)
downloadslackbuilds-fd15dd31e7920bebdd97ba4390bf3088d302507c.tar.gz
desktop/dolphin-megasync: Added (MEGAsync plugin for dolphin).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--desktop/dolphin-megasync/README4
-rw-r--r--desktop/dolphin-megasync/doinst.sh11
-rw-r--r--desktop/dolphin-megasync/dolphin-megasync.SlackBuild113
-rw-r--r--desktop/dolphin-megasync/dolphin-megasync.info10
-rw-r--r--desktop/dolphin-megasync/kf5.patch12
-rw-r--r--desktop/dolphin-megasync/slack-desc19
6 files changed, 169 insertions, 0 deletions
diff --git a/desktop/dolphin-megasync/README b/desktop/dolphin-megasync/README
new file mode 100644
index 0000000000..74918418be
--- /dev/null
+++ b/desktop/dolphin-megasync/README
@@ -0,0 +1,4 @@
+MEGAsync plugin for dolphin file manager.
+
+Dolphin-megasync uploads your files to your Mega account from Dolphin.
+You need to install MEGAsync for this plugin to work.
diff --git a/desktop/dolphin-megasync/doinst.sh b/desktop/dolphin-megasync/doinst.sh
new file mode 100644
index 0000000000..a668ea01e4
--- /dev/null
+++ b/desktop/dolphin-megasync/doinst.sh
@@ -0,0 +1,11 @@
+
+if [ -x /usr/bin/update-desktop-database ]; then
+/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
diff --git a/desktop/dolphin-megasync/dolphin-megasync.SlackBuild b/desktop/dolphin-megasync/dolphin-megasync.SlackBuild
new file mode 100644
index 0000000000..d9804bea4e
--- /dev/null
+++ b/desktop/dolphin-megasync/dolphin-megasync.SlackBuild
@@ -0,0 +1,113 @@
+#!/bin/bash
+
+# Slackware build script for MEGAsync
+
+# Copyright 2022 JW(Shinichi Abe) <shin1.abe@nifty.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=dolphin-megasync
+SRCNAM=MEGAsync
+VERSION=${VERSION:-4.7.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-${VERSION}_Linux.tar.gz
+cd $SRCNAM-${VERSION}_Linux
+
+# prepare source
+mkdir -p build
+# Apply Arch patch (Thanks to Arch)
+patch -p2 -i $CWD/kf5.patch --verbose || extit 1
+mv src/MEGAShellExtDolphin/CMakeLists.txt src/MEGAShellExtDolphin/CMakeLists.txt.old
+mv src/MEGAShellExtDolphin/CMakeLists_kde5.txt src/MEGAShellExtDolphin/CMakeLists.txt
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cd build
+cmake ../src/MEGAShellExtDolphin \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX}
+make
+
+make install DESTDIR=$PKG
+cd ..
+install -Dm644 LICENCE.md $PKG/usr/share/licenses/$PRGNAM/LICENCE.md
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+cd $TMP/$SRCNAM-${VERSION}_Linux
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CREDITS.md LICENCE.md README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/dolphin-megasync/dolphin-megasync.info b/desktop/dolphin-megasync/dolphin-megasync.info
new file mode 100644
index 0000000000..ecb9348136
--- /dev/null
+++ b/desktop/dolphin-megasync/dolphin-megasync.info
@@ -0,0 +1,10 @@
+PRGNAM="dolphin-megasync"
+VERSION="4.7.2.0"
+HOMEPAGE="https://github.com/meganz/MEGAsync/"
+DOWNLOAD="https://github.com/meganz/MEGAsync/archive/v4.7.2.0_Linux/MEGAsync-4.7.2.0_Linux.tar.gz"
+MD5SUM="b1734bf785e279dd0d01d8ff254c7587"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="JW(Shinichi Abe)"
+EMAIL="shin1.abe@nifty.com"
diff --git a/desktop/dolphin-megasync/kf5.patch b/desktop/dolphin-megasync/kf5.patch
new file mode 100644
index 0000000000..3f773ddeef
--- /dev/null
+++ b/desktop/dolphin-megasync/kf5.patch
@@ -0,0 +1,12 @@
+diff --git a/MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt b/MEGAsync/src/MEGAShellExtDolphin/CMakeLists_kde5.txt
+@@ -64,4 +64,4 @@ target_link_libraries(${MEGASYNCPLUGIN} KF5::CoreAddons KF5::KIOCore KF5::KIOWid
+
+ #install(FILES ${CMAKE_CURRENT_BINARY_DIR}/megasync-plugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR})
+ install(FILES megasync-plugin.desktop DESTINATION ${KDE_INSTALL_KSERVICES5DIR})
+-install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${CMAKE_INSTALL_LIBDIR}/qt5/plugins)
++install(TARGETS ${MEGASYNCPLUGIN} DESTINATION ${PLUGIN_INSTALL_DIR})
+
+diff --git a/MEGAsync/src/MEGAShellExtDolphin/megasync-plugin.moc b/src/MEGAShellExtDolphin/megasync-plugin.moc
+deleted file mode 100644
+index e69de29b..00000000
+
diff --git a/desktop/dolphin-megasync/slack-desc b/desktop/dolphin-megasync/slack-desc
new file mode 100644
index 0000000000..dc49fcdc2d
--- /dev/null
+++ b/desktop/dolphin-megasync/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+dolphin-megasync: dolphin-megasync (MEGAsync plugin for dolphin file manager)
+dolphin-megasync:
+dolphin-megasync: MEGAsync plugin for dolphin file manager.
+dolphin-megasync: Upload your files to your Mega account via Dolphin.
+dolphin-megasync:
+dolphin-megasync: HomePage: https://github.com/meganz/MEGAsync
+dolphin-megasync:
+dolphin-megasync:
+dolphin-megasync:
+dolphin-megasync:
+dolphin-megasync: