summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2022-11-19 03:57:36 +0100
committer Willy Sudiarto Raharjo2022-11-19 03:57:36 +0100
commitccd953ff8268068a62e5b67f98320905eb6b9b8b (patch)
treec88936f87cb613bccbc5c8e7431f10709d33ae38
parent11a6244cdf7e4c42ca4071a142e568ba052ee7af (diff)
downloadslackbuilds-ccd953ff8268068a62e5b67f98320905eb6b9b8b.tar.gz
python/networkx: Removed (split into python2/3).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/networkx/README3
-rw-r--r--python/networkx/networkx.SlackBuild102
-rw-r--r--python/networkx/networkx.info10
-rw-r--r--python/networkx/slack-desc19
4 files changed, 0 insertions, 134 deletions
diff --git a/python/networkx/README b/python/networkx/README
deleted file mode 100644
index 4c00f24f83..0000000000
--- a/python/networkx/README
+++ /dev/null
@@ -1,3 +0,0 @@
-NetworkX is a Python package for the creation, manipulation,
-and study of the structure, dynamics, and functions of complex
-networks.
diff --git a/python/networkx/networkx.SlackBuild b/python/networkx/networkx.SlackBuild
deleted file mode 100644
index e8fd700476..0000000000
--- a/python/networkx/networkx.SlackBuild
+++ /dev/null
@@ -1,102 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for networkx
-
-# Copyright 2016 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=networkx
-VERSION=${VERSION:-2.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-mv $PRGNAM-$PRGNAM-$VERSION $PRGNAM-$VERSION
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-sed -i -e 's:share/doc:doc:' setup.py
-
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE.txt INSTALL.rst CONTRIBUTING.rst CONTRIBUTORS.rst README.rst RELEASE.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/networkx/networkx.info b/python/networkx/networkx.info
deleted file mode 100644
index 2107c93ada..0000000000
--- a/python/networkx/networkx.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="networkx"
-VERSION="2.2"
-HOMEPAGE="http://networkx.github.io/"
-DOWNLOAD="https://github.com/networkx/networkx/archive/refs/tags/networkx-2.2.tar.gz"
-MD5SUM="e003e0a05bc7e008a2bc3278593c8240"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Fernando Lopez Jr."
-EMAIL="fernando.lopezjr@gmail.com"
diff --git a/python/networkx/slack-desc b/python/networkx/slack-desc
deleted file mode 100644
index a330321184..0000000000
--- a/python/networkx/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-networkx: networkx (create, manipulate and study complex networks)
-networkx:
-networkx: NetworkX is a Python package for the creation, manipulation,
-networkx: and study of the structure, dynamics, and functions of complex
-networkx: networks.
-networkx:
-networkx:
-networkx:
-networkx:
-networkx:
-networkx: