summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Fernando Lopez Jr2022-11-19 03:54:47 +0100
committer Willy Sudiarto Raharjo2022-11-19 03:54:47 +0100
commit866eca51bdcf9b9807dd21078a302ba23556ee53 (patch)
tree6577fe5dcf80fd71153ae94a76845c8d0c04b891
parent1ec05e1c6e251d89eb385559de5b3c6c60612e83 (diff)
downloadslackbuilds-866eca51bdcf9b9807dd21078a302ba23556ee53.tar.gz
python/python3-networkx: Added (manipulate/study complex networks).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/python3-networkx/README3
-rw-r--r--python/python3-networkx/python3-networkx.SlackBuild98
-rw-r--r--python/python3-networkx/python3-networkx.info10
-rw-r--r--python/python3-networkx/slack-desc19
4 files changed, 130 insertions, 0 deletions
diff --git a/python/python3-networkx/README b/python/python3-networkx/README
new file mode 100644
index 0000000000..4c00f24f83
--- /dev/null
+++ b/python/python3-networkx/README
@@ -0,0 +1,3 @@
+NetworkX is a Python package for the creation, manipulation,
+and study of the structure, dynamics, and functions of complex
+networks.
diff --git a/python/python3-networkx/python3-networkx.SlackBuild b/python/python3-networkx/python3-networkx.SlackBuild
new file mode 100644
index 0000000000..d746f7f47b
--- /dev/null
+++ b/python/python3-networkx/python3-networkx.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/bash
+
+# Slackware build script for networkx
+
+# Copyright 2016 Fernando Lopez Jr. <fernando.lopezjr@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-networkx
+VERSION=${VERSION:-2.8.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+SRCNAM=networkx
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e 's:share/doc:doc:' setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CONTRIBUTING.rst INSTALL.rst LICENSE.txt README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-networkx/python3-networkx.info b/python/python3-networkx/python3-networkx.info
new file mode 100644
index 0000000000..eb6e74773a
--- /dev/null
+++ b/python/python3-networkx/python3-networkx.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-networkx"
+VERSION="2.8.8"
+HOMEPAGE="http://networkx.github.io/"
+DOWNLOAD="https://github.com/networkx/networkx/archive/refs/tags/networkx-2.8.8/networkx-networkx-2.8.8.tar.gz"
+MD5SUM="df9398c5db11589f20e72668f3e1760f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Fernando Lopez Jr."
+EMAIL="fernando.lopezjr@gmail.com"
diff --git a/python/python3-networkx/slack-desc b/python/python3-networkx/slack-desc
new file mode 100644
index 0000000000..af6cad16cc
--- /dev/null
+++ b/python/python3-networkx/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-networkx: python3-networkx (create, manipulate and study complex networks)
+python3-networkx:
+python3-networkx: NetworkX is a Python package for the creation, manipulation,
+python3-networkx: and study of the structure, dynamics, and functions of complex
+python3-networkx: networks.
+python3-networkx:
+python3-networkx:
+python3-networkx:
+python3-networkx:
+python3-networkx:
+python3-networkx: