summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Andrew Clemons2021-07-25 08:14:05 +0200
committer Willy Sudiarto Raharjo2021-07-25 11:56:07 +0200
commit72f78b3ea00d7a880b17a07c5bab13eb4a5cb103 (patch)
tree43f2e075402f0953228ac3fda229a930e90f3b9d
parentae87f355db6d7ba14874345d94ca9816217c5cb9 (diff)
downloadslackbuilds-72f78b3ea00d7a880b17a07c5bab13eb4a5cb103.tar.gz
python/tweepy: Updated for version 3.10.0.
This is the last version to support python 2.7. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/tweepy/README4
-rw-r--r--python/tweepy/tweepy.SlackBuild16
-rw-r--r--python/tweepy/tweepy.info6
-rw-r--r--python/tweepy/update_req_for_pip6.patch21
4 files changed, 7 insertions, 40 deletions
diff --git a/python/tweepy/README b/python/tweepy/README
index baa2c40a68..37e660511b 100644
--- a/python/tweepy/README
+++ b/python/tweepy/README
@@ -1,7 +1,3 @@
tweepy (Twitter python library)
Tweepy is a python library for accessing the Twitter API.
-
-If you want to build this for use with Python 3.x (needs the optional
-dependency python3) pass the script PYTHON3=yes, like
- PYTHON3=yes ./httplib2.SlackBuild
diff --git a/python/tweepy/tweepy.SlackBuild b/python/tweepy/tweepy.SlackBuild
index b5d8a1dbd7..7d2acbcb2c 100644
--- a/python/tweepy/tweepy.SlackBuild
+++ b/python/tweepy/tweepy.SlackBuild
@@ -24,14 +24,14 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tweepy
-VERSION=${VERSION:-3.1.0}
+VERSION=${VERSION:-3.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -63,12 +63,9 @@ else
LIBDIRSUFFIX=""
fi
-PYTHON=python
-[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
-
DOCS="CHANGELOG.md CONTRIBUTORS LICENSE README.md"
-set -e
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
@@ -83,13 +80,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# https://github.com/tweepy/tweepy/issues/533
-patch -p1 < $CWD/update_req_for_pip6.patch
-
-# we have six=1.8.0 and requests-oauthlib=0.4.2, so we cheat
-sed -i -e "s|1\.7\.3|1.8.0|" -e "s|0\.4\.1|0.4.2|" requirements.txt
-
python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/tweepy/tweepy.info b/python/tweepy/tweepy.info
index 34a6a874c4..6ccc82dbde 100644
--- a/python/tweepy/tweepy.info
+++ b/python/tweepy/tweepy.info
@@ -1,8 +1,8 @@
PRGNAM="tweepy"
-VERSION="3.1.0"
+VERSION="3.10.0"
HOMEPAGE="http://tweepy.github.com/"
-DOWNLOAD="https://github.com/tweepy/tweepy/archive/v3.1.0.tar.gz"
-MD5SUM="358e750d6f865ebe83dbb2bc6e9235f4"
+DOWNLOAD="https://github.com/tweepy/tweepy/archive/v3.10.0/tweepy-3.10.0.tar.gz"
+MD5SUM="53f490178cf718bc2e70567a268caae7"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="requests-oauthlib"
diff --git a/python/tweepy/update_req_for_pip6.patch b/python/tweepy/update_req_for_pip6.patch
deleted file mode 100644
index 0214819549..0000000000
--- a/python/tweepy/update_req_for_pip6.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 2de2d05..3b3b807 100644
---- a/setup.py
-+++ b/setup.py
-@@ -1,6 +1,6 @@
- #!/usr/bin/env python
- #from distutils.core import setup
--import re
-+import re, uuid
- from setuptools import setup, find_packages
- from pip.req import parse_requirements
-
-@@ -14,7 +14,7 @@ if mo:
- else:
- raise RuntimeError("Unable to find version string in %s." % (VERSIONFILE,))
-
--install_reqs = parse_requirements('requirements.txt')
-+install_reqs = parse_requirements('requirements.txt', session=uuid.uuid1())
- reqs = [str(req.req) for req in install_reqs]
-
- setup(name="tweepy",