summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Luis Henrique2010-06-30 04:23:47 +0200
committer Robby Workman2010-06-30 04:23:47 +0200
commit409a1e3b6fca1ce1aa900aa89efdf041d640659f (patch)
tree1b626cdbba10fc613f4c23cdd14b4639c762d6f5
parent8ddac80dd633d32ae7262b3fb2f00b8c52c177b9 (diff)
downloadslackbuilds-409a1e3b6fca1ce1aa900aa89efdf041d640659f.tar.gz
audio/rubberband: Added (tempo/pitch changing utility)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
-rw-r--r--audio/rubberband/README4
-rw-r--r--audio/rubberband/libdir_x86_64.diff19
-rw-r--r--audio/rubberband/rubberband.SlackBuild80
-rw-r--r--audio/rubberband/rubberband.info10
-rw-r--r--audio/rubberband/slack-desc19
5 files changed, 132 insertions, 0 deletions
diff --git a/audio/rubberband/README b/audio/rubberband/README
new file mode 100644
index 0000000000..e5b4d907cb
--- /dev/null
+++ b/audio/rubberband/README
@@ -0,0 +1,4 @@
+Rubber Band is a library and utility program that permits you to change
+the tempo and pitch of an audio recording independently of one another.
+
+This requires libsndfile, vamp-plugin-sdk, and ladspa_sdk.
diff --git a/audio/rubberband/libdir_x86_64.diff b/audio/rubberband/libdir_x86_64.diff
new file mode 100644
index 0000000000..fa01d83678
--- /dev/null
+++ b/audio/rubberband/libdir_x86_64.diff
@@ -0,0 +1,19 @@
+diff -Nur rubberband-1.5.0.orig//Makefile.in rubberband-1.5.0/Makefile.in
+--- rubberband-1.5.0.orig//Makefile.in 2010-05-02 14:06:05.000000000 -0500
++++ rubberband-1.5.0/Makefile.in 2010-06-29 21:15:03.253114720 -0500
+@@ -28,11 +28,11 @@
+
+ INSTALL_BINDIR := @prefix@/bin
+ INSTALL_INCDIR := @prefix@/include/rubberband
+-INSTALL_LIBDIR := @prefix@/lib
+-INSTALL_VAMPDIR := @prefix@/lib/vamp
+-INSTALL_LADSPADIR := @prefix@/lib/ladspa
++INSTALL_LIBDIR := @prefix@/lib64
++INSTALL_VAMPDIR := @prefix@/lib64/vamp
++INSTALL_LADSPADIR := @prefix@/lib64/ladspa
+ INSTALL_LRDFDIR := @prefix@/share/ladspa/rdf
+-INSTALL_PKGDIR := @prefix@/lib/pkgconfig
++INSTALL_PKGDIR := @prefix@/lib64/pkgconfig
+
+ all: bin lib $(PROGRAM_TARGET) $(STATIC_TARGET) $(DYNAMIC_TARGET) $(VAMP_TARGET) $(LADSPA_TARGET)
+
diff --git a/audio/rubberband/rubberband.SlackBuild b/audio/rubberband/rubberband.SlackBuild
new file mode 100644
index 0000000000..bacaab500d
--- /dev/null
+++ b/audio/rubberband/rubberband.SlackBuild
@@ -0,0 +1,80 @@
+#!/bin/sh
+
+# Slackware build script for rubberband
+
+# Written by Luis Henrique <lmello.009@gmail.com>
+
+PRGNAM=rubberband
+VERSION=${VERSION:-1.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fixup libdir on x86_64
+[ "$ARCH" = "x86_64" ] && patch -p1 < $CWD/libdir_x86_64.diff
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG COPYING README.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/rubberband/rubberband.info b/audio/rubberband/rubberband.info
new file mode 100644
index 0000000000..f20f537c20
--- /dev/null
+++ b/audio/rubberband/rubberband.info
@@ -0,0 +1,10 @@
+PRGNAM="rubberband"
+VERSION="1.5.0"
+HOMEPAGE="http://www.breakfastquay.com/rubberband"
+DOWNLOAD="http://code.breakfastquay.com/attachments/download/1/rubberband-1.5.0.tar.bz2"
+MD5SUM="c5f288d644fcd46bd159e187bcc33f25"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Luis Henrique"
+EMAIL="lmello.009@gmail.com"
+APPROVED="rworkman"
diff --git a/audio/rubberband/slack-desc b/audio/rubberband/slack-desc
new file mode 100644
index 0000000000..6ba0493e40
--- /dev/null
+++ b/audio/rubberband/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+rubberband: rubberband (audio time-stretching and pitch-shifting)
+rubberband:
+rubberband: Rubber Band is a library and utility program that permits you to
+rubberband: change the tempo and pitch of an audio recording independently of one
+rubberband: another.
+rubberband:
+rubberband: Homepage: http://breakfastquay.com/rubberband
+rubberband:
+rubberband:
+rubberband:
+rubberband: