summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis2022-06-27 15:07:12 +0200
committer Willy Sudiarto Raharjo2022-07-02 04:55:44 +0200
commitd4d75ea63f5601f51c5c52dd399ed2e3fc38581e (patch)
tree60c3baa67900fe70e3a820c9b5598903dde8b9e1
parent61c32133465cfa1e5d17bf03b04e7154724b77b1 (diff)
downloadslackbuilds-d4d75ea63f5601f51c5c52dd399ed2e3fc38581e.tar.gz
system/slpkg: Updated for version 4.1.3.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/slpkg/README41
-rw-r--r--system/slpkg/doinst.sh7
-rw-r--r--system/slpkg/slack-desc10
-rw-r--r--system/slpkg/slpkg.SlackBuild20
-rw-r--r--system/slpkg/slpkg.info8
5 files changed, 25 insertions, 61 deletions
diff --git a/system/slpkg/README b/system/slpkg/README
index 5828dd8d0e..94145cfd3e 100644
--- a/system/slpkg/README
+++ b/system/slpkg/README
@@ -1,36 +1,5 @@
-Slpkg is a powerful software package manager that installs,
-updates, and removes packages on Slackware based systems.
-It automatically computes dependencies and figures out what
-things should occur to install packages. Slpkg makes it easier
-to maintain groups of machines without having to manually update.
-Slpkg works in accordance with the standards of the organization
-slackbuilds.org to builds packages. Also uses the Slackware Linux
-instructions for installation, upgrading or removing packages.
-
-What makes slpkg to distinguish it from the other tools;
-The user-friendliness it's a primary target as well as easy to
-understand and use, also use colours (by default) to highlight
-packages and display warning messages, and many of the others
-available options it's ready to use.
-
-Features
-
-* Dependencies resolutions
-* Dependencies visualizations
-* Multiple options
-* Multiple repositories
-* Easy configuration
-* Fully configurable
-* Adaptability
-* Powerful options
-* Source builder
-* Faster process
-* Better Security
-
-Optional dependencies:
-
-* python3-pythondialog (for dialog box interface)
-* pygraphviz (for drawing dependencies diagram)
-* graph-easy (for drawing ascii dependencies diagram)
-* aria2 (alternative downloader)
-* httpie (alternative downloader)
+Slpkg is a software package manager that installs, updates and
+removes packages on Slackware-based systems. It automatically
+calculates dependencies and figures out what things need to
+happen to install packages. Slpkg makes it easier to manage
+groups of machines without the need for manual updates.
diff --git a/system/slpkg/doinst.sh b/system/slpkg/doinst.sh
index 67244ee97e..c07a4c6ffb 100644
--- a/system/slpkg/doinst.sh
+++ b/system/slpkg/doinst.sh
@@ -8,11 +8,8 @@ config() {
fi
}
-CONFIGS="slpkg.conf repositories.conf blacklist slackware-mirrors \
- default-repositories custom-repositories rlworkman.deps pkg_security"
-for file in $CONFIGS; do
- config etc/slpkg/${file}.new
-done
+config etc/slpkg/slpkg.yaml.new
+config etc/slpkg/blacklist.yaml.new
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
diff --git a/system/slpkg/slack-desc b/system/slpkg/slack-desc
index 9eebd74623..e9abbc7cd9 100644
--- a/system/slpkg/slack-desc
+++ b/system/slpkg/slack-desc
@@ -8,11 +8,11 @@
|-----handy-ruler------------------------------------------------------|
slpkg: slpkg (Slackware Packaging Tool)
slpkg:
-slpkg: Slpkg is a powerful software package manager that installs, updates
-slpkg: and removes packages on Slackware based systems. It automatically
-slpkg: computes dependencies and figures out what things should occur
-slpkg: to install packages. Slpkg makes it easier to maintain groups of
-slpkg: of machines without having to manually update.
+slpkg: Slpkg is a software package manager that installs, updates and
+slpkg: removes packages on Slackware-based systems. It automatically
+slpkg: calculates dependencies and figures out what things need to
+slpkg: happen to install packages. Slpkg makes it easier to manage
+slpkg: groups of machines without the need for manual updates.
slpkg:
slpkg: Homepage: https://dslackw.gitlab.io/slpkg
slpkg:
diff --git a/system/slpkg/slpkg.SlackBuild b/system/slpkg/slpkg.SlackBuild
index 7d2dd7ae8c..43e0a704bf 100644
--- a/system/slpkg/slpkg.SlackBuild
+++ b/system/slpkg/slpkg.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=slpkg
-VERSION=${VERSION:-3.9.8}
+VERSION=${VERSION:-4.1.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -81,26 +81,24 @@ find -L . \
python3 setup.py install --root=$PKG
+mkdir -p $PKG/usr/sbin
+cp bin/slpkg $PKG/usr/sbin/slpkg
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/etc/slpkg
-# install configuration files
-CONFIGS="slpkg.conf repositories.conf blacklist slackware-mirrors \
- default-repositories custom-repositories rlworkman.deps pkg_security"
-for file in $CONFIGS; do
- install -D -m0644 conf/$file $PKG/etc/slpkg/${file}.new
-done
+install -D -m0644 configs/slpkg.yaml $PKG/etc/slpkg/slpkg.yaml.new
+install -D -m0644 configs/blacklist.yaml $PKG/etc/slpkg/blacklist.yaml.new
-# keep original configuration file for reset
-cp -p conf/slpkg.conf $PKG/etc/slpkg/slpkg.conf.orig
+mkdir -p $PKG/usr/man/man1
+cp man/slpkg.1 $PKG/usr/man/man1
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.md ChangeLog.txt LICENSE ISSUES KNOWN_ISSUES REPOSITORIES.md \
- INSTALL.md requirements.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst ChangeLog.txt LICENSE.txt requirements.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/slpkg/slpkg.info b/system/slpkg/slpkg.info
index d9990d1581..dfeb1fa5f3 100644
--- a/system/slpkg/slpkg.info
+++ b/system/slpkg/slpkg.info
@@ -1,10 +1,10 @@
PRGNAM="slpkg"
-VERSION="3.9.8"
+VERSION="4.1.3"
HOMEPAGE="https://dslackw.gitlab.io/slpkg"
-DOWNLOAD="https://gitlab.com/dslackw/slpkg/-/archive/3.9.8/slpkg-3.9.8.tar.gz"
-MD5SUM="41b3f4f0f8fb8270e3b03abd2c73be2c"
+DOWNLOAD="https://gitlab.com/dslackw/slpkg/-/archive/4.1.3/slpkg-4.1.3.tar.gz"
+MD5SUM="49a8716cd964bcbac26938907051d7c0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="SQLAlchemy"
MAINTAINER="Dimitris Zlatanidis"
EMAIL="d.zlatanidis@gmail.com"